My interlocutors hear me very badly - Modem calls & MMS / 4G issues

Hello, I’ve noticed that a lot of people I talk to say they can’t hear me very well (as if I were far away).
However, I don’t block the microphone, and I have updated (some time ago) the firmware of the BM818 EU modem to the following version:

M100E_YCSN0_1.0.0_220926 YCSN0_M100E_1BAD_3117_V1.0.0.2_20220930 M100E_1.0.4_200715
VoLTE enable is checked

I also sometimes get the impression that I’m losing the 4G connection even though the icon is enabled and there’s no orange exclamation mark on it (e.g.: Firefox cannot open webpage, then I need to reboot the phone). Ditto for MMS: despite a good APN configuration in Settings and Chatty, I can’t receive or send any MMS.

Do you also get this kind of feedback from your contacts, or these connection/MMS problems with your modem? What’s your version?

Thank you very much!

I can hear the other party clearly, but they can only hear garbled noises from me. I did receive an MMS image when I was testing it, so it does work, but I have not been interested in setting it up again. I have also updated my modem firmware to the latest version, and use the BM818-A1.

I got the Librem 5 USA for the hardware kill switches to block out everyone else, so I have no interest in troubleshooting my “issues”. I only have a phone number because many businesses and institutions require it. If I could use them without requiring a phone number, I would, as I have persistently attempted to do so for the last few years already.

Have you tried testing the microphone out by making a recording? That could help figure out if its a mic issue or modem issue.

As for the loss if 4G signal without an indicator, I believe it is a known bug. It has happened to me before and there are a few others who have posted the same.

I think I see this as well. Especially when using the Librem 5 as hotspot. But maybe, this is when I observe it easier, because I’m using the data connection then more extensively. I use ping to determine if the 4G connection is really gone, and often indeed it is gone.

Thank you all for your feedback. I see I am not alone.

@FranklyFlawless same here, I speak maybe 3 or 4 minutes, then it starts to be unclear to my interlocutors while I hear them well. This can be a problem if you need urgent talk.

@Sarcasmo220 good remark. I don’t think it is related to the microphone. This works well sometimes, and it is not a cut-off issue but like I am very far away.

@janvlug sometimes, I am reading RSS feeds, first article does work, then I lose connection. So I check on Firefox : no more connection (while the 4G icon is blue with multiple bars). This is really strange. I have tried to update the modem firmware yesterday, but the version above is the latest one.

Maybe the team is aware about this issue, I hope

1 Like

That’s why I thought it would be a good idea to test the microphone. The input (microphone) volume can be adjusted in settings, but it would be good to test it on a recording so you have an idea how much higher the volume needs to be adjusted and how it sounds.

1 Like

Same issue here. I can hear the other party clearly, but I come across as muffled with an echo, the echo delayed by several seconds. I have been in contact with support over this.

I was told to try turning down the microphone volume,(analog modem setting) under Sounds to about 50% (from 100%). The 100% setting was the default, as I never played with this setting before.

I am still trying this out, but the other parties are saying they can hear me a little better now. Still needs some work on my part to fine tune this setting.


For starters, reset your audio settings to defaults:

sudo rm -rf /var/lib/alsa/librem5*.state ~/.config/pulse
sudo reboot

50% for microphone is too high. By default it’s at 41% (0dB).

1 Like

Thank you for your kind support. I have checked the sound settings :

  • before running your commands, microphone was ~40%
  • then I have run your above command (no output, no error message)
  • then after reboot, I still have the exact same microphone level (~40%)

Yes, same thing happening here: icon says 4G (without warnings), but there is no connection. Think it happens after wakeup from suspend.

There’s a lot of other settings than can influence audio than mic volume, so please do a test after resetting them.

Same thing here. This has been happening for a long time.

Resetting the audio settings has eliminated the echoing (apparently), but the the audio outbound from the L5 seems to be overly low-pass filtered, as compared to the iPhone, knocking out the higher audio frequencies and making the audio a bit more difficult to listen to. Is this how the L5 is designed or is it just my unit?

Depends. If your call goes through 3G or even 2G, it’s not going to sound the same as via 4G due to different audio codecs used on those networks.

1 Like

My expectations were that the L5 would perform ever better when it came to the cellular and wifi connections. Specially when waking up from suspend.
It appears the contrary has happened.

After a suspend - with cellular and wifi connections on - the L5 appears to
resume normal functions. That is, judging by the icons in the top tray, at least. In reality, nothing happens when I try to load a webpage or my rss feeds. Sometimes another number is dialled then the one I picked from my contacts. People do not hear me talking, and/or I do not hear them. Etcetera
Switching off wifi seems to help sometimes. Most of the time only HKS’ing the cellular modem will work.
Lately at least the yellow exclamation mark pops up to at least indicate something is wrong. Something of an improvement, I guess.
Another thing is, that the L5 seems to only be able to find a 3G connection instead of a 4G one after a suspend. Really? In the middle of Amsterdam?!

By far the most annoying thing, though. Is the absence of a ringing noise when calling mobile numbers. I hear a phone ringing when calling landlines. But not when dialling 06-numbers. (Sometimes I only hear partial voice mail messages.)
This truely frustrating lack of feedback has been a feature of the L5 for months now, and I would have expected it to be a priorty to-do item for the development team. After all, it is a pretty basic part of being a usable phone.
Unfortunately, there has been no discernable progress in this area. I really hope this changes in the near future.

Normally I fix that visual bug by retoggling the “Mobile Data” setting off and on.

Well, my mobile data is switched on by default, not off.
And I have been removing the exclamation mark from day one by switching off and back on again the roaming function. Back then it was, as you say, merely a visual bug. And maybe/probably it still is. Because switching of the exclamation mark this way does not result in the connection being restored.

1 Like

Well my phone plan has no data whatsoever, so toggling it does nothing other than simply removing the exclamation mark.

That would make a difference, yes.

1 Like