My librem5 is dead

long story short, for a couple of months I was using my librem5 as my main device, with few problems: battery and apps, for apps I was able to solve well using waydroid.
Well a couple of days ago it started to warm up quickly, I closed all apps and disconnected the USB cable; and then did a reboot.
But from then on it wouldn’t boot, i get only a black screen.
Is there any procedure to attempt a recovery of the device? thx

First questions:

  • Does the upper right corner indicator light come on and what color is it (blinking or no) when you try normal boot with battery?
  • Have you tried booting the phone without battery (using provided charging cable) [don’t worry when the light blinks]?
  • Is the battery deformed (bulging etc.) or is there an odor (batteries may fail)?

If you use the forum search, you will find several threads that have hashed similar situations.

No, nothing; i can see only the led turn on red to indicate the charge battery when i plug the USB cable in.

yes, but nothing, i get the led turn red and blinking

the battery seems okey

Interesting. Not a quick fix then, probably.

The red indicates charging (gets external power) but there is also the possibility that it’s not getting enough power. For a check, you could try letting the phone charge for a while, before trying to boot. And if I remember correctly, L5 stops charging the battery if the heat sensor trips, so the previous charge may not have been that much. Red also indicates that something is alive.

If the phone doesn’t boot with just the cable but the light come on, I’d try to connect to it using the jumpdrive procedure next. Have you tried it before? See: That should let you see inside and let you copy any files you may want to save (also, lets you take a back up of the whole disk, in case you do the next bit). If there is some filesystem fault, you could also use it to re-flash your phone. Jumpdrive will also tell, if there is more serious faults (like, say, with the screen, as it would display a message there about jumpdrive).

Battery could maybe be dead even if it seems ok. But let’s assume for now, that it’s good.

Of course, you always have the option of contacting support via email.

1 Like

Have you tried turning it on in a dark room?
Occasionally I have it all the the way dim and it looks blank in the light.:man_shrugging:


Good point. One of the recent (month?) updates seemed to dim the screen lightness setting (I may remember wrong) and if it’s low enough, it might only seem to be faulty. There probably should be safety feature to prevent that on a power-on screen.

if the phone is still under warranty be sure to contact Purism support.

one thing I might do since it seems to have died right after it got hot, is to take the back cover off remove battery and inspect the device. maybe remove some screws, etc. see if there are any burning smells and look for any signs of heat related damage. Anything melt or looks to have charred, etc.

If nothing else, for me it seems like when I take things apart and put it back together it starts working again :slight_smile:

I guess I will contact the assistance

1 Like

Tried it now, but get nothing.

1 Like


You can do the following:
First, power supply unplugged, push the power button for 30 seconds (keep it pushed)
If nothing happens, you can try to let the phone charge at least 30 min (if not already done) and try again
If nothing happens, open the back of the phone and unplug the battery (keep it out of the phone), then plug the power supply and try again
If the phone power up, you can plug back the battery
If nothing happens well seems a good choice

1 Like

Lil’ late on this, but I once thought that my phone or battery died.

(Haven’t read all of the posts here, so apologies if I missed important info)

Whenever I push/hold the power button, a red light may pop up but then returns to an off state. Then no matter how many times I’ve press the on button, it stays “dead.”

Everytime this happens, I pull off the back, take out and back in and try the power button again. If it’s just the red light, then dead state, then repeat the process.

It shouldn’t take many tries to get power on for good again, but that’s if it has enough battery juice to keep it powered.

Don’t know if this helps, but it works for me.

1 Like