My Phosh experience feedback on a Debian Intel Tablet

Hello, I have a Debian on a x86_64 (AMD64) tablet :
HP Pro 608 G1 with Intel Atom x5-Z8500 and 4GB of RAM
and I installed Phosh on it aside with GNOME Wayland.

The installation is very simple, just open a terminal and type the following command:
sudo apt install phosh
Enter your password, let it install, reboot the tablet and when you enter your session password, click on the wheel and choose Phosh instead of GNOME. And that’s it!

Phosh is impressively responsive, and it’s very ergonomic for a tablet compared to GNOME 3.38. But I did encounter some shortcomings that I’d like to share with you. Knowing that Purism works mostly on the Librem 5, I didn’t want to spam their git with issues. I hope that we could find some solutions here:

  1. some untimely session restarts that I suspect are related to screen rotation when I force a little too fast (like in a row: go to app launcher > open settings > go back to app launcher > switch to portrait mode > right away type a text > switch back to landscape mode, etc.). But in normal use, I didn’t notice this phenomenon too much.
    -> Have you seen this kind of problems?

  2. Some important settings in the Settings application or GNOME Tweak are not kept: so you have to reset after each reboot.
    Is there a workaround (e.g. a command on the terminal) to make the following settings permanent?
    -> enable touch keyboard (because it is disabled at each reboot, so there is no keyboard button on the bottom bar)
    -> maximize/minimize buttons, etc. (because disabled at every reboot)

  3. because of the above mentioned problem, the window management can sometimes be mismanaged (overflows the screen and you can’t crop it).
    Is there a workaround (e.g. a command on the terminal) to make the following settings permanent?
    -> Maximize window opening by default
    -> change the resolution of Firefox (debian package) which opens with a too big zoom level (the Flatpak version of Firefox does not have this scaling problem).

  4. when locking, you have to unlock a code… PIN. Which I never set because I have a user password. I did not find in the settings how to disable PIN unlocking and if the screen locks: impossible to unlock > mandatory reboot.
    Is there a workaround (for example a command on the terminal) to remove this PIN code?

  5. the automatic screen rotation mode is missing: you have to slide the notification bar and choose the portrait or landscape mode manually.
    Is there a workaround (e.g. a command on the terminal) to set up automatic screen rotation?

Thanks a lot for your help.


For both 2 & 3, I have found a workaround : a script. The issue I have is that a @reboot cronjob does not work (I don’t know why, I suspect it works before login). So I have “workarounded” the workaround by using a desktop file which launch a script, and adding this destop file as startup application in Gnome Tweak tool.
The script (let’s call it in the location /home/tablet) shall contain the following content :

sleep 1 && gsettings set sm.puri.phoc auto-maximize true && gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled true

Then the desktop.file (let’s call it phosh_setup.desktop in location /usr/share/applications/) shall contain the following content :

[Desktop Entry]

Then go to Gnome Tweak Tool > Startup applications > and chose phosh_setup

About number 4, it seems to be a know issue that is work in progress.

About number 5, @fralb5 is true : I have phosh 0.8 version (there is no 0.10 version available yet). I hope it will be fixed then.


Look at what “sudo journalctl -b” says for around the time when that happened, probably there is some error messages then saying phosh was “killed” and/or something about “segmentation fault” or “assertion failure” or similar, that could help explain what went wrong. If phosh crashes then I think the developers will want to know about it, so creating an issue at might be a good idea, especially if you find a way to reliably reproduce the crash.

1 Like
  1. phosh -U makes it start without PIN, I don’t know if you can start with a real password
  2. I think auto-rotation came with version 0.10.1, is it the version you have ?

Thank you all, I have updated my 1st post with a workaround and some purism progress.

1 Like