[MyL5] First impressions and first problems


In bulk my first impressions about the Librem5 and the problems I encounter (I have already solved some of them thanks to the PURISM forum and to the excellent automatic translator DeepL which allows me to write in English…). My others nicknames are “patou” and « xpf » (on another sites probably…)

First of all, I must say that I don’t regret my purchase at all, but I was immediately very disappointed by my debut with it. It still lacks a lot of software specifically adapted for it. An important update “Byzantium” should be released soon, which should solve a lot of problems… Let’s wait… Maybe the buyers of the next batch, in the 4th quarter, will inherit a perfectly tuned device…

Its biggest current handicap, in my opinion, is its slowness to start up. I regularly count 15 seconds before the little green light appears to indicate that the device is turning on. It takes another 10 seconds to get to the first screen and type in the first unlock code and another 10 seconds to type in two other codes (PIN for the SIM and another code to unlock the Librem5). Boasting about the Librem5 to your friends on the basis of such a “performance” seems to me very counterproductive… I couldn’t import my thousand contacts correctly: only the email addresses were imported. I had to copy the phone numbers by hand … only to find that I could not initiate a call by clicking on the numbers… I had to add “+33” in front of each complete number (including the 0 at the beginning). I also have other problems that I will list in a future message … after lunch. Have a good lunch ! And see you later…

Hello again, I don’t know (or rather I don’t know anymore) what the first code is. For me it’s simply the unlocking of the device. The 3rd code, I understand less. I will try to make a copy of the message on the screen that asks for this code.

Here are the problems I’m facing:
-1) I formatted in ext4 on my Linux computer (with GParted) the additional 128GB memory card I was using on my previous Android-lineage smartphone, but I can’t write anything on it anymore, in this case the data that were on it before and that I had saved on the computer. As a result, the memory card appears in the Librem5 tree but I can’t write to it either.
-2) I can’t remove “Mirage”, an application installed not from the PureOS repository but with “apt install” -3) I can’t get “Maps” and “Midnight Commander” to work and GParted doesn’t launch.
-4) Could we install and use GDebi?
-5) I don’t know how to make a backup. When I launch the Backup application, I get the following message: “BackendException: Could not initialize backend: No module named gi.repository” ???
-6) The alarm of the application “Clocks” did not ring this morning…
-7) How to increase the sound in general on the device? (By the way, I would like to point out that the sound was very good)
-8) The contacts appear on the screen after a very (too) long time after launching the “Contacts” application
-9) The battery is very quickly down


Have you tried this command?
sudo apt remove mirage

Is Clocks able to wake up the system? It’s worth filing a bug report about it if that is the problem.

You can install gdebi:
sudo apt install gdebi

The question is whether phosh is configured to open .deb files with gdebi as the default and whether gdebi has libhandy classes in the code to make it adaptive.

To increase the audio volume try using this command:


Thank you Amosbatto !

Other problems encountered:
10) The screen resolution for applications not optimized for the Librem5 does not allow them to be used or not easily. There is a “Scale Screen” application that is part of the “Goodies” pack for the Librem5, which allows you to change this resolution, but it does not stay on after the device is turned off. It must therefore be reactivated after each start-up. You can’t “zoom” on the screen with two fingers.
11) The virtual keyboard does not allow you to lock it in the “Caps” position. The beginnings of sentences (after the dot that ends the previous sentence) do not automatically begin with a capital letter, it must be activated. Finally, you cannot access an accented letter by holding down the letter on the keyboard: you have to press another key to access the “catalog” of all accented letters.
12) There is no possibility of creating Contact Groups, which is very useful for group mailings.
13) It does not seem to be possible to order batteries separately from a smartphone, for security reasons during transport.

Hello again Amosbatto

The removal of Mirage and the installation of GDebi worked well. Thank you!

I will give the result of a future attempt to install an application with GDebi when it comes up.

Thanks again,

1 Like

How did you import your contacts? I know you said it didn’t work properly, but I could not find any option to import contacts at all, even though I was looking for one. I ended up inputting contacts completely manually.

Also, thanks for tipping me off to the existence of DeepL, which I hadn’t found when looking for new machine translation services.

Patch : I import my contacts with « Contacts Importer », which is a part of « Librem5 Goodies », which is in the PureOS repository.

1 Like
1 Like

My Android takes much longer to start! Lol!

Could this be GNOME Keyring, which stores all the passwords you create for applications?

sudo apt purge mirage …?

The flatpak works well.

Pure Maps (flatpak) works well, also. PureMaps (flatpak) on the L5


It is possible…

What was your order date, the date of the mail asking for the modem, verify address etc. and the shipping date? Thx.

1 Like

sudo apt purge gparted

Looks like that you prefer GUI. After apt install --no-install-recommends partitionmanager (this program belongs to KDE), sudo authentication should work, if all dependencies there (works on Mobian, you might try this, perhaps helps).

After creating an alarm and closing the edit screen, you then have to select the saved alarm for it to become active. It’s a repeating buzz.

Edit: The Alarm settings panel may have changed since the initial Evergreen release last November. I tried it out just now and I see that it now selects the newly created alarm automatically. Works for me.