[MyL5]: first impressions

You might have to contact Purism for more diagnostic expertise.

Thanks, I wrote them yesterday

We are checking this information with some of the Librem 5 developers to
check if there is any further test that we can do.

Did you already check this one here to rate your user experience?

Thanks! I did

Quick update: still no news on the SD thing (I got some reply from the purism support, but no fix yet).
Regarding random reboots, I’ve not had any in those days.

I also tried a couple of games (the usual supertuxkart and animatch) and they work really well. Overall, the experience is quite nice (far from perfect or at least at pair with an android phone, but we’re on the right track)


Update: Purism support said it might be an hardware problem and will replace it since it’s under warranty. In one day they sent me the “return label”, so I just had to put the phone back in its shipping box along with its accessories, went to the postal office with the return label and that’s it (I’m in Europe and the phone is being sent to Germany. Since it’s a replacement, I won’t have to pay for customs again). Purism support is great, now let’s hope the new/fixed phone is shipped fast.

To quickly delete personal data, I removed .config, .cache, Music/Documents/Downloads, .local/share and few others, plus I removed some of the installed app.

Side note: I’m back to the pinephone, which feels slower but hey, at least I didn’t erase data on it.


The operating system really ought to provide this function, not as a high priority, but eventually.

Even the iPhone has this function - you just have no way of knowing whether it really does what it says. :frowning:

simply deleting/removing data on the phone does NOT guarantee that it can’t be recovered/restored …

1 Like

Yep, neither formatting. And on flash disks tools like shred won’t work, so actually it’s quite impossible to safely erase data on the phone without rm+fill free space

So it should be crytoblob (eg for cryptoloop) with self-destruct capability (scramble the data and remove itself)

I hope L5 in the future will support FDE, as pmOS on the pinephone already does

True, up to a point.

In theory, yes. In practice, not as bad as that.

In fact, if you have some kind of erase at the disk firmware level, it actually is possible to safely erase data. The problem is, with closed source disk firmware, you have no idea whether the disk does what it says it does - which is why open source operating systems prefer to rely on secure erase functions that they themselves implement - and create an unsolvable problem.

I believe it is coming.

L5 also already does, with both PureOS and pmOS and I believe Mobian as well. We just don’t have it nicely integrated in a user friendly way in PureOS, but the plan is to have it ready in place for byzantium.


or you can encrypt the data you want ‘gone’ and set a super-strong, random passw/pass-phrase that you will forget about and don’t store anywhere and simply format the whole data-storage-medium afterwards …

like this :

encrypt (LUKS) > set passw > lock > format

could additionally write whole data-storage-medium with random and then with zero …

No news on the repair process. They received my phone three weeks ago, last time I wrote to purism they told me that they were “waiting to receive some spare parts”. I’ll ask them again this week

1 Like

Received it today, they said they would have fixed it, but it seems a new unit: it came with the screen protector and no sign of my previous usage. I can confirm that this time the SD card reader is working :slight_smile:


And yet another SD card slot update. Today it stopped working. Symptoms are the same as before:

fdisk -l /dev/sda
fdisk: cannot open /dev/sda: No medium found

gnome-disks: Drive is present, but under volumes it says: No Media.

I tried the uSD card on another machine and it is working, and I tried
again with the other 3 uSD I had around and none of them did work.

I just reported this again to purism support

edit: on the flip side the camera preview in the megapixel app is working :smiley: yay

1 Like

Did you by any chance remove or insert the SD/SIM tray while the phone was on?

Nope, since when I got the working unit I never had the need to change the uSD nor the SIM, so the tray was always left inside

Yes I did that today and the phone restarted. I placed the SIM with uSD card back in and since then I have no cellular signal.