[MyL5] I received my Librem 5 Evergreen


I received my Librem5 yesterday, I’m located in Austria, my Reddit thread was already mentioned in this forum.


After some, well, let’s call them starting issues I’m finally very happy with the phone. I’ve tried some linux based phones before, but thats the first one that feels like real Linux as I love it.

Big thanks goes out to Purism for making this real, I really appreciate the hard work you put into this!

At this point I want to mention a strange issue I had with the Librem 5 at the beginning.

Some of the first things after booting it up and get through the startup assistant was to update the phone by using apt on the shell. Stangely apt at this point failed to download all the information from the repos and with an upgrade tells me that some packages can not be verified. At this point I stopped to upgrade and got straight to reflashing the phone with the latest image https://developer.puri.sm/Librem5/Development_Environment/Phone/Troubleshooting/Reflashing_the_Phone.html.
After reflashing the phone I get through the setup steps again and this time apt works just fine, no more upgrade issues.

Because I wanted to play with the phone I sadly don’t did more research on the actual problem but as it seems it was based on some apt repo key problems. Maybe someone can put some light on this.

I’ll follow up on this post when I have used the phone for some days. If any questions feel free to ask, I’ll try my best to answer them.


I didn’t experience anything like that with mine. Maybe @dos or someone else from the Purism team can provide some insight.


Hi dale6667,

Great news about you getting your Librem 5 thats awesome.

Have you tried cellular calls yet?

Also what network are you using in Austria?

Thanks in advance


1 Like

Hi @LinuxNew,

yes I’ve tried cellular calls, they work fine (as well as SMS and mobile data). I’m using A1 as network provider: https://www.a1.net

You’re welcome!


I had a minor issue with apt on mine initially too, so maybe your issue was the same. Basically, the timezone for the phone was set to UTC. I changed the time to reflect the time in my current time zone, but forgot to change the timezone itself. This led to a timing mismatch between the time on the phone and the certificates on the Purism repo servers, so apt update and apt upgrade wouldn’t work.

Once I correctly set the timezone, everything was fine.


Any Problems with “Zoll”. How/what did you have to pay in delivery?

1 Like

Hi @taylor-williamc ,

yeah, that could indeed have been the problem. I’ve only checked the time which was correct, but not the timezone. Now the timezone is definitely correct and apt is working fine.


1 Like


No problem with customs. The customs declaration was handled by DHL, I’ve got an SMS from them that I have to provide order confirmation and payment confirmation (which took me some time, as I ordered 2017, lol).

As DHL delivered the package I’ve paid about 100 euro customs.


We’ve started this community wiki on the L5, which you may find helpful over the next few days:


Thanks @amarok, thats indeed very helpful!


Thanks for the info dale6667 thats awesome :+1:

1 Like

Thanks! I sometimes see Firefox recommended in the forum, but firefox-esr-mobile-config really needs to be installed along with it. I am glad to see these optimizations gathered in one place. Maybe someone can add Time Zone to “WiFi Connection Problems” given the problem in this topic.


Done! Thanks. :+1:


It’s supposed to be installed by default though. Is it not?


In my case I just installed firefox-esr. firefox-esr-mobile-config was installed with it.

1 Like

Any ideas on turning off the mobile config and refreshing Firefox when the phone is docked?

Congratulations! I would love to see more review from you about Librem.


I have a Birch model, and I might have installed it before it got that default or in another way. I think that I tried Iceweasel because I could not find Firefox via the GUI, which gave me Firefox without the mobile config. I do not remember if/when I switched over to the plain ESR package. I just remember that scrolling through the tabs did not work until I installed the mobile config. What I did might not be reproducible now. The software has come a long way since I first received the device.

1 Like

Oh yes, it makes sense then - firefox-esr-mobile-config is a fairly recent addition :slight_smile:


Thanks for sharing your findings.
Nice to hear that A1 works out of the box.
Which modem did you choose?

Any chance to test e.g. 3 as well with this modem?