[MyL5] Received my Librem 5, WiFi doesn't work :-(

@Skalman @dos
I remember that my date/time/time zone was initially off, but I don’t remember if I fixed it before trying to connect to WiFi or after. I seem to recall I had some intermittent connection issues in the beginning, though. Works fine now…in spite of me!


@mattnewport: The wiki page @amarok posted above was created to help people with their new device on basis of recurring questions most likely a lot of people will have.

So in case you stumble upon some points that did help you, please do not hesitate to update the wiki page or just post it here and we will do so. This wiki is a community approach and we would all appreciate if helpful knowledge is conserved.

Thank you ind advance.


I was sleeping and just woke up :smiley: But I see Sebastian already replied.

I thought you might be sleeping. :wink:

Can you share the date on which you had placed the order / supported the project back in 2017?

I’m in Canada and I ordered August 24th 2017.


I am in Canada too and waiting for my Librem 5. By the way, are you using Telus, Bell or Rogers?

I’m currently using a pre-paid SIM from Speakout (7-11’s pre-paid service). It works for texts and I was also able to make and receive calls although initially that wasn’t working, not sure what changed that made it start to work.


i know this is about L5 but on my Librem-Mini-v1 the first thing i do when i get to desktop after a clean install is :

sudo apt autoremove --purge ntp and then i enable time-syncronization briefly and then turn it off in the GUI. PureOS Byzantium

Hi mattnewport awesome news you have your phone working, what are cellular calls like using the SIM card?

Is the sound quality good or not so good?

Any other issues with calls via the SIM card?

Thanks in advance


1 Like

I just tested calling my other phone, couldn’t really judge the sound quality with the two phones next to each other. I can try calling someone else later.


I’ve just received mine. I set correctly date and time and apparently it connect to the WiFi, but it keeps disconnecting, I spent two hours to add an email account. Is there any other trick?

See here:

Take the date/time settings off automatic and use manual. Make sure you also select your time zone. You can return it to automatic after you get everything running.

1 Like

Yes, I did everything as suggested, but my connection is pretty unstable … unusable.

Do you set your SSID to “hidden” on your router? That caused issues for me.

Are you using MAC filtering?

1 Like

Nope, I can see the name of my network on the WiFi setting. And no, I’m not using MAC filtering

It’s probably best to email Support at this point then.

I’m assuming you don’t have problems connecting any other devices…?

1 Like

Of course I can connect any other device. Luckily the phone works with mobile data. I’ll contact the support. Thanks

1 Like

You may want to take off the back cover and tighten the screws that cover the wifi module and cellular modem a bit (but don’t overtighten). That pressure helps keep the wifi card from shifting around (along with a tab that stops the wifi card from sliding out once it’s pressed all the way down).

If that doesn’t work, you may want to remove that cover (TURN THE PHONE OFF FIRST!) so that you can visually inspect the antennas going to the WiFi card. Sometimes they don’t snap cleanly into place–a good test is to attempt to rotate them a bit, if they are snapped in place they should rotate, otherwise attempting to rotate them will cause them to fall off. Then of course add the cover back and tighten it, before you power the phone back on.


The screws were tight enough in my opinion. Also the antennas were snapped in place … I pushed a little bit to be sure. Unfortunately the phone keeps disconnecting :frowning_face: