[MyL5] Received my Librem 5, WiFi doesn't work :-(

I received my Librem 5 Evergreen today, was excited to get it up and running. I’m unable to connect to any WiFi networks though which limits what I’m able to do with it pretty majorly (using a SIM with no data plan at the moment).

Lots of visible networks show up but I’m unable to connect to any of my home networks. No errors, just enter the password and it never connects.

I’ve tried restarting the phone a few times and turning the WiFi kill switch on and off but nothing seems to work. Anyone got any ideas what the problem might be or how to fix it?


Do you by any chance have MAC filtering enabled on your router?

Edit: Welcome, by the way!


No, I don’t have MAC filtering.

I also can’t find the User Guide mentioned in the Quick Start Guide. Anyone know if that is actually supposed to be on the phone?

No, it’s online:

As of today it hasn’t been updated from Dogwood to Evergreen, but I imagine it’s applicable.


I’ll run through some points… Forgive me if they seem like elementary questions, but I know I forget to check the basics sometimes:

Is your router set to 2.4 GHz? That’s what the L5 uses.
On the L5’s WiFI settings screen, is the top toggle to the On position (to the right)?

So far, you and I are the only ones who have posted about getting their Evergreen. I received mine on Nov. 18. I know it took a little while to understand the settings.
Maybe Support Technician @joao.azevedo can chime in here…

Jackson in the Librem 5 Matrix channel has also reported getting his. I don’t know if you have a Matrix account, but that is another place to post some questions. Not to mention a lot of the Purism support posts there as well.

You could try putting it really close to your wireless access point/router in case it has trouble with signal strength.

I think I also had to reboot my router the first time…but then it’s bipolar.

After you do get connected, be sure to install updates; some good fixes came out in the last few days. You can do that from inside the PureOS store or from the Terminal.

Yep, the top toggle is set to on. One router has two networks, a 2.4GHz and a 5GHz and the Librem 5 can see both of them but connection fails to both. The other router supports both 2.4GHz and 5GHz but only displays as a single network on any device, not sure what mode it’s using. The Librem 5 can see it but again fails to connect. I also tried my phone in WiFi hotspot mode and same issue.

In all cases I see a message flash by very briefly at the top of the screen under “Wi-Fi” where it says “Connecting” for a while and then flashes up too quickly for me to read but something like “Connection failed - IP configuration…” and then more text that is cut off.

There’s a lot of WiFi networks visible from my location so there may be some interference but I haven’t had an issue connecting with any of numerous other devices (Android phones, iPhones, Windows phones, Macs, PCs, game consoles, Raspberry Pis, Neato robot vac…).

I wonder if it would help if you rebooted the router while the phone’s WiFi is enabled to connect automatically (with your network name, password, and security type all enabled).

Can you share the date on which you had placed the order / supported the project back in 2017?

1 Like

I do have a Matrix account. I’ve asked on the community forums and someone suggested checking my date and time were set correctly which they weren’t. Setting them manually fixed it!


Something else to try: open the terminal app and enter this command:

sudo journalctl -b | grep wlan0

that should give you a bunch of output with log entries related to wifi. For comparison, on my Librem 5 Birch I get something like this (here I cut out parts of it and replaced by access point name by “ABC”):

NetworkManager[454]: <info> wifi-nl80211: (wlan0): using nl80211 for WiFi device control
NetworkManager[454]: <info> device (wlan0): driver supports Access Point (AP) mode
NetworkManager[454]: <info> manager: (wlan0): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/3)
NetworkManager[454]: <info> device (wlan0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
NetworkManager[454]: <info> device (wlan0): set-hw-addr: set MAC address to [...] (scanning)
wpa_supplicant[457]: nl80211: Could not set interface 'p2p-dev-wlan0' UP
wpa_supplicant[457]: nl80211: deinit ifname=p2p-dev-wlan0 disabled_11b_rates=0
wpa_supplicant[457]: p2p-dev-wlan0: Failed to initialize driver interface
NetworkManager[454]: <info> sup-iface[0xaaaaee200980,wlan0]: supports 4 scan SSIDs
NetworkManager[454]: <info> device (wlan0): supplicant interface state: starting -> ready
NetworkManager[454]: <info> device (wlan0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
NetworkManager[454]: <info> device (wlan0): Activation: starting connection 'ABC' [...]
NetworkManager[454]: <info> device (wlan0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
NetworkManager[454]: <info> device (wlan0): set-hw-addr: reset MAC address to [...] (preserve)
NetworkManager[454]: <info> device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
NetworkManager[454]: <info> device (wlan0): Activation: (wifi) access point 'ABC' has security, but secrets are required.
NetworkManager[454]: <info> device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
NetworkManager[454]: <info> sup-iface[0xaaaaee200980,wlan0]: wps: type pbc start...
NetworkManager[454]: <info> device (wlan0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
NetworkManager[454]: <info> device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
NetworkManager[454]: <info> device (wlan0): Activation: (wifi) connection 'ABC' has security, and secrets exist.  No new secrets needed.
NetworkManager[454]: <info> device (wlan0): supplicant interface state: ready -> inactive
NetworkManager[454]: <info> device (wlan0): supplicant interface state: inactive -> scanning
wpa_supplicant[457]: wlan0: SME: Trying to authenticate with [...] (SSID='ABC' freq=2412 MHz)
kernel: wlan0: authenticate with [...]
kernel: wlan0: send auth to [...] (try 1/3)
NetworkManager[454]: <info> device (wlan0): supplicant interface state: scanning -> authenticating
wpa_supplicant[457]: wlan0: Trying to associate with [...] (SSID='ABC' freq=2412 MHz)
kernel: wlan0: authenticated
kernel: wlan0: associate with [...] (try 1/3)
NetworkManager[454]: <info> device (wlan0): supplicant interface state: authenticating -> associating
kernel: wlan0: RX AssocResp from [...] (capab=0x411 status=0 aid=6)
wpa_supplicant[457]: wlan0: Associated with [...]
wpa_supplicant[457]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
kernel: wlan0: associated
wpa_supplicant[457]: wlan0: CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-99 noise=9999 txrate=1000
NetworkManager[454]: <info> device (wlan0): supplicant interface state: associating -> associated
NetworkManager[454]: <info> device (wlan0): supplicant interface state: associated -> 4-way handshake
wpa_supplicant[457]: wlan0: WPA: Key negotiation completed with [...] [PTK=CCMP GTK=CCMP]
wpa_supplicant[457]: wlan0: CTRL-EVENT-CONNECTED - Connection to [...] completed [id=0 id_str=]
systemd-networkd[281]: wlan0: Gained carrier
kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
NetworkManager[454]: <info> device (wlan0): supplicant interface state: 4-way handshake -> completed
NetworkManager[454]: <info> device (wlan0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "ABC"
NetworkManager[454]: <info> device (wlan0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
NetworkManager[454]: <info> dhcp4 (wlan0): activation: beginning transaction (timeout in 45 seconds)
NetworkManager[454]: <info> dhcp4 (wlan0): dhclient started with pid 943
dhclient[943]: DHCPDISCOVER on wlan0 to port 67 interval 7

after that follow more lines related to DHCP including a DHCPREQUEST line where it asks for a specific IP address, but probably in your case something goes wrong earlier. If you could run that command, look through your output and see at what point it differs from the above, that might give some clues.

It can look messy on the small screen but you should be able to scroll up by dragging, hopefully being able to look through the whole output.

5GHz networks should also work on the Librem 5 (they do for me at least :slight_smile: )


Date time fix did the trick, just installed the OS update and all seems to be working so far.


Thanks. I didn’t know that.

You might also want to browse the community wiki for tips we’ve been adding along the way:


You can mark this thread Solved if you you want, to help other users.

1 Like

So it’s this issue:

@amarok in your case, it was not necessary to set the date manually to get WiFi working?

1 Like