[MyL5] Update process is broken

After I managed to flash the phone to Byzantium, I put it away for 2 weeks. I turn it on today and try to update everything through the Pure Store app. It tells me

-Unable to download updates: The following packages have unmet dependencies.-

But it doesn’t show me what those dependencies are. So I try to update it from terminal and while that updated most of the packages some are still stuck and not updating.

The following packages have been kept back: Librem5-base, Librem5-gnome-base, Librem5-non-gnome, Linux-image-Librem5 0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

Does anyone know why this is happening. I thought the updating process on linux was solid. I guess not.


Debian is solid. I had this problem once, years ago on Mint, then once on Mobian Phosh last year. I forgot the details, so I did a quick search to refresh my memory and found this on Tech Republic:

sudo apt update  
sudo apt install aptitude
sudo aptitude safe-upgrade

This command will not remove any packages unless they are unused and will install the kept-back software.

Note: Edited to correct typo (“apt” vs. “aptitude”) and to account for the fact that most users probably do not already have aptitude installed.

I get

E: Invalid operation safe-upgrade

Yeah, you would, because I did a Sierra-Tango-Papa… “sudo apt safe-upgrade” should be “sudo aptitude safe-upgrade”. Since you likely don’t have aptitude installed, you would need to do so first.

sudo apt install aptitude

Mea culpa. @Quarnero was kind enough set me straight. I do appreciate it, as I sometimes get ahead of myself – not a good thing to do when giving advice to others! :grimacing:


Just because I agree that sudo aptitude safe-upgrade is very well thought out framework, as kindly recommended from your side:

@Photon, I see your advice as solution to this thread already (even before @Poseidon read your above post).

Such kind of upgrading to the latest of linux-image-librem5 Kernel version requires (and is nothing new) this repeated procedure (after apt update) as such upgrade, other than to minor or major Kernel revision (But what do the other digits mean here?) is much more complex and needs to be executed on top (as one more/additional full-upgrade step) of the latest PureOS official software (from official repo) regular/daily upgrade, as some kind of “standalone” upgrade related to the new/latest officially released Kernel only.

PureOS maintainers did just great job, as usual, but this time only difference is that individual/final user needs to prepare his/her Linux installation for the apt full-upgrade before proceeding with such (new distribution related) commands:

EDIT: @Photon, please correct/edit (just once replace apt with aptitude) your first post here as you wanted to have it initially.


Not at all! I’d define your initiative here as pure dialog. Very nice gesture actually in order to resolve someones issue, temporal one/solvable. Thanks therefore!

1 Like

I had the same on L5 and Mini, solution as above. Reported it in the Chat, as the PureOS Store should have been able to do the update.
@dos tried to replicate it with a recent image, but didn’t get the same problem.
Maybe it’s only when starting with an older image. Which one did you flash?

1 Like

Correction/Edit complete!

1 Like

That worked now. Thanks however some packages were removed. Like megapixels is no longer on my phone. And I cannot find it in the store. Is that meant to happen?


Apparently yes.

Megapixels was replaced with another application by Purism. I don’t recall the name exactly (Millipixels?), but it was covered in several other threads here.

1 Like

Well excuse my ignorance but I don’t spend every day reading this forum. I have a day job and other things to do.

1 Like

That’s sort of funny, but I apologize. What I meant to say was that I was too busy with my job and other things to go into detail or find the links, but that you will find them if you look. No disrespect intended. :grin:

Actually, I’m still stuck on Megapixels on my Pinephone and I can’t find the replacement in the Mobian repository, so I’ll just have to be patient.