Navigation experiences requested

Did you ever try to navigate with your Librem 5?

  1. Did you get a decent GPS fix?
  2. What navigation program did you use?
  3. Can you give a short description of your experience?

For me:

  1. My Librem 5 cannot get a decent GPS fix. I’m in contact with helpful Purism support to try to check the antenna connection.
  2. I tried PureMaps and GNOME Maps, both give a rough location (probably not based on GPS, but on other location hints. GNOME Maps does not fit well on the screen and seems unable to use the current location as navigation starting point.
  3. I cannot use the Librem 5 for navigation because of lack of a good GPS fix. First I have to check the antenna connection to see if this is hardware related.
  1. Still have no L5 to try it with.
  2. Last time I tried a navigation program, I used a Brunton compass and a map.
  3. It was 1983 and I got lost in a parking lot.

I can get a fix with an accuracy of 3m. It could take quite a long time to get a fix, sometimes it seems to be enable to get a fix even outdoors.

I tried GNOME Maps

In it current state, I found GNOME Maps barely usable for navigation:

  • It doesn’t disable blank screen nor lock screen (however you can do it manually in Settings)
  • I didn’t find how to make the map follow my position so the current position goes out of the screen quite quickly
  • It doesn’t fit well on the screen
  • I cannot use addresses from contacts

You can start navigation from current position by clicking on your current location and then the navigation icon


My new Librem 5 Evergreen jumps wildly on the Gnome map tool from place to place every 5 or 10 seconds or so, and ends up sticking in China!, or half way around the globe from where I am. This is unacceptable behavior. Getting the map back to where I am is a tedious and time consuming annoyance. If it’s that bad then I’ll have to carry paper maps in the car to work from. … or my iphone.

I’ve tried adjusting the geoclue configuration (in /etc/geoclue/geoclue.conf), by switching on and off (true and false) geo-location sources, and it seems that the NMEA information source is what is putting me in China.

But even with that disabled, I still am left a thousand miles away at what appears to be the home of a network somewhere in LA or out in the desert where there is probably a network hub.

It would be helpful to have a more clear description of how geoclue is working internally, but so far I can’t find this, short of trying to study it’s source code which is over my head.

I’ve also installed the geoclue-2-demo package which installs the /usr/libexec/geoclude-2.0/demos/where-am-i command to manually be able to test geoclue.

What would be more helpful was some way for geoclue to report a verbose description of how it is arriving at it’s results.

In searching for help on this failing geo location issue, it’s not a new issue, but rather about 2 or 3 years old. Also there are those who appear to not want this to work at all. It seems that some people want the Librem 5 for privacy (encryption), and others also want it for anonymity (staying anonymous). …And those who want to keep their location secret need a way to disable this feature to locate you on a map. As it is, I suspect that this geo location problem has not been fixed because there are those who don’t want it fixed. Hope I’m wrong.

But at least for me I bought the L5 because it provided switches to turn on or turn off one’s ability to have privacy and/or anonymity, not because it was limited to one way or the other, but because it was capable of being private and capable of being anonymous if in the future I wanted those features.

I do hope this map location issue gets fixed and that it doesn’t take another 2 or 3 years to get that fixed.

For what it’s worth, on my laptop under Debian Gnome Maps locates me fairly close to where I am and is stable and doesn’t jump to China, LA or the California desert. I’m pretty sure it’s not using any cell signal for one.

The GPS on my L5 is accurate - once it has made up its mind where it is.
I think the speed with which it settles on a proper position has improved over the last couple of weeks. But I do not have extensive data on that.

I tried Gnome Maps, but found it lacking.
Pure Maps is much much better. It works very well when I cycle. I will try it in my car shortly.

Only qualm: PureMaps should work on their use of color, specially when it comes to fonts. When the L5 uses a dark theme, the text in PureMaps - being black and blue - is utterly unreadable. How much work can it be to correct that?

1 Like

But my L5 does still exhibit the jumping behaviour; in my case between my actual location and somewhere in another city 80km from here.
But it doesn’t jump as often as it did in the beginning.

And just when I thought things had improved…
I went out grocery shopping just now. Took my L5 with GPS on, and PureMaps running.
Bloody thing kept pointing to my house (10 meter or so margin) all the way; did not move whatsoever. I would say GPS is still not working as it should.

Same experience, most of the time, for me. PureMaps is a huge improvement over Gnome Maps, however. I have tried everything. Once PureMaps located me on GPS it works very well.

Exactly. When it works, it is as good as any phone out there. But often I don’t even try because it is too much of a hassle to get it working. It just takes too long before you can get on the road.

I still don’t have my L5 (although last week I have received and replied to the address confirmation email; by the way, the support team at Purism has been extremely helpful and patient with my questions about the additional parts to be ordered, thanks again!) but first thing I would do if my GPS misbehaved would be installing an app such as Satellite so I could better understand what the problem is: does the phone see any satellites at all? If so, does it see enough of them as to get a fix? Is their signal strong enough to get and update a fix when I am moving? I guess that would help me to better understand why the GPS is behaving randomly; maybe you guys have already tried that, but that’s where I would start. If GPS is not working properly, navigation is not going to be a pleasant experience…

1 Like

Does not work on Librem 5 (yet).

Today I gave it a try on the road. In the car.
Driving by car from Amsterdam to Fontainebleau, smack in the middle of Paris on the Peripherique, I switched on the GPS and started up PureMaps.
The map indicated I was still at home for about 10 to 15 minutes, then it switched to my actual location.
Of course that is way too long, but it did find me without stuttering from that moment on.
Not too bad.

1 Like

That is really good to hear. This kind of affirms my suspicion that my Librem 5 has a hardware issue, which I think was more common in the early deliveries. Maybe the time has come to take the risk and check the antenna connection.

  1. Gnome Maps isn’t very usable overall, but gives a decent enough looking GPS fix considering I am inside, about as accurate as I would expect to get on another phone.
  2. When using Google Maps in Firefox ESR, the GPS fix is not accurate at all for some reason. When I first tried it it would always point to someplace in China, and today it was much better, but still pointed to some place several kilometers away.

A bit of a mixed bag from Fontainebleau, France. We were in the woods today for some bouldering.
I am happy to say that the gps figured out are position in the forrest within minutes (5 to 10). And it followed our walk pretty much spot on.
Except for one or two episodes (lasting a few minutes each) when it seemed to get stuck and tried to refind its footing. (This was in the open, not with trees overhead.) It would re-initialize on the spot it got stuck on (showing a wider ring around the location indicator), hesitate some more, and then jump to the actual location again.
So, a bit of a mixed bag. But, all and all, not too bad.


Some bouldering

I hope you secured that Librem 5 well! :rofl:

Sure! In a bumper case (which offers so-so protection) and wrapped in a sweater. :grin::+1:


Hello. I gave in and installed PureMaps via Flatpak. When it works, it works great. However, I have spent a lot of time lately playing with the geoclue.conf file at etc/geocle/geoclue.conf. There is a post about this file but I am too lazy to find it and link to it.

Long story short, I experimented with every GPS source in that Geoclue.conf file. I eventually resolved, last night, to turn every GPS source “on” via the “true” command in the file.

Also, and I believe this is important, I allowed Firefox browser to have access to all GPS information. Yes, yes, I know: privacy concerns. Do this at your own risk. You know what also?: the GPS works a lot better now. It works in Firefox. It works in PureMaps. I have navigation in my car now. I can use if for navigation for hiking, etc. I am happy. For now.

Caveat: I just finally discovered this last night. Might it break today or sometime in the future? Yes. But, I think it is important to go play with that Geoclue.conf file and see what works best for you.


I have been plowing information about GPS on the Librem 5 and I have taken the phone apart to replace the WiFi card. It is still not clear to me how to apply the hardware fix to the GPS antenna. I have been in contact with support about it, but that communication ended a couple of weeks ago after a number of “I will check with my colleagues and get back to you…” So I am now in a state where I, in fact, occassionally can get a GPS fix, but it is usually very shortlived. Nothing that could be used for navigation.