Navigation experiences requested

Just another addition to my report from France. Except for one really slow gps-response in the car, navigation on the L5 worked like charm.
It found the correct position within minutes on several occassions, and it followed our movements step by step.
It worked like a ‘normal’ smartphone, I would say. Very happy with that. :+1:


Could you please provide some examples? Your experience with GPS seems to be in another galaxy than mine…

Lately GPS and PureMaps works pretty well right now. As in, I click on it, it mostly finds my location fairly quickly. As long as I have cellular reception with Mint Mobile, it generally follows me.


By examples, i was referring to what you changed in your Geoclue.conf file.

1 Like

Just installed the latest OS update, including some new geoclue stuff.
It appears someone f*cked up something. PureMaps does not settle on my actual location any longer - it can’t even find it. It is a mile or so off, at best.

It gets stuck on the wrong location my GPS tends to indicated from day one (in another Dutch city, miles from where I actually am). I am back to day one.
Can I undo this ‘update’?

Why does the GPS have a preferred wrong "home’ spot, anyway?! It has been there since I started up the L5. I have never actually been in that location.
How can I get rid of it?! (Out! Damned spot!)


Yes, probably, but it can get complicated depending on exactly what that update was.

No! Wait! I might have spoken too soon! After half an hour or so walking the dog, and then cycling to work things seem to have settled down a bit. The dart is no longer pointing to Zoetermeer (the damn spot, and a terrible city), it started to follow me pretty precise. And now it has decided on a location a hundred meters from where I really am.
Not perfect. But not as terrible as I feared.
See how this develops.

I would still really like to get rid of that ‘default’ home spot it can’t get out of its head.
Could that be accomplished by editing the geoclue.conf file?

Maybe the damned spot is coming from where it thinks the mobile tower is. It depends on which sources of location information you have enabled in the .conf file. So if you had enabled only GPS and mobile tower information and it doesn’t yet have a fix from the GPS, perhaps it is falling back to the much coarser location estimate based on the mobile tower. I don’t think you will find the answer in Macbeth though.

1 Like

:slight_smile: The default spot it likes to settle on is about 50km from my actual location. I haven’t got the slightest clue as to why it would pick this location.

I did have a look at my geoclue.conf, though. And I noticed that the ‘modem-gps’ entry is set to ‘false’. Is this supposed to be this way? It probably is unrelated to the weird defaulting to Zoetermeer, but I do wonder why it is set this way.

Ah. Somebody answered my geoclue.conf question in another thread: it switches off the GPS antenna build into the modem. The L5 uses a seperate GNSS receiver.

Nope. I am stuck in ff’in Zoetermeer again!.

PureMaps starts on my location, but within a second in jumps to Zoetermeer (or actually Pijnacker which is a smaller municipality right next to it).
And the satellite app - from the PureOS flatpak repository - doesn’t offer a clue - no data at all.)

Sounds like everything works exactly as it should. When you have no GPS fix, all you get is location based on GeoIP, GSM cells and WiFi networks around and it’s going to be as accurate as available data is of your neighborhood in Mozilla’s database. Once you acquire a GPS fix, it gets used instead and you get a precise location.

Older version of Geoclue often misbehaved and preferred completely out-of-date GPS locations over ones more recent but from less accurate sources. This may have put you under impression that it worked better before, but it absolutely did not - for example, it kept telling me I was 1500km from the place I actually was in even though it already knew that can’t be true thanks to 3G data, just because that was the last place where the GPS module has acquired a fix a week earlier.

GPS takes time to work. It’s never instant.

1 Like

Or, as is the case with the L5, it never happens.

When the L5 gets a fix, it works accurately. But quite often it just takes way to long for it to get that far. I haven’t seen this on earlier phones. And it just isn’t very practical.

Your explanation that it reverts to an earlier known (gps) location does not seem plausibel, since the phone has never been in Zoetermeer or Pijnacker. Ever. And it does not revert to any other earlier location where it has been.
Furthermore, it picks this location each and every time as a fallback, It just seems to consistent, and too far away, for it to be attributed to inaccuracy alone.

That’s not what I said. I said that the latest update stopped reverting to an old GPS location, because it was a bug that now got fixed.

My experience is the GPS works, but geoclue does not. When I use GNSS-test or GNSS traces it works without issues. The fix is pretty fast (after the first fix). But, geoclue cannot get a fix at all (tested with where-am-i) and I experience the same issue than described above using gnome-maps. Disabling 3G, CDMA and WiFi sources in geoclue.conf avoid the jumping locations issue but provide some wrong constant location.

It should work now on up-to-date system, provided that there are no custom changes in geoclue.conf that could break it. Also, if you ever restart gnss-share you have to restart geoclue as well, otherwise it’s not going to be able to use GPS until a reboot.

There’s no need to disable other sources, it should not jump anymore when there’s a fix available.

That wasn’t clear from your message,