New Librem 13v2 won't get past Memtests: advice?

My Librem 13v2, ordered 9 months ago, arrived today, supposedly with Purism OS installed.

Am I doing something wrong, or is it not working? I’ve been trying for hours to get it to start.

  • Plug in power.
  • Start button
  • Goes straight to Memtest86 5.01 coreboot 001 screen.

I waited two hours, tests were still not completed, so then I tried to start over bypassing them.

  • Esc

New screen with option: Esc -> Boot menu. If I don’t choose anything, the memtest screen appears after about 3 seconds, and I’m back to square one.

  • Esc

Boot menu has three choices:

  1. AHC I/2: Samsung SSD 850 EVO M.2 250GB ATA-9 Hard-Disk
  2. Payload [memtest]
  3. Payload [coreinfo]

If I select 1, I get the memtest screen again, and tests start to run.
If I select 2, I get the memtest screen again, tests start to run. Again.
If I select 3, I get the “Esc --> Boot menu” screen.

So whatever I do, I end up at the memtest screen, watching tests run forever.

There’s no way I can find to skip all the tests.

There’s a way to skip the “currently running test” (Press c, 1, 2, 0), but when I repeatedly do that, after about test 9, it just starts running test 2, and then I’m skipping tests in a circle forever.

There’s a way to specify a single test, or a list of tests, but these seem to be in addition to the default tests that start running: selecting a single test this way has no effect on the currently running tests.

Can anybody suggest a way to boot into the supposedly installed Purism OS – apart from trying to reinitialize everything from USB sticks?

TMIA, |r:b:


As far as I know, memtest has no “end” – it’ll keep running forever. It’s probably some sort of mistake that you get straight into memtest from trying to boot on the disk (maybe the disk was not setup properly and it skips straight to next?) ; anyway I’m afaid your only way forward is to install the system from an USB stick.

For what it’s worth, PureOS is not pre-installed as much as it should have been setup to install itself on first boot, so this really is not much different (aside of needing an internet connection and some USB stick for the install media), give it a try :slight_smile:

Thanks, that is disappointing.
Well, I’ve installed PureOS, and now I’ve got different problems, but I’ll open a separate thread that.
Thanks and kind regards, |r:b: