New Librem 14 boot issue

I was setting up my new Librem 14 and decided to reboot it as it wasn’t showing that it was plugged in (other than the power LED). I had installed a few software packages, but nothing too radical (I thought). When I went to reboot, I inserted my Librem Key and got a message (that is now gone) that said that there was a checksum error on some file like


I selected to update the checksum (after I tried not to). Now I get:

Gpg: verify signature failed: Unknown system error
Invalid signature on exec boot params
!!! Failed default boot
New value of PCR[4]: 8a6a9….b3
!!! Starting recovery shell

I have not idea what to do.

Did you update the boot partition? This could change the checksum, but should still allow you to load.
Have you got a Boot USB?

I got a thumb drive in the box. Should I insert that and the key and boot it?

That is what I would do. What OS is on the drive?

It is no brainer to do a clean install for new device anyway and then reconfigure the Librem key.

I tried to insert the Librem key and the thumb drive that came with the laptop and it still didn’t boot.
The boot messages are as follows:

Attempting default boot…

*** Found verified exec boot params
Gpg: verify signatures failed: Unknown system error
Invalid signature on exec boot params
!!! Failed default boot
New value of PCR[4]: 8a6a….b3
!!! Starting recovery shell
~ #

It does not appear to me that you have managed to boot from the USB. What OS is on the driver?

You can type gui-init to get back to the menus from the recovery shell prompt. From there you can force a boot from the boot menu

1 Like

Factory user PIN of Librem Key should be 123456 but in my case it was 12345678, that is equal to admin PIN, so that upon my first reboot after initial boot, when I chose to re-sign the files in /boot using my Librem Key, I entered 123456 but it failed, then it started recovery shell, there I typed
then I entered the menu to re-sign, now using 12345678 and it succeeded.
The confirmation of the error in factory configuration was given by changing default PINs following the documentation:
To change PIN, you first need to type the old PIN, typing 123456 for user PIN failed to change, it worked using 12345678. For admin PIN the old value was correctly 12345678.
I ask @joao.azevedo if the error of factory configuring user PIN = admin PIN is common.