New Librem 14 Unlock luks

Brand new out of the box, went thru setup 1st time, booted correctly. Turned off, day later would not boot past the “Please unlock disk luks” Password Screen. Have tried everything 10 times, factory reset, change passwords, no passwords, help files, Wiki files, the other USB dongles that came with it, ALWAYS comes to this password screen and will not take ANY passwords including the defaults of either “123456” or “12345678”.
Bought this for wife , she is done with it. I can not use this either if I have to plug the Librem Key into it everytime I want to use it. This key will eventually breakoff or get lost.
Can someone help me get past this password screen and can I set this up to run WITHOUT the USB Librem KEY, a mandatory password to boot is no problem.
Otherwise I’ll have to return this for a refund and then back to Bill Gates who I was trying to get away from. Thx for your help I appreciate it.

the LUKS password is never the LK or TPM default, it’s whatever you set it to on first boot. The LK does not unlock the LUKS volume.

that’s exactly how Pureboot is designed to work though – the LK is used to verify the firmware on each and every boot.

You can download the standard coreboot/SeaBIOS firmware instead and flash that - then you won’t need the LK anymore. See You can download the firmware file from another device if your L14 isn’t bootable

If you don’t want a disk unlock password on boot, then you’ll likely need to reinstall the OS and deselect/not choose that option. Then you’ll just get the standard user/password login prompt only


thank you very much for this quick reply, Let me try this and i’ll post back with my results. I appreciate this help very much

Alternatively, if you do want a disk unlock password on boot (disk decryption password) but you don’t know what that password currently is then you’ll also need to reinstall the OS?

yes, that’s correct

Thx for this help. Last night I reset passwords/factory reset but could not get past LUKS Password. I followed the above link for coreboot/SeaBIOS but the file I downloaded could not be recognized because it had wrong extension, I guess.
I did see something about a “Utility” file that seemed like it did several things automatically to get me booted with SeaBIOS. but don’t know where or how to get it installed and run.

Also if I get the seaBIOS on a usb thumb drive how do I get it to run/execute?

Ultimate goal is get booted without needing the Librem Key. Down the road if I want to go back to higher security I’ll cross that bridge then.

I guess my biggest problem now is that I can/don’t have the password to the LUKS.

thx again appreciate your patience and help.

that Luks password has nothing to do with anything LibremKey related at all.
There is an optional script to use the LibremKey to unlock that password as well.
during the initial start of your Laptop you are asked for a password to encrypt your SSD.
That is what Luks is asking for.
If you forgot that password, the only option is to reinstall pureOS again no way around it.
regarding the change form pureboot to coreboot, there is a description on how to do that in the doku as well
best regards

When updating the firmware from USB via the Pureboot menu option, the file on USB needs to be a .rom. The files downloaded from Purism’s repo (either manually, or via the coreboot utility script) are zipped, though the script should unzip it and inform you to copy it to USB, then reboot and update via the Pureboot Menu

thx very helpful. I will reinstall pure OS

I’m in! I reinstalled pureOS from a USB drive and it worked like a charm. You were exactly correct, I had a password for my Librim 14 SSD that I did not remember, so the install gave me the chance to make a new one. Problem solved. I can’t thank you guys enough! Now it boots with the Librem KEY in.

Next question, what printer drivers do you use. I have an epson ET-3760 and all the drivers on the manufactures web site are for MAC or windows?

1 Like

My impression is that Epson in general is not very good with Linux. I think HP is better.

In this case though, search is your friend, and you may be OK: EPSON (ET-3760) Printer & Scanner