New Phone without SIM ; Issues with internet

I am able to connect to the wifi, get an IP address, ping via terminal both IP address and name resolve google.

But when I try and launch the web application, software updates, update time, etc nothing happens.

Is this an IP address on your local network? or an IP address on the internet? or both work?

For name resolution, is your DNS server on your local network or on the internet?

This might get the cleanest error message. What is the output from

sudo apt update

Verified that I was connected to Wireless network
Dropped to terminal and pinged google’s domain
then pinged
I was able to ping both locations
sudo apt update works fine

OK, then try

sudo apt upgrade

1 Like

Doing some updates now. after sudo apt update some addition applications that needed internet started working such as weather and the application update area. After it finishes these updates I will do the sudo apt update and report back.

Updates completed and rebooted.

Software update area is complaining of mkdirat: Permission denied.

Web browser still not working but Firefox is now installed and is working.

You would need to post the actual complete shell session output, comprising the command that you typed, any ‘good’ output, and any error message(s) such as the one you have posted.

From the sounds of it, your underlying problem sorted itself out.

Agree the base issue of internet access for various application is solved. I will close this and open alternative thread on the Purism Store.

dpkg --get-selections epiphany-browser

Now you might want to follow this reliable guide:

1 Like