New Post: App Showcase: Drawing

Doodle on a digital canvas with Drawing:


Nice, but it is much less responsive on my L5 … not a lot of fun.

1 Like

Seems performant enough.

Trying to enter a custom colour via #RRGGBB crashes the app!

Not being familiar with the app, there are things that I couldn’t work out how to do e.g. draw a rectangle, either outline or solid.

Did you install the Flatpak? I did, this could be the difference. It takes seconds for every command to be executed.

1 Like

Um. This is going to be a dumb question but how would I know? I just used the PureOS Store GUI to install it.

dpkg-query --list | grep draw
ii drawing 0.6.3~pureos+librem5.1 all Simple application to draw or edit pictures, for the GNOME desktop.

and /usr/share/applications/com.github.maoschanz.drawing.desktop

contains lines like

Exec=drawing --new-window

and which drawing gives /usr/bin/drawing which is Python3 code.

Does that answer the question??


Yes, that is the standard package.
In order to be able to install Flatpaks you have to add the Flathub repository (see here, only step 3), then you are able to chose which package install from the top right button of the PureOS Store GUI:

So, if you confirm that your installation is as efficient as the one of the App Showcase video, I’ll switch to the standard package too.

1 Like

Check the Installed tab inside the store, find the app, and click to display it. Scroll down through the app description until you see the Version.

The Drawing app currently in the store is the pureos-amber-phone version.

Additionally, if you use the search box in the store to find a package by name, if you don’t specify flatpak or native in your search, and if there are both versions available, you will see two entries for the same app in your results. Click on each one to see which version it is, flatpak or native. If only the native, or only the flatpak, is available for installation, you will see only the one entry in your search results. Click and read to see which version it is.


OK. Thanks. I hadn’t explored how to use the PureOS Store app much. However the version displayed in the PureOS Store app is just the same as that given by the dpkg-query command that I mentioned previously.

I haven’t looked at the video. However the performance of the standard package is pretty good (I had no objections to the performance - I was happy with the performance). I do recommend that you try the standard package.

However functionally there seem to be some weirdnesses that I haven’t overcome yet.

For example, I created a test drawing and saved it (all good). Then I renamed the file using the shell. Now the Drawing app’s file chooser widget won’t show the file. It also won’t display another .PNG file that I scped in from another computer. I couldn’t work out how to open a .PNG file that is not in ~purism/Pictures. The filter for the file chooser also doesn’t seem to be working. It says “All pictures” and the other filter options are blank and don’t seem to work.

So I am baffled at this stage as to how the “Open an image” file chooser works (or not).

At this stage, somewhere between the Drawing app, Python3, GTK, libhandy? and the Librem 5, the file chooser doesn’t seem to be working.

Obviously the file chooser widget is pretty important. Being able to “open” and “save” need to work!


For me, when I choose “Open an image” from the menu in Drawing, an initial list appears that includes the Pictures folder and a couple of other .png files. Down in the far left corner, there’s a small icon which triggers the file system to slide in from the left, with the usual Home, Documents, Downloads, Music, etc., directories. I’m able to open images from the other folders, not just from Pictures.

If I’m not mistaken, flatpaks don’t get updated from the terminal when using sudo apt update. I think they have to be updated from the store, so that’s one reason to check the store periodically. (Although I think some of them actually update automatically.)

1 Like

Flatpaks can be updated automatically, at least with GNOME software. Updating via terminal is as easy as flatpak update :slight_smile:


Pay attention that when you select “Open an image”, the first list you get is that of recent files, It’s not clear at all, but playing with it a bit I came to this conclusion. You have to browse to your folder in order to find the renamed file.
As regards the performances, I think the image size is key. I tested it on a 3000x4000 jpeg image ad it was desperately slow. Today I saved a test image, which by default is 600x1000, ad it worked perfectly. Perhaps the hardware doesn’t allow to manage large images.

1 Like

look at that penguin face ! it knows it’s a Chad so it has a slight smile on it’s face … LEZ GO BABY !

Excellent. That does the trick. Thanks.

1 Like

Yes. Not clear at all. That explains about 90% of my confusion. (It also may be recent files across more than just this one app ??? because it was showing me some unexpected stuff in addition to the two drawings that I created.)

I think the filter is still not working - but that isn’t a major problem.