New Post: Introducing Flatpaks on PureOS

If you are using PureOS or any other GNU/Linux distribution you’re probably already familiar with Flatpaks, but if not, here’s a short introduction: Flatpak is a convenient way to distribute apps on GNU/Linux. Read more at: Introducing Flatpaks on PureOS – Purism


Maybe it’s just me but I like links to be posted without the tracking (e.g. in this case in the query string, and in this case fairly lightweight):


Especially as clicks on such “lightweight” links are ANYWAY tracked with forum javascript, as evidenced by the little click counter after the link :smiley:


… and to an extent tracked in the web server itself. But it’s the principle of the thing, particularly in this forum.


A typo in the blog text: “pureos” needs to be --> “PureOS” in the first command, it seems (the latter remote-add uses this)

so how do you access flatpaks cant install them currently in pureos store only by adding the flathub flatpak repo. But how do you add the pureos flatpak repo?

I purged my flatpak apps and repo to see if the pureos one was a little lighter on size using flatpak remote-delete flathub which automatically uninstalls all flatpak apps and the pureos store flathub repo that i had manually added before.

But i dont see a single flatpak app shown in the pureos store.

I manually installed sudo apt install pureos-flatpak-defaults and added the remote flatpak remote-add PureOS --user but still no flatpak apps show

Try the drop down menu top right in the store app, where it says Flathub (or PureOS).

Tried that for apps i know exist as Flatpaks, e.g. Gnome Contacts app, but the only store is PureOS shown in dropdown.

Has anybody installed a Flatpak app using the PureOS flatpak added repo yet?

That is strange.

When I look back at the commands I sent in order to install the flatpak, I see:
sudo apt-get install pureos-flatpak-defaults, and
flatpak remote-ls pureos

this only shows you if remote is installed and it is in my case using flatpak remote-ls PureOS typing pureos doesnt find anything (argh i am not a fan of case sensitive prompts at all)

I see Tuba so when i search Tuba on the PureOS store app nothing is found.

In terminal using flatpak install app.drey.Warp installs, with two prompts:

  1. system/user (what should i pick?)
  2. install runtime yes/no

Too bad org.gnome.Loupe is not yet included 8) but at least now i can test out the available Flatpak Apps.

Okay. I do have the repository in my store. So, I must have done something right.

You say:

I did:

There is a slight difference there; could that be it?

figured it out wooot, in addition to the above the store plugin is needed:

sudo apt install pureos-store-plugin-flatpak will do the trick!

This should almost be a wiki entry. Any idea of difference between user/system flatpak install?

no that doesnt matter too much here

In that case, I am pretty much stumped I got it working. I only did that one command.

probably depends on whether you had used the default Flatpak repo before which i have, and after nuking it, it may have removed poureos components as well.

Flatpak feeds up scrolling is a lit slower i notice and articles cant be scolled using touch at all only the cursor buttons work. Also tuba flatpak scolling using the poureos flatpak repo is slower and more jerky than the default Flatpak. So it still needs a little polish.

User install makes the appliciation that you install only available to the user installing it.
System install makes the application system wide (i.e. to all users) available.

See here the man page.

1 Like

thanks! would that also mean other users cant access the same app, or the apps data when installed as user? and for system install every user would have access to the same app and app data? not quite sure what the use case is.

I think: System wide installed flatpak applications are available for all users and need root rights to install. User installed flatpak applications are available only for the user installing it, and installing does not need root rights. I assume multiple users could install the same flatpak application for themselves. But this would increase the needed storage.

In the Librem 5 context, I assume there is usually one user (default username is purism) which has sudo rights so the difference between user and system install is in practice not so relevant on a Librem 5.

1 Like

Is there anything I need to do getting someone reviewing my MR to publish a flatpak on your repository or has the process of submission been changed?

Gnome-Feeds aka “Feeds” will not install with PureOS Flatpak. Installation stalls at ~3% and then times out after a while. Flatpak remote Feeds install also fails, seems that resource is not available. The PureOS Flatpak app is also large ~170MB (.deb install is ~4MB).

Has anybody experienced PureOS Store Flatpak remotes not being available recently?