Newly installed Samsung nvme M2 ssd creating read-only error on Librem 15v3

good eve,

I recently had to change the nvme ssd that shipped with my Librem 15 as it was having trouble booting up. I posted an earlier post on this and decided to stick to Samsung m2 ssd as per purism support recommendation.

I purchased a Samsung 980 250gb nvme m2 ssd drive and the installation went without a glitch.

The laptop now boots up without any issue, however, every do often my screen freezes and I can get a black screen with the following errors repeated over and over:

systemd-journal:failed to write entry ignoring read-only file system

I found this askUbuntu forum thread that suggest this could be a firmware issue and that I should try to upgrade it. I followed these instructions to download and upgrade my firmware but the Samsung 980 is not listed in their download page, the 980 PRO is but its firmware does not recognise my ssd, so i am stuck.

Any ideas how to fix this?

For anyone looking to upgrade their m2 disk on a librem to the Samsung 980, the firmware update is now available and I successfully manage to upgrade the firmware on my system using the above instructions.

I will report back once I have had time to test the update fixes the fstrim error.


Unfortunately still facing the issue with the error,

systemd-journal:failed to write entry ignoring read-only file system

even after firmware upgrade. Anyone have any suggestion on how to fix the issue?

Just some random ideas:

  • disable fstrim if it is a problem (depending on whether you are using an encrypted root partition and what type of encryption you may not even want fstrim)
  • if the laptop allows two internal drives then boot from an internal drive that works and use that to test, experiment with, probe the troublesome Samsung 980.

I think the problem sequence as per the second bullet point is

  • boot disk gets an error
  • kernel remounts read-only on error
  • so nothing useful about the error can be written to any log file or journal that might shed light on what the error actually is.
1 Like

Support suggested the issue arises from a corrupt installation. Re-installed PureOS and the problem disappeared.

However, it reappeared when I suspended by laptop, unplugged it and resumed my session a few hours later. I had noticed previously that the issue was happening when resuming a suspended session.

Is it possible that the drive is just faulty?

1 Like

Still not solved my problem. I re-installed my system and it was working fine until my laptop went to auto suspend mode while inactive. Upon reactivation, the disk mounts as read-only.

yes, I am thinking it might be a disk issue. Will update this thread if I find the issue.

That, by itself, smells of faulty software.

1 Like

software or firmware you reckon?

I finally purchased a brand new Samsung SSD 980 (NVMe m2) and after a fresh install and a few hours or reconfiguring my laptop (with the power plugged in) the system crashed as the systemd log journal tried to write to a ro disk,

so given this is a brand new disk purchased from the official Samsung store, I can only imagine the issue is coming from my laptop.

Is it possible that the power supply is at fault?

almost certainly not. This is likely a bug either in the kernel or the NVMe drive firmware. I found another similar instance here:

I don’t have a 980/980 Pro on hand to test, but the 970/970 Pro have no issues from what I’ve seen. I’d probably return/exchange as there’s no telling when the issue might be resolved


Ditto. No 980 here but I have a 970 Plus and it works fine with Linux. Also have a 950 Pro in a different computer and that too works fine with Linux.


thank you for the update @MrChromebox, I will indeed return the 980 and get a 970 instead.