No 4K output with external monitor


#1

Hi there,

I’m running a librem13v4 and there is no option for 4K output over HDMI.

The website states the laptop supports 4K.

How can i get this to work?


Librem 13 v4 screen blanking issue
#2

See here please: https://tracker.pureos.net/T298


#3

So is this not a solved problem?


#4

Last time I tried this with latest PureOS on a 4K HDMI connected TV it worked right out of the gate - on a L13v2, IIRC.

Cheers
nicole


#5

Hi nicole,

I’m using 4.19.0-5-amd64 version of the kernel, apt says pureOS is up to date, i’ve tried multiple cables and still can’t get it to work =/

This monitor/cable works with my Dell XPS running Antergos at 4K.

Thanks,

Adam


#6

There are instructions on that issue how to achieve 4K. If you look at the product page, Librems support only 4K@30Hz. So add the file /etc/X11/xorg.conf.d/10-monitor.conf with the following content:

Section "Monitor"
        Identifier "HDMI1"
        # 3840x2160 25.99 Hz (CVT) hsync: 57.05 kHz; pclk: 290.25 MHz
        Modeline "3840x2160_26.00"  290.25  3840 4064 4464 5088  2160 2163 2168 2195 -hsync +vsync
EndSection

log out and start your session with Xorg instead of wayland.


#7

Hi mladen,

I do not want to use xorg, so sadly that will not work.

I guess i’m stuck at 1080p for now.

Many thanks,

Adam


#8

You can achieve 4K resolution with wayland in “weston” window manager, or another desktop environments. To reach 4K in weston, you need to install it from repository and create file ~/.config/weston.ini

[output]
name=HDMI-A-1
mode=300.00  3840 3848 3880 3920  2160 2182 2190 2196 +hsync -vsync

next, move to terminal with CTRL+ALT+F3 and write weston-launch


#9

Hi thanks for this,

Any idea if this would work with Gnome mutter?


#10

@nicole.faerber Hi, would you have any idea why PureOS doesn’t support 4K outputs by default, i noticed you commented saying it works for you. I’m running the latest packages/firmware, however it still fails :frowning:


#11

Like I said before, it is not the case that we would not support 4k@30Hz. Why this is not working with your particular setup is hard to say from remote. This may have to do with specific features (or lack thereof).

Could you e.g. connect your 4k display and try to run the xrandr command?
Maybe this tells us something (if it outputs something under Wayland).
You use the default PureOS with GNOME?

Cheers
nicole


#12

Hi Nicole,

Thanks for taking the time to reply!

I am running everything as stock PureOS, which is all up to date and also i updated coreboot via the purism scripts.

I connected the 4K display, which works on a friends Thinkpad running Fedora, but on my Purism laptop i get:

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
XWAYLAND2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 280mm x 160mm
   1920x1080     59.96*+
XWAYLAND3 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 620mm x 340mm
   1920x1080     59.96*+

So it seems to not pick up the 4K resolution over HDMI?

best,

Adam


#13

the cable must at least be HDMI 1.4 for 4k @ 30hz capability.


#14

Yes i’m using the correct cable. The setup works fine on a Thinkpad running Fedora.


#15

I actually just checked again and indeed now run into the same problem as you - only up to fullHD on the HDMI port. So I have to assume this is some sort of regression in some software part, which we now have to figure out.
Thanks for your persistence and patience!

Cheers
nicole


#16

Hi Nicole,

Thanks for taking the time to test!

I’m glad this is reproducible also, apologies to the team for causing more work /o.

If i can help in anyway, please let me know or point me to a ticket etc.

Many thanks,

Adam


#17

Just to add, I tested a fedora bootable image last night and i still can’t get more than 1080p on the display output.

So i guess this is something lower than PureOS itself?

Adam


#18

I am not sure yet - it could also be related to the kernel version for example, which would then also hit Fedora or any other at some point. I have Librem laptops in our office at hand which still do show the 4k@30Hz, I need to bisect the differences to come to the bottom of it.

Cheers
nicole


#19

I switched to using X11 today as i now have to use a QHD monitor, the issues @mladenlinked fixes my issues on X11, i hope i can get back to Wayland soon :frowning: