No full desktop trying to run PureOS live

I would like to try out PureOS, so I created a bootable USB drive with PureOS 8.0 Beta 1 (from Linux Mint 18.2, my main distro).
The checksums were OK but when I start PureOS from that USB drive I never get beyond the “PureOS” screen.
The initial boot prompt is OK, I can see an select all the options available but running the live OS doesn’t work.

I also tried PureOS 7.0 - doesn’t work either, same result.

I’m using a Lenovo W530 laptop:
The nVidia graphics card is deactivated.

What could be wrong or would have to be changed for me to try out PureOS? I’m really interested in the distro!


I’m having a similar problem running PureOS as a virtual machine in GNOME Boxes.
It was working fine for me up until last week, where it stopped working after a sudo apt upgrade. I’ve since tried downloading a fresh copy of the .iso, but I get the same results. I can select whether to boot into the live image, or just install, but trying to boot fails.

My guess is that something made its way into the update files that probably shouldn’t have, so I expect it will get fixed pretty soon, though I’m kinda surprised 7.0 also isn’t working if that’s the case.

I’ve attached a screenshot of what I see when my VM gets stuck. I gave it between 5 and 10 minutes and didn’t see it move beyond this point.

Thanks for your post!
I get a little further and then stuck:
The white bar moves all the way to the right, then PureOS appears. That’s it, no further. Very frustrating, especially because Lenovo laptops like mine are never ever a problem when it comes to running a Linux OS on them!

PureOS is fully free OS, does not have any proprietary drivers/firmware. This can easily be a reason for your troubles. You can try to boot the failsafe session, or press ESC key and watch the kernel messages output, and report here.

Hi @mladen,

I was able to boot the live install in GNOME Boxes after all, though only when removing the splash boot parameter. With splash, it gets stuck at the point in my screenshot above.
I don’t actually know much about virtualization as far as how hardware is treated, so I thought that running it as a VM meant that it wouldn’t actually see what specific hardware I have and would basically negate the fact that I have some proprietary drivers installed on the host OS (Ubuntu GNOME).

But as I indicated, previous snapshots have worked just fine, without the need to tweak boot parameters, so that still suggests to me that something got tweaked somewhere (though maybe it’s a Boxes thing and not a PureOS thing).