No internet after update


I recently upgraded my laptop from PureOS 9.0 Gnome to PureOS 10.0 KDE Plasma.

Upon finish of installation, I ran updates, installed a few programs, checked my email through Thunderbird, etc. Everything seemed fine. This morning, however, upon startup, it appears to be connecting to my internet just fine, but I cannot get anything through Thunderbird or Firefox. Thunderbird gives errors that it fails to connect to mail servers and Firefox cannot load pages. It looks like there is a very, very slow download and upload speeds when I inspect the wireless connection. But I can’t do anything.

Any help would be much appreciated. Thank you!

Okay, I’ve got updates.

I attempted to get internet through Ethernet cable. Still no luck. So, I decided to double check my GUFW setup. Yesterday, when I installed KDE, I then installed GUFW and turned it on, incoming-deny, outgoing-allow. Then I closed the app. Everything was fine until this morning when I had no internet. Anywho, I opened GUFW to see what was going on, and the firewall was turned OFF but I have no idea why it was off. I left it on. Anywho, I turned it back on and immediately my emails flooded in and all internet has been restored.

That makes no sense to me. A firewall that is turned off shouldn’t be blocking any traffic. Any ideas what’s going on here?


1 Like

Interestingly, today, again, the GUFW was off and I had no internet. So, I had to reopen the GUFW app and turn it on again. Does anybody know why that’s happening? Perhaps I’ll mark this one as solved and create a new topic for GUFW.