No ringtone - Librem 5

My phone is not on silent.
My volume is max.
The sound test works.
Under Feedback settings calls is set to full.

However, under sounds in the feedback settings if I were to open the folder there is no sound to choose from. I think what is happening is that my phone doesn’t ring because there is no ringtone file to play.

I have no idea why the files are gone or how to restore them.

You can test that or just customize your ringtone by choosing any .ogg file as ringtone (under Mobile Settings - Feedback - Sounds). Sound Converter app will make those from mp3s if needed. Or grab the original contest winners: Announcing the Librem Phone Ringtone Contest winners – Purism

1 Like

apt install sound-theme-librem5

The question would then be why the package was removed in the first place (you can check dpkg’s logs).

If that helps please consider improving the community wiki: Librem5 / Librem 5 Community Wiki · GitLab.


Wild guess: files have been removed by a fsck after crash.

I’ve had that same issue (no ringtones on incoming calls or messages) since I got my L5.

I can confirm that I have the sound-theme-librem5 package installed. But the package provides only .oga files:

And the Choose sound dialog says Sound files (ogg) in its filter drop-down list, not .oga:

Manually navigating to /usr/share/sounds/librem5/stereo (the directory that contains the .oga files) doesn’t help either:

1 Like

That seems like an oversight. What happens when you rename the file extensions to .ogg?

That doesn’t matter as those are part of the default theme. They’re used when you don’t configure anything else. If calls doesn’t ring then check the feedback setting of the calls application in the same mobile settings app too and the global setting.

1 Like

Thanks. Here’s what my Feedback screen currently looks like:

Which of those settings do I have to modify so I get an audible ringtone on incoming calls and SMS instead of just a vibration?

1 Like

What output device is used in the sound settings ?

Does it ring with a headset plugged in ?


Those settings look correct. Do you get audio on other events like alarm clock or SMS and it’s only incoming calls that’s failing?

EDIT: It seems it affects SMS as well from what you write above? If so check your audio settings in the settings app. Does the audio test button there work?


The alarm clock works with sound, but incoming calls and SMS do not.
Global setting is “On” (with a bell symbol next to it).

Output device is Speaker - Built-in Audio.

Edit: Sound test in Settings works, both left and right channel. I’m also getting sound on websites without any issues.

1 Like

To debug further you can try this:

In one terminal (terminal A) do:

killall feedbackd ; sleep 1 ; G_MESSAGES_DEBUG=all /usr/libexec/feedbackd

in another one (Terminal B) run

fbcli -E phone-incoming-call

then paste the output from Terminal A in text form here (please no screenshots as we need the whole output)

1 Like

How do I copy anything from the Terminal?
I have only Paste and Select All. I also can select by dragging, but it never seems to be copying anything.

Also been trying Ctrl+Shift+C (like the help window suggests), but that only yields ^C in the terminal, and nothing is copied. I’m feeling pretty stupid, but here we are. Any clues?

1 Like

CTRL+SHIFT+C copies form the terminal (works fine here with phosh-osk-stub). Also hitting Menu should give you a menu key should give you a popover with copy/paste. That said you can also redirect the debug output to file directly or run via ssh so you can copy/paste from your PC.


This does not work for me. Can you please explain this with more details. Thanks in advance.

When I hit in terminal OSK the Ctrl it gets inverted. How I have to issue now SHIFT+C exactly?


Ay, it seems the copy-paste in terminal is no more (I remember vaguely that it ma have worked at some point). Ctrl+Shift+C and other shortcuts do not work with touch keyboard (but do with external). Menu does not have any copy-paste tools/icons (as it should). And pressing terminal does not pop up menu with these options (when menu pops up, it clears the selection).

Workarounds: external keyboard or forward outputs to text files and then copypaste from there (like: ls > lscontent.txt [add > and filename after the command]) by opening the file in gui (gedit for instance) via filemanager (where copy-paste works normally).

1 Like

This works fine for copying!

1 Like

Ah, a hidden gem (that some may not have found yet): on terminal keyboard touch “>_” (terminal special keys), under which a “menu” key can be found, which opens a bit different menu that has copy command (if text is selected first). Not the most intuitive but it’s there.