No Wi-Fi Adapter Found

You will probably want something like
sudo journalctl -t NetworkManager | grep 'Feb 18'

(or replacing ‘Feb 18’ with whatever the date is where you are).

The output won’t make a lot of sense to you. It won’t even make a lot of sense to me, but it may help to show whether anything is happening when you turn on the WiFi HKS, noting again that I suggested above: I would boot with the WiFi definitely off and the modem also off, let the Librem 5 settle down for a minute or two after booting, then switch the WiFi on using the HKS.

@jsjjnbrunk. I can confirm your problem. Basically I have the same configuration i.e. phone connected to power supply and placed close the access point. I’m still probing, but it appears to be a problem with the access point being too clever and the L5 trying to follow that. My router cannot be set to a 20M channel band width, as suggested elsewhere, but i had some success setting it to some lower WLAN standard (5G n/Wi-Fi 4, 40 MHz). I’ll try the L5 with a less demanding access point these days …

Perhaps unrelated, i set Settings->Power->Automatic Suspend to ‘off’ for now.

@jsjjnbrunk what is “dmesg” saying on console?
Try this kernel maybe work for you:
If still not work with newer kernel try the charging step, just to refresh the memory sys:
If still not working, then you need to wait for the Big Update soon by using modem gsm internet or reflash the L5.
Good luck!

@carlosgonz I’ve tried the kernel and found it improved things a bit. The reason for instability of WLAN is signal strength due to the log messages:

Feb 19 12:36:24 pureos wpa_supplicant[506]: wlan0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-72 noise=9999 txrate=6000
Feb 19 12:36:24 pureos wpa_supplicant[506]: wlan0: CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-71 noise=9999 txrate=6000
Feb 19 12:36:30 pureos kernel: wlan0: disassociated from 3c:a6:2f:e7:c8:52 (Reason: 33=DISASSOC_QAP_NO_BANDWIDTH)
Feb 19 12:36:30 pureos systemd-networkd[368]: wlan0: Lost carrier
Feb 19 12:36:31 pureos kernel: redpine_91x: rsi_mac80211_set_key: RSI del key
Feb 19 12:36:31 pureos kernel: redpine_91x: rsi_hal_key_config: Cipher 0x0 key_type: 2 key_len: 0
Feb 19 12:36:31 pureos kernel: redpine_91x: rsi_mac80211_set_key: RSI del key
Feb 19 12:36:31 pureos kernel: redpine_91x: rsi_hal_key_config: Cipher 0x0 key_type: 2 key_len: 0
Feb 19 12:36:31 pureos wpa_supplicant[506]: wlan0: CTRL-EVENT-DISCONNECTED bssid=3c:a6:2f:e7:c8:52 reason=33

But that’s is not really true. The L5 was placed very close to the router and other devices don’t share the problem. As said, the kernel improved things a bit. Thanks.

I’ve set up another router with better results. At least i get WiFi when not being absolutely close the router. Good enought for now.

To be more explicit about the situation when i received “No Wi-Fi Adaptor Found”: It was immediately after a reboot forced by holding the power button. Together with the problem above, i believe it could just have been a “hanging bit” of some kind. Contrary to jsjjnbrunk i had that particular situation only once.

@jsjjnbrunk I’d thus support the advice to try the charging step and make some probes with the router.

As my case i do not have any problems with my Evergreeen on Charging or Wlan or Bluetooth(i do not use BT ATM and BT is OFF on Posh). The reception signal of Wlan on L5 is really good and superior, anyway the issue “No Wi-Fi Adaptor Found” is already tracked by Purism Team.
Also try set your router to Channel 9 and Signal N on Band 2.4 Ghz for better long range and compatibilities to L5.

Thanks. I do think the router i was using initially (Fritz!Box 7520) might try something that L5 does not like right now. I’m using a GL-AR150 for the L5, yet.

Hmm, the kernel you pointed me to might have an issue with sound. Please see:
No more sound, please help.

Thank you very much, the system feel much more stable meanwhile.

I checked your "Fritz!Box 7520 " router then this router support AC Signal which is not compatible with L5, you need to make sure you manually set it to the N signal. The other router “GL-AR150” is not a good router this router has poor signal to devices… I have a “GL-AR150” then i know that this tiny router is not good for long range.
The sound is work good to me with kernel linux-image-5.11.0-1-librem5 (5.11.0~rc7pureos1), I do not know why is not working on you.

@carlosgonz Thank you for your support.

To tell the full story: I have made quite some tries to adjust the “Fritz!Box 7520”, but in the end, none really worked. The router does a lot of tricks. It offers both 2,4 and 5 GHz at the same time. Initially and with the default configuration, it was possible to connect, but not good enough for any download. Additionally, it had to learn about the datetime issue first. After finding that the router’s abilities can be related to the problem, i reduced the protocols level on the router and found, that i additionally have what appears as a range or signal strength issue. It worked in a range of about 1 meter around the router. The connection then became stable enough to upgrade and install a ssh-server.

Matters appeared to be improved also with the kernel you point me to. I could set back the router to its default configuration, but without range improvements.

From both the administration surface of the router as well as from the logs, the “Fritz!Box 7520” simply appears be quite tricky and happily juggles with protocols, channels, signal strength and everything else during operation. I think the L5 tries to follow and negotiate all this with the router, but with a result that leads to what appears as a poor signal strength and still with occasional connection drops.

At that point, i additionally stumbled into the no return from sleep issue and had to reboot the device forcedly for several times leading to the issue in the topic. Well, yes, one can call this a rough start.

The decision to try another router came out right. Contrary to your experience, perhaps because it is a “GL-AR150-Ext” really, the cover is at least 10 m, enough for me. I’ve let the L5 run for a night and don’t see any connection drops in the log now. Operation with the device feels stable now. From that finding, i do think the signal strength problems i experienced with the first router can not be attributed to the L5’s hardware, but rather to some negotiation incompatibility with the Fritz!Box.

As for the linux-image-5.11.0-1-librem5, is do confirm my finding. I’ve reinstalled the kernel with same outcome (i.e. failure of pulseaudio to open the modem sound), so the issue should be replicable. If you want, i can do any test you want to narrow down the problem.

Thanks again, carlosgonz. I for one did not expect that everything runs smooth from the start and that a long list of issues will have to be worked down for a while. I’ll try out some USB-C docks next to get a wired connection, too.

Turn off the band 5ghz on your router, then just leave the band 2.4ghz, then check if your mobile(L5)workstation work better.
The Wlan and BT is not work reliable at the moment, then we have to be careful about the settings of the functions. As a said there are already a big improvement on BT - Wlan but not yet arrived, we need to wait…
Note: The band 5ghz is low range compared to band 2.4ghz. So for Long range is 2.4Ghz or much better the band 1ghz for super long range.

Maybe we should make a thread for collecting information how well the L5 can connect with other 802.11 devices. What do you think?

1 Like

Can the Librem 5 optionally use the new iwd daemon

instead of wpa_supplicant?

From what I heard of iwd, it is much faster and conformant compared to wpa_supplicant. Perhaps it would handle this problematic router much better?

1 Like

I did as you say and connected to the Fritz!Box again. And yes, it works well.

I did not find an option to deactivate 5 GHz in the router’s configuration first, so i haven’t tried that before. The router now reports 2,4 GHz, n/Wi-Fi 4, 20 MHz for the connection and good signal quality. And i do have a 10m cover at least with it.

My impression before was, that the L5 was in fact connected via a 2,4 GHz channel, both from the routers information about the connection as well as from the L5’s log, but both 2,4 and 5 GHz were offered …

Thanks carlos, i let the L5 run a night with this connection and check the log tomorrow for drops.

1 Like

AFAIK you can also tell the Fritz!Box to use two different SSIDs for the two Bands that way you can decide which band to long into and keep the Librem5 to always try to get into the 5G network. and getting lost in the switch.


Yeah that work too. But also we can manager the WLAN band from Posh but yes a diferent SSIDs is required to prevent conflicts on both bands

Manuel, that’s perfect. It saves the higher speed for the other devices!

While this is good for fault isolation, I have only ever used my Librem 5 on the 5 GHz band and I have not had any problems with reliability or range. Obviously range depends a fair bit on the house construction.

One comment that may be relevant: Some people use the same SSID for the two bands and some people use different SSIDs. I prefer the latter - because that way you can be sure, if you only associate with one SSID, that it stays on the corresponding band - or not at all. At the same time, there is no need to turn bands on and off on the router, which will negatively impact other devices.

1 Like

I was troubleshooting that is why i said to turn off the band 5ghz. I already know that Librem 5 work amazing on both band. But “WLAN, together BT, plus Purism-HKS” still is not all together reliable, but Purism team already is working hard to get all reliables soon as possible.

1 Like

I have this exact issue now. I was experimenting with my new cellphone connection card and run into this issue. The Wifi - Bluetooth HW kill switch works fine but WiFi does not get detected.
Bluetooth is detected, active and working. WiFi adapter is not found. ip addr command shows wwan0 and wlan0, the ifup command runs with no output, i would think it is successful, but the WiFi does not show up.

Was there any fix provided.

Check the button ON/OFF for WLAN in Phosh bar menu.

Did you mean the top bar menu? There it shows Mobile detected, Bluetooth detected but WiFi not detected.

/etc/network/interfaces only shows lo as available interface. wwan0 and wlan0 are not mentioned.
Interestingly, ip addr command shows both as available. wwan0 is shown as down.