No Wi-Fi Adapter Found

My Evergreen phone arrived yesterday. I was able to connect to my home Wi-Fi router, though the connection was wonky and dropped randomly. Still, I was eventually able to install the latest OS updates and download a couple of apps from the PureOS store. Left the phone turned on and connected to the charger overnight. But all day today I have been totally unable to get a Wi-Fi connection. Searching Wi-Fi under settings returns a, “No Wi-Fi Adaptor Found” graphic. I’ve double-checked the Time-related Wi-Fi fix, played with those settings, restarted the phone with the Wi-Fi hardware switch on & off — tried every permutation I can think of. No joy.

One thing I don’t see in the list of things you tried is; have you tried unplugging the wifi module and plugging it back in (reseating)?

2 Likes

There are a couple of topics already on troubleshooting getting WiFi connected on the Librem 5.

I would start with ifconfig
Does it show wlan0     ?

If you are having trouble, I would boot with the WiFi definitely off and the modem also off, let the Librem 5 settle down for a minute or two after booting, then switch the WiFi on. Does wlan0 appear as an interface? In the top line of the screen does WiFi appear? does Bluetooth appear?

Did you set the date and time manually?

Mostly Wlan, Bluetooth issues seems has been fixed from sources, but not yet arrived ATM to L5.
A maybe a temporary fix to yours issues is that turn Off Bluetooth while using the Wlan(wifi). So turn off BT from posh then reboot ur L5, Wlan should work.
Check WLAN HKS is on.

“One thing I don’t see in the list of things you tried is; have you tried unplugging the wifi module and plugging it back in (reseating)?”

Thanks, Yes, I did try that. Everything looked fine (I visually checked the antenna connections), but it didn’t produce any results.

1 Like

Thanks but I just get “Command not recognized” if I enter “ifconfig” at the command line. Is ifconfig supported in PureOS?

“Did you set the date and time manually?“

Thanks, yes I did try that as mentioned above.

“So turn off BT from posh then reboot ur L5, Wlan should work.”

Thanks, but the results are the same — no Wi-Fil

Your issue is playable sometimes when wlan and bluetooth is on. If you unpluged the Wlan Module to check whatever, you turned off the L5 first? Are you already tryed with newer kernel if work like Linux 5.11rc7?

Definitely works on my Librem 5. But I might have stuffed up with that suggestion if it turns out that I installed it.

With the WIFi off and the modem on, can you get on the internet and then install ifconfig ?

Alternatively,

ip link show

(which gives more compact output anyway).

Thanks for following up. Here’s what I get from op link show:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: usb0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
link/ether 42:ba:e5:58:95:02 brd ff:ff:ff:ff:ff:ff
8: wwan0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT group default qlen 1000
link/none

OK, so if you follow the procedure in reply 3 above, gathering ip link show output at each stage and then posting here …

At some point you may have to contact Purism support (support@puri.sm) for guidance.

It may also be a good idea to install librem5-goodies so that you have the Screen Shot tool installed.

Are you able to confirm whether Bluetooth works?

Thanks. Yes, Bluetooth works.

Which would tend to indicate that you don’t have a hardware problem, given that WiFi and Bluetooth are on the same removable module and controlled by the same HKS.

Have you looked in system log files for anything about WiFi adapters / wlan0    ?

1 Like

Thanks, but: HKS? System logs?

I have a general idea of what system logs are, but not enough to find them in PureOS nor to harvest the specific data from them that would answer this question. No idea what HKS is.

Hardware Kill Switch

You will probably want something like
sudo journalctl -t NetworkManager | grep 'Feb 18'

(or replacing ‘Feb 18’ with whatever the date is where you are).

The output won’t make a lot of sense to you. It won’t even make a lot of sense to me, but it may help to show whether anything is happening when you turn on the WiFi HKS, noting again that I suggested above: I would boot with the WiFi definitely off and the modem also off, let the Librem 5 settle down for a minute or two after booting, then switch the WiFi on using the HKS.

@jsjjnbrunk. I can confirm your problem. Basically I have the same configuration i.e. phone connected to power supply and placed close the access point. I’m still probing, but it appears to be a problem with the access point being too clever and the L5 trying to follow that. My router cannot be set to a 20M channel band width, as suggested elsewhere, but i had some success setting it to some lower WLAN standard (5G n/Wi-Fi 4, 40 MHz). I’ll try the L5 with a less demanding access point these days …

Perhaps unrelated, i set Settings->Power->Automatic Suspend to ‘off’ for now.

@jsjjnbrunk what is “dmesg” saying on console?
Try this kernel maybe work for you: repo.pureos.net/pureos/pool/main/l/linux-next-librem5/linux-image-5.11.0-1-librem5_5.11.0~rc7pureos1_arm64.deb
If still not work with newer kernel try the charging step, just to refresh the memory sys: https://docs.puri.sm/Librem_5/Troubleshooting/Charging.html#evergreen
If still not working, then you need to wait for the Big Update soon by using modem gsm internet or reflash the L5.
Good luck!