No Wifi, cannot set date and time

I don’t have automatic available. That’s not the point. The doggone thing should let me set the time if it’s going to pretend to offer the option.

And what you said about swiping upwards doesn’t work either.

Setting the time is a popup over the time page, so both a little picture of the popup and the main time page show up in the “swipe up” area. Swiping those away doesn’t change the phone’s time.

Honestly, why does a user have to play guessing games like this? Is someone too lazy to put in an Apply button?

Another “thing” that needs to be ensured is: Settings -> Mobile -> Mobile Data = ON. In addition, please type inside Terminal app:
date --utc
sudo apt update
TZ=GMT date

You might also use timedatectl command (if chosen so):

No you’re missing the point.

The software has a bug. There is this “option” (that appears to be either broken, or written with a non-obvious method of applying changes) to set the date WITHOUT any sort of connectivity. It’s broken. I’m NOT asking how to turn on connectivity, I’m asking how to set the clock without connectivity.


I would agree. Please see: “Set the time manually”. Refer to the following as well:
sudo hwclock --show
sudo hwclock --help

setting the time with sudo date works…until I restart the phone. It’s obviously getting a wrong time from some piece of hardware at bootup.

sudo hwclock --show gives me an error message: “hwclock: ioctl(RTC_RD_TIME) to /dev/rtc0 to read the time failed: invalid argument” (Also applies if I don’t do --show). This command works on my ubuntu desktop.

As an aside, now that I have the phone at home, it turns out the wifi is actually broken (though bluetooth apparently is functional).

I’m sorry to hear that, yet I do not get any kind of error on my Librem 5, when here related command used.

EDIT: Is this one working on your phone:
sudo hwclock --systohc --update-drift --verbose?

How about:
sudo dmesg | grep rtc-m41t80?

I recently received the L5USA as well and I am able to set the time manually. I go to the Date & Time setting and get the popup time change window with the up and down to change the time. As I press those arrows I can see the time change both in the window and at the top of the L5 screen. I hit the back button (upper left) then swipe away the time screen. The time change stays as I had just set it. On a side note, I did have to change screen zoom first from 200% to 125% to see the entire time pop up window.

I tested this with both wifi on and off (off via setting and side switch). The cellular switch was off as well (but I have no sim anyway). When I reboot phone the time change sticks. Then if I turn wifi auto time back on it will go to the correct time as well.

I haven’t done much with phone since I received it but I did do the software updates that were available via the PureOS store app in the update tab.


Yes, this should do, by sliding the Automatic Date & Time button to the left (off state), perhaps landscape mode preferably (by hiding the keyboard through hitting the keyboard icon on the bottom screen edge right). Thanks a lot!

Thanks. I forgot to mention to turn off the toggle for auto date and time to be able to press (i.e. no longer grayed out) the date & time section below the toggle to get pop up window to change time manually.

It is still difficult to see entire pop up in landscape so going to Displays setting and changing scale from 200% to 125% allows full view of date and time for me. Now if I can just get my scale setting to stick at my setting after restarts.

1 Like


The first command gives me IOCTL error messages.

The second one gives me “oscillator failure, data is invalid” multiple times.

I begin to suspect my phone is quite defective at a hardware level.

After years of waiting, THIS.


THe toggle for auto date and time was turned off. I had reduced the zoom size.

Nevertheless moving the up and down arrows on the time and date had ZERO immediate effect and closing the popup makes it forget my changes.

Looking at the reply above this one, it appears the phone has a hardware issue. I’m pretty furious at Purism right now; after three years of lies and excuses and broken promises, my phone doesn’t have a functioning hardware clock and doesn’t have WiFI (it remains disabled even after I flip the kill switch; bluetooth does not) so I cannot download new software.

At this point it’s good for nothing but playing chess and 2048. Even the keyboard is frustrating for me and I can’t try another one, because WiFi is broken.

Really, dude?

Yes, really.

This phone was touted for over a year as “now shipping” with a lead time of two months in the fine print. I upgraded from the regular Librem 5 on the strength of that. You can excuse the delay on the basis of Covid19, but not the lying about the delay.

And after all that I have a near brick.

I’ve just send you private message with my thoughts on your issue.

Have you emailed support?

1 Like

My guess is that happens because your hardware clock is broken, which you saw from the error messages when you tried to run the hwclock command, because when setting the time manually in the GUI it tries to set the hardware clock directly. I think the GUI effectively tries to do both “date --set” and “hwclock --systohc” and it needs both of those to work.

The command “sudo hwclock” should show the date and time and not any error messages.

On the bright side, this could mean you have only one hardware issue, the clock, and that you wifi problem is just a consequence of that.

Anyway, I think your best course of action is to contact Purism support by email and explain this to them, probably the output of the “sudo hwclock” command you get will be enough for them to conclude that you have a hardware issue so they should let you send it back. And they will hopefully add “verify hardware clock” to the list of things they check before shipping a phone.

1 Like

The good news is, the WiFi was really a non-issue. WHat I saw on the settings panel was a grayed out WiFi icon, then when I pressed it, it lit up but had a slash through it. Pressing it again put it back in the grayed out state. So it looked as if I was toggling between “airplane mode” and “can’t find the WiFi hardware.” I did find the online manual, and it’s a bit tricky but you CAN get to the WiFi setup from that icon. I was able to turn it on and log in.

The bad news is, the actual “cellphone modem” is getting ZERO signal here. With my sim card in my old phone, I have four to five bars. In this phone, absolutely no signal, 0 dB. I need to try again elsewhere, obviously, to learn more.

But the clock probably really is fubar. (I’ll experiment some more after I disconnect from WiFi.)

@bplo, @kernelsandurz, @SteveC, @Skalman and others, I just found those two “automatic” commands working well (as tested) and useful with GNOME on Librem 5 (after Date & Time manually correctly adjusted and actually having connection to the Internet by having, for example, sudo apt update working with Wi-Fi/Ethernet):
sudo apt install ntpdate
sudo ntpdate-debian