No Wifi, cannot set date and time


I just reflashed the Librem 5 Evergreen using this procedure.

Even though the Wifi kill switch is set to ‘on’, Wifi and Bluetooth are greyed out in the top status drawdown. Is this a hardware issue? Should I send the device back for repair?

I also tried to change the Date & Time by going to settings > Date & Time > Date & Time. Both ‘Automatic’ switches are set to ‘off’. I try to enter the correct date and time but run into 2 UI issues:

  1. Every minute the correct time I have entered is reset to the incorrect time that the phone thinks it is. This is very frustrating.
  2. Once entered, I cannot close the dialog because the ‘back’ button in the left-hand corner of the top window border is rendered off-screen. This is also very frustrating.

How can I fix these issues? This all seems like basic stuff not working.


For the “back” button issue, tap the “^” symbol at the bottom of the L5’s screen, which will minimize the app upward. Then swipe the dialog box away. (Agreed, this is not exactly a convenient method.)

For the WiFi/BT issue, you might try a restart, if you haven’t already. If you have an active SIM card inserted, you should be able to use automatic time sync.

And make sure the hardware kill switches are definitely ON. (Although I’m sure they are, if you’re seeing WiFi/BT panels in settings.)

1 Like

Thanks. I managed to set the date & time to within a second accuracy from the command line (date -s and hwclock -w).

However, after a restart I still see the Wifi and BT icons disabled, with all kill switches definitely ON.

I do not have a SIM inserted at the moment. But it should just work without one, right?

Yes, WiFi/BT should work. When you flashed, did you do it with the kill-switches OFF?

Yes, the kill switches were off during flashing.

And you’ve turned these on from within the Settings app?

When I go to Settings > Bluetooth, I see ‘No Bluetooth found. Plug in a dongle to use Bluetooth’.

I don’t know where to enable Wifi in Settings. I don’t see a switch in Settings > Network.

Wi-Fi settings should also be there, except when the hardware switch is turned off, in which case it would not appear:

Once you tap on Wi-Fi, you get this page (I’ve temporarily disabled mine in order to hide the available network names):

My WiFi switch is on, but I don’t see the Wi-Fi entry in the Settings menu. The first entry is Network, then Mobile then Bluetooth.

This seems like a hardware problem.

And it’s strange that BT is there, but not WiFi, since they’re both controlled by the same hardware switch.
Probably time to email:

Alright. Thanks a lot for the help!

1 Like

I don’t know if you saw this thread, but it might be related:

…or maybe not, since you’ve completely reflashed to Byzantium. Everything should be nice and fresh.

EDIT: Are you able to see WiFi from within the Advanced Network Connections app? See here.

If so, can you create a connection to your network?

1 Like

This issue may not be what I have with my Librem 5, but sometimes after booting/rebooting, the Wi-Fi won’t be available (even though my hardware switch is definitely on). If I turn the hardware switch off, wait for 20-30 seconds, then switch it back on, most often the Wi-Fi will be available again until another reboot.


From what to what? amber to amber? byzantium to byzantium? amber to byzantium? something else?

Was WiFi working before you reflashed?

I doubt it.

No, but it may be appropriate to contact

It could be a firmware issue.


Thanks. I tried that but it didn’t work for me.

1 Like

I hadn’t used the phone for many months and started using it again yesterday. I did not check the previous version before flashing, but it was probably amber. I flashed byzantium now. WiFi was not working before I reflashed.

Support is helping me out. Thanks!

1 Like

Nope. That app does not show WiFi either. Just Ethernet.

To close this thread, I contacted Purism support and after a few exchanges which involved me sending phone logs, they concluded the WiFi card was broken and sent me a replacement. WiFi and Bluetooth work as expected with the new card installed.


Not so fast.

I just today got my Librem 5 USA…and I cannot set the time on it.

I have no wifi. I know that. That’s not the complaint.

The problem is the app to set the time is simply not useful. I can’t figure out how to tell it to accept the setting I just input, and backing out with < simply causes what I did to be ignored. Even if it does seem to take, it gets thrown away before I can (or as I actually) exit the main settings screen. Where the heck is the OK or Apply button?

1 Like

It should apply and stick on exit. Instead of using the < button after you adjust the time, minimize the screen (tap the “housetop” icon under the display), then swipe the dialog box up to dismiss it. See if that helps.

If you have a SIM card, inserting that and using “automatic” on the date/time should set it for you.

1 Like