Not sure why hotspot isn't working

Thanks for the reply.

  1. Yes, it all loads fine on the Librem 5. It just doesn’t on the other phone that is connecting to it. Samsung Z Flip3.

  2. I haven’t installed any but I do have PIA that I can choose to turn on for my android device. I don’t know how to use it on the Librem 5 either. Could my Samsung ZFlip 3 have any other settings that need adjusting to get hotspot working?

Also, thanks for the Waydroid feedback. I was just trying to install it to do mapping as I’ve tried the Librem maps and erm… they suck at the moment :sweat_smile: so I was looking for something to use that could make the Librem my daily driver. At the moment the Librem phone usually sits on my bedside table as a nice ornament that I sometimes fiddle with and learn about how un-linuxey I am. Using the command line is not my fortay.

Hey guys I’m going to need it a modem soon for an upcoming trip.

Should I attempt to get the hotspot working or just give up and use two sim cards (please don’t delete, my finger slipped)

@Not4Resale see if that helps you:

Thanks for the advice. Just checking, is there a similar - button that is a bit longer? I’m getting an error and am not sure if I’m typing something slightly wrong.

You did typing something slightly wrong.

If you get an Error like “Bad argument ‘flags’”. You passed likely some wrong spelled command… so you had:

This should be:

sudo iptables-legacy -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu 

And you done:

sudo iptables-legacy -A FORWARD -p tcp -tcp flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu

This missing “-” between “–tcp flags” change a lot. Your other issue was that you have only one “-” before the tcp in front too. You need two of them without space/whitespace between. Take care of that.

This Internet-Forum try to change two minus - into a lager one character font, which is susceptible to faults.

If you have questions you can try google the command in first place “iptables-legacy” or your try “iptables-legacy --help” or “man iptables-legacy”.

Hope that the posted command by tendays will solve your issue.

Thanks for your explanation Christal. I tried looking for an answer for what to put in the terminal but couldn’t find something with the appropriate em dashes – so I copied your previous post’s terminal guide and replaced the double en dashes with a proper em dash.

Am I still typing something wrong?

I’m still getting the flags answer.

No em dash! No en dash!

Any dash character should be a normal hyphen character, and any long format option name should be preceded by two normal hyphen characters.


Hi Irvinewade, I had tried doing that initially but after appearing to accept the terminal command, the hotspot didn’t work.

Do you have a solution for that?

Which Wifi modem have you been using?

I had to replace mine with a new version that Purism is using for the latest builds for their phones.

Their should be two versions, the old and the new. Could possibly take a picture of it to show us, if necessary?

How do I check? My librem came in the mail around a month or two ago.

I think I was in the evergreen batch.

I did it this way and typed in my password. When I pressed enter it showed exactly this screen.

Then I tried to hotspot and this happened: (network settings photo added too for more info)

Not the bad argument photo. That was a mistaken upload

sudo journalctl -b | grep redpine

If you get output then you have the card that was shipped with the first N phones.

sudo dmesg | grep brcm

If you get output then you have the card that is now shipping.


See New Post: Shipping new SparkLAN Wifi cards with Librem 5 for another approach,
basically: nmcli -f GENERAL.DRIVER d show wlan0

A month or 2 ago! Most likely you have an up to date wifi modem in your phone then.

I’ll try and see if I can find photographs of the old and new wifi modems to show you a comparison to

I use my Librem 5 as my daily phone, but often I take my old Android still with me. Usually the Android is connected via the WiFi hotspot on the Librem 5. This connection is not totally stable and sometimes a bit hard to get working.

When I have the hotspot working, usually after a few minutes internet stops working on the Android, and the internet connection on the Librem 5 is lost. Once, after reconnecting to the internet on the Librem 5 (see below how I do that) the internet connection becomes usually more stable.

On your screenshot, I see the little exclamation mark next to your WiFi connection indicator. That is exactly what I also sometimes see. Often when I see this the internet on the Librem 5 is not reachable as well.

When this happens, I open a terminal window on the Librem 5 and ping


Now you should see responses appearing continuously, if the internet connection is fine. When I see the exclamation mark on the Android, I usually do not get responses on the ping (so nothing appears in the terminal). If there is no ping response this indicates that the internet on the Librem 5 is not working fine, so also not on the Andoid that is connected to the Librem 5.

If I get no ping response, I leave the hotspot on, and try to get the connection working on the Librem 5. And I leave the ping command running (thus still without responses) in the terminal.

Then I try to get the internet connection working again, and check the terminal after every change if the ping gets responses. At the moment there are responses I check the internet connection on my Android, which then usually works as well. If not, I would reconnect the Android or stop and start the WiFi hotspot on the Librem 5.

So basically, I have always a terminal window with the ping command open on my Librem 5 to asses if the Librem 5 has a good internet connection.

I have no standard procedure for getting the internet back on the Librem 5, but I usually try these things (after every thing I check the terminal if the ping gets a response):

  • Switching off and on the upper hardware kill switch.
  • Going into GNOME Settings and switching off and on Mobile, or Mobile Data, or Data Roaming. Normally I have these all three on.

I never dit any iptables commands on my Librem 5 to get the WiFi hotspot working.

Thanks Janvlug,

I tried doing the ping thing and it works perfectly while on a wifi network or the phone’s own data but as soon as I turn on the hotspot the terminal says that the

Network is unreachable

I’m at a loss as to why the internet works fine but not in hotspot. I’m flying tomorrow so as it stands, it looks like I’ll just swap my sims so that clients who try to sms or call me can do so with the Librem and everything else will happen on my daily driver.

Sigh… I was so hopeful of a non Android/Apple phone when I purchased the Librem in 2019 but it looks like I’ll still be stuck in the Corporately Privatized Matrix for the foreseeable future because I’m just not technical enough to figure Linux out yet.

Ffs - I can’t even seem to upload the correct photo that I just took on my Android!

Sorry for uploading the wrong photo again.


I’m currently in New Zealand and after bringing my gfs old phone as a “modem”, I randomly tested the hotspot on my Librem 5 last night and… It works!!! :partying_face::partying_face::partying_face:

My little Librem 5 is now 1 step closer to daily driver territory. :blush: All it needs now is a Waze type of app for navigation that uses collaborative data to get the best transport details and I’m 100% in on the Librem 5.



If you were having PMTU problems then it could depend on the mobile service provider. So it might work in NZ but still not work where it was previously not working. So I suggest re-testing when you get back home.

A good way to verify is to check whether you’re able to communicate with the phone itself over the hotspot network (ping, ssh etc.)

1 Like