Observatons with the Chestnut batch - Librem 5 received Jan 2020

Good to know about emacs; I’ve often wondered about it. I am thinking for the time being, that I might stick to GUI gedit on the “Librem 5”, & work between the Terminal & it, if I have too?
Does anyone know if the new Keyboard, that will eventually have ctrl on it etc, will be available on “amber” or will it be just on the"byzantium" repo?

1 Like

Can someone clarify whether the current Librem 5 keyboard does or does not have an Esc key?


It does. Questions about software can be answered by checking our development images: https://developer.puri.sm/Librem5/Development_Environment/Boards/emulators.html

or by browsing project merge requests: https://source.puri.sm/Librem5/squeekboard/merge_requests?scope=all&utf8=✓&state=merged

or by reading project release notes: https://source.puri.sm/Librem5/squeekboard/-/tags and https://source.puri.sm/Librem5/squeekboard/blob/master/debian/changelog

Those will be relevant to 90% of projects we develop.


Yes, nano.

I turns out that nano can use Esc Esc as a “synonym” for the Control key e.g. press and release Esc, press and release Esc, press and release X. So that should give you a way of saving edits in nano. Problem solved?


About keyboard and ctrl key, does it work to connect an external physical keyboard via the USB port?

1 Like

Thanks for the thought, that has gone into thinking that through, and asking questions to help in regards to saving with nano, with the ctrl key not being on the Keyboard yet. I am going to keep that in mind, & save that info re: Esc Esc sequence to a file. :slight_smile:

It does seem to me at the moment, that actually the “Chestnut” batch doesn’t yet have Esc either on the Keyboard; although I think I read from this Link ( https://forums.puri.sm/u/dcz ), that the interim Keyboard “dcz” has completed, is most probably on a Purism repo by now, or tomorrow; and it is that one, that has so far the Esc Key, but not yet the Ctrl Key (apparenttly ctrl is coming soon?). Please update me if I am wrong about the interim new Keyboard, and Esc.

Can someone tell me whether the new Keyboard as to date, will be in the amber or byzantium repo? :thinking:

The keyboard is in amber-phone. I’m not sure about Byzantium. Software is never assigned to batches but rather to repos, so all hardware revisions have the same software. Including the emulator link I posted before.


Thanks for that “dcz”: I am glad it is in amber-phone; as I am having trouble with using “_sudo add apt repository _ _ _ _” on the Librem 5, to set “byzantium” as the repos to use on it… Now on the “Librem 5” I’m not sure if that is the best idea, even if it were after updating the get the new Keyboard?

I don’t know, I never used Byzantium mysekf.

As for squeekboard 1.8.0, it got stuck somewhere in the pipeline and is not in the repo yet. This is the update that allows the user to switch to terminal manually.

That is interesting to know about squeekyboard 1.8.0 not in the repo yet (24/01/20); I guess soon it will be though!

Is there a special amber repo, for the “Librem 5”, like you typed (amber-phone etc.); so there then would be a separate amber-main used for the Laptops & OS. It would then, just by that, make huge sense, to just stay with amber on the “Librem 5” that it came setup with?

Thanks dcz

I don’t have accurate knowledge of how it’s organized, but I think “amber” proper is the base for all devices, while amber-phone contains only packages that have temporarily diverged on the phone.

Thanks for that “dcz”. I’m best to stick with “amber-main” & the others then for awhile; while there is also a divergent "amber-phone repo. Do you know what file & path too, that the repos on the phone are setup in; as they don’t appear to be showing in /etc/apt/sources.list ? To know that would be helpful, even if at this stage, it were for just the learning. :slight_smile:

Also have a look in /etc/apt/sources.list.d

Hi Kieran, Something that has always confused me, is with /etc/apt/sources.list.d , is that in the past, even though I’ve known /sources.list.d was a Directory. In other Distros, I’ve never been able to find any file in it; even though, there has been Nothing in /etc/apt/sources.list as well; and in those several distros, I’ve still been able to install programs with “apt”. ??

The amazing thing I found this time cd-ing to sources.list.d, and using ls ; this time it actually showed a file ( nano.save ). So using sudo nano /etc/apt/sources.list.d/nano.save , that command opened that file, and in it were the 3 x byzantium repos setup. :slight_smile:

If someone can comfirm that “Librem 5” (Chestnut batch), comes with the amber repos setup, with also the amber-phone one too instead , then it looks like my using _sudo add apt repository _ byzantium repo three times for the different ones at the cli, actually worked, when I was using those commands, and the terminal had complained that it couldn’t do it, & that it failed.

Does anyone know the exact text to write in this file ( nano.save ), to add the amber-phone repo to the ones already there, that “dcz” was saying would be updated with the new Keyboard soon? eg. _deb https://repo _ ?? ? :thinking:


Almost certainly; even Android can do that with USB OTG, and this is a native Wayland environment where I remember my keyboard working fine on the terminal in the emulator, and I use the ctrl key a lot, even on Android, so would probably notice if it didn’t work.


I can’t comment on that without knowing which distro, and running it.

On my desktop, man apt points me at man sources.list and explains what files are used and what format the files should be in; and perhaps on your other distro, it will give different equally helpful info.

That doesn’t seem like a well-named file. I gather this is a consequence of being unable to save files in nano. You should rename that.

Not having a phone yet, I can’t answer your question on what apt sources should be set to for the Librem 5 at the current time.

1 Like

Thanks happysmash27, I might have to try that in a few days to weeks time. :sweat_smile:

Hi kieran, That was a bit vague, about in some distros, there was nothing in both sources.lisf file; and nothing in a file within sources.list.d, and everything still working? (it is old memory, so it is not surprising that you are unable to comment on that without good detail.

nano.save does seem a strange name… Thanks for the suggestion of using man sources.list. Most enlightening, although on the phone, with a slightly too long a pause on the enter key, had it scrolling very fast, through the whole lot. I did, get before that though, to use .sources, or .list, depending on the format used, for part of the name of the file within /etc/apt/sources.list.d . :slightly_smiling_face:

As default repositaries on the “chestnut” batch, are the amber ones (amber main, amber-phone, amber-security, and amber-update). I’m not sure of the path to the amber main one, or the amber-phone one as well. I’ve spent a lot of time trying to find the current ones of those two, especially the amber-phone one!? :yum:

I also don’t really know, how the file nano.save got in the sources.list.d directory; as I can’t edit it without having "arrow keys" with no ctrl, and no Esc either; and using **sudo add-apt-repository deb https://repo _ etc ** didn’t work to add the amber repositories either. I guess buying a USB A to USB C adapter for my keyboard, is the next step to right things; & and it would be good to know, what the default name for the file the sources are saved in, within _sources.list.d _ ? :thinking:

I mightn’t be able to get back to this for a few days?

There is no default name. Any name that ends with .list will do. See question https://askubuntu.com/questions/82825/do-files-at-etc-apt-sources-list-d-need-to-have-an-extension-list (update: corrected link) and man sources.list, the relevant parts are cited there. The purpose of *.d directories is to customize settings without having to modify system-provided fikes which could be overwritten on a package update.


My usual preference is mcedit, which is a part of Midnight Commander. This runs from the console and, I believe, uses ncurses. Normally the controls rely on the function keys, but it also displays the controls as buttons at the bottom of the screen. In a GUI based terminal emulator, those bottom-screen buttons can be selected by a mouse. That capability has been useful to me using a touch-screen tablet upon which I have installed Ubuntu. Hopefully something I’ve said there will be useful to you.

1 Like