Observatons with the Chestnut batch - Librem 5 received Jan 2020

Hi all, I just wanted to record some of the observations that I’ve made with the Librem 5 phone, since I received it in the “Chestnut” batch, in early Jan 2020; and see if other people have found the same, or have other things to add?

I found by trying to charge the phone while it was ON; lead to it quite quickly getting very, very hot indeed.
After some experimenting, I found that I could really only charge the phone, when it was completely OFF. Then it would charge in the 2hrs (and NOT get very hot at all), with the Indicator light going off, after that time, which by the Guide, is when it is charged.

I’ve found the Phone is pretty/very quick in basic operation (which was very pleasing), & silky smooth. Personally I like the Multi-tasking view, and the ease of it. Although sometimes the last app/program open won’t Close. Have others found this?

The SMS/Text messages App, works really well. To date, I’ve found no problem sending or receiving Text messages.

The Maximum volume on my Phone, is pretty low (like a person talking very softly). Does anyone know, if this is an underline software setting, or software problem, or maybe the hardware? Just need that extra work, that will flow down with regular updates. And I am very aware that the “Librem 5” Chestnut batch, is very much a development phone. But it is great. I’m looking forward to it inproving over the next months to come.


I think the volume issue is a software configuration/profile problem that is being addressed. It may be related to this issue.


Thanks David,
I can see what you mean from the Link you included. That would most likely be the issue with the sound volume.

I can’t find the specific thread, but I’m pretty sure the “heating up while being charged when the phone is on” has been a problem since Aspen, related to the current lack of any automated control of downtime for the processor. As I understand it, while most devices clock their processors way down when not in use, the L5 processor is running flat out all the time, because that control hasn’t been built in yet. It should be fixed with software and new battery eventually?


Thanks for that “ecs”; that would explain the heating up issue with charging when the Phone is on at the moment, until a control can be built :slight_smile:

I guess we can see by now… this is going to be a longer term project than initially thought. At least, finally, now the community can get to work and help get to the finish line. :slight_smile: So many knowledgeable people working on these things and putting their time in to help troubleshoot like this, I think it’s very cool. :heart_eyes:


Just a punt, from your handle. Are you in Australia (the OZ part…unless its related to something else)? If so, how is its reception and making calls.

Funnily just today I paid my last payment for a phone and I still keen to see how the L5 performs as is while hoping there will be a modem option that better suits regional Australia.

Hi Brad,
Yes OZ, does stand for Australia. I live in regional OZ too.
Where I live there is a Tower with a Telstra Transmitter on it about 2kms away. The “Librem 5” has 3 bars to indicate 4G Signal strength; because “every man & his dog” are on 4G now, most of the time I get “1Bar” (sometimes 2); with this Transmission it is pretty fast (quite acceptable). I only researched with Duckduckgo for the Bands that Telstra use; & with pleasantness & begging with a support person, I got the 4G frequence that the Tower near my address uses (as not all Towers always use the same frequencies) (of course that was essential for guaranteed reception at home).

The only Modem at present to use in Australia, that is on offer is the EU version of the one you are asked to choose from, between the two different versions. That EU version of the Modem, supports nearly all Telstra’s Phone mobile frequencies (except for one I think). My Tower only transmits on one 4G frequency from Telstra, & that is near 2000 (there is a slight range in each one of the frequencies).

Voice Calls work well (watch you don’t flick the Kill switch for the Microphone to OFF, has to be done deliberately though). SMS works great! (but no MMS yet); & the Terminal works well with most things, except for Saving edited work done in 'nano", as there is at present no “Control Key” on the Keyboard, but “apt install”, “ifconfig”, & most of the other commands I’ve use are find; even “nano” (except you can’t save edits). The GUI “Text Editor” seems to work OK too, as with other stuff the “Librem 5” comes with by default. :smiley: (very happy)


Thanks so much for taking time to give such a considered reply. That’s heartening news. I’m near Lismore/ Byron Bay nth nsw. Given your info I wouldn’t get coverage at home most likely which doesn’t worry me at all. My mobile never worked here for years and only just started in the past year or so I can live without it. 4G will find its way here when we become a marginal seat again.

You’ve given me enough with everything you said to make me get it. I do travel throughout this region for work so that will limit me, but again, that’s for work and I am already resigned to going back to carrying two mobiles with the L5 having no dual sim capability.

But thats all very encouraging. I am in Q2 this year so I am expecting a lot be ironed by then.

On another note…did they get you for gst?

1 Like

HD-OZ, did you have any issues with the local carrier when connecting to their network, or did you just slot in the SIM and go for it?

1 Like

You may not need to beg. :slight_smile:


enter suburb/postcode, persuade it that you are not a robot, choose correct tower in your area if more than one, will list carriers and frequencies.

? That would seem to be a fairly significant obstacle to using that editor.

Have you tried vi ?

Brad, With mine, as I expect yours, from the Crowdfunding campaign; it was Just the price of the phone, which at the time of the campaign, was the $599 + whatever the Exchange rate was between USD to AUD (postage was free for the Crowdfunding ones); on delivery it was nothing more, as in Australia there is NO import duty, until $1,000 or more in spent (which means the original advertised price of an item).


Slotted in SIM & went for it! Done. :slight_smile:


Thanks for that LINK kieran to (rfnsa site); fabulous!

I’ve never used Vi , I’ve read a little about it, & had a quick look at it. To me it seemed a bit of a steeper learning curve? I’m trying to learn Terminal Commands better; plus want to get to other projects. I read that gedit should be installed on the “Librem 5”; but I haven’t been able to get it to run from the Terminal yet.

It is.

If you have a working GUI then gedit is the easiest option.

If you don’t have a working GUI (e.g. ssh in from another computer or GUI is actually broken) then you need a terminal-based editor such as nano or vi. nano is the easier to learn but, as you have seen, is a problem if there’s no Control key. (Some Control characters have meaning in vi too but I expect that you never need them i.e. that everything can be done without using Control characters if you have to.)


Thanks for that. I had in my 3rd Post here (8th), said that the GUI Text Editor, seemed to work well; and although I haven’t tested it fully, it does appear too. The thing I didn’t realise then, is that it is actual the GUI of gedit. So should be fine on the Phone Only in the Terminal would I have to learn vi . Is there another easier cli text editor though?

Not much easier but maybe a bit more modern is vim (an extension of vi). You also have emacs although I have never used it and can not comment on the ease of use or if it needs ctrl.

On the other hand, as far as I know @dcz implemented a terminal layout (issue for the keyboard which includes ctrl and the likes. I am not sure when it will pop up as an update.


Small clarification: I implemented a layout that has no Ctrl but the simple keys. It should be in the repos today-tomorrow.

The separate issue https://source.puri.sm/Librem5/squeekboard/issues/170 tracks the addition of Ctrl. Support in layouts is on the way in https://source.puri.sm/Librem5/squeekboard/merge_requests/306 but there’s no layout that makes use of it yet. Contributions and testing welcome!


emacs is heavy on the ctrl and alt keys :slight_smile:

unless you use EVIL mode with gnu/emacs and then it becomes more like vim … yeah emacs is not installed by default on distros but vi or vim most likely are …


That sounds great about the ctrl Key & maybe Esc would you think? Thanks too, to “dcz” for all that work and planning on the Keyboard. I think it is well worth it.

Your appraisal of vim against vi too; was good to know, and the ups on the keyboard too :slight_smile: