OK, I seem to have semi-bricked my 13


#1

It boots, but the desktop is blank and I cannot run any apps at all, even if I enter them by name. Tilix, for instance, won’t start.

Is there a way to reset it to what was shipped to me?


#2

Running purebrowser simply sends me back to the login screen, too.


#3

I’m not sure, but from what you describe it sounds like it’d be better to just start fresh.

Someone here more familiar with Linux might be able to tell you a way to refresh your install without loosing everything.

Starting over is a good way to ensure you have eliminated the problem.

Are you able to get into Tilix? (terminal)


#4

Yeah, that’s pretty much what I’m asking for.


#5

…and I did mention that Tilix won’t start.


#6

If you can get access to a terminal, I would try to do a

sudo apt update
followed by a
sudo apt full-upgrade

Then restart and see if your problem has been fixed.


#7

Well, I can’t get access to ANYTHING, including Tilix.

So I guess I need to reinstall, but…I have no idea how to even begin to do that.


#8

download from purism the pureos image.

Then using etcher (it runs on everything) make a boot able disk with it and a USB drive.

Then when booting with it iplugged into a USB port on your Librem, push ESC (I think) to access the boot menu, and select your usb drive

From there you will boot into a live environment, and have the option from an icon on the desktop to install PureOS. Follow the wizard and viola.

Edit:
Try pushing alt + f2 first. See if the run command window comes up. If it does you may be able to open Tilix this way by just typing tilix and hitting enter.

One other thing you could do is to click on the gear when you click on your name to log in, and try changing the desktop manager you are using. It could just be that GNOME was corrupted. If you can load a different manager, or access Tilix, you should be able to fix things.


#9

Actually, the desktop manager seems to be starting, and my attempts to run Tilix involved getting to the Activities menu.

It’s just that no command I enter will actually DO anything. I see the little arrow chasing its own tail, then nothing.

It’s as if everything else EXCEPT the desktop manager is hosed.

I’m going to try a different manager.


#10

Then it isn’t your manager.

I would go ahead and prep your pureos usb drive.

Someone else might be able to help if you have some time. Also if you haven’t already, contact Purism customer support. They know things like this professionally, and might be able to help you not have to start from scratch.

Out of curiosity what was the last thing you did before your Librem started behaving like this?


#11

I installed a bunch of stuff (like GTK libraries, etc) to try to port my text editor (since the one that came with it blows chunks). This is why I immediately realized I would probably have to start over.

I also did a app-get update.


#12

I mean sudo apt update.


#13

I’m not sure what the combo might be on a Librem/with PureOS, but try hitting ctrl+alt+function keys - this will usually drop you to a terminal outside of the usual desktop enviornment.


#14

Ah, ha! Yes, Ctrl Alt F2 drops me into a plain text mode.

That, at least, will allow me to rescue my data before I blow the whole thing away and re-install.

Thank You!!


#15

@2disbetter, thank you for your help. Even though I’ll have to reinstall, you pointed me in the right direction on that.


#16

@SteveC when you do Ctrl+Alt+F2 and login, try to update your system: https://tracker.pureos.net/w/recommendations/upgrading_packages/

Then also re-install pureos metapackage just in case:

sudo apt install pureos-desktop


#17

“Could not resolve repo.puri.sm” returned when I tried to do sudo apt update. And the other commands shown there (such as sudo apt upgrade and sudo apt full-upgrade) return even more error messages than that.

On upgrade, for instance, it tells me

Blockquote
Some packages could not be installed. This may mean thgat you have request an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following packages have unmet dependencies:
libavcodec-extra57 : Conflicts: libavcodec57 but 7:3.4.3-1 is to be installed
E: broken packages

Doing the full upgrade scrolled for quite a time and most of the messages seem to be “failed to fetch” messages

All this, I suspect, stems from my attempting to install Gtkmm libraries so that a makefile would quit complaining they didn’t exist. (Even pkg-config needed to be installed for that makefile to work.)


#18

try a sudo apt install -f, and see if that fixes the dependency issue. Then try an apt update again. If that doesn’t work then just remove libavcodec-extra57, and try the apt update again.

If you can’t apt update, then you would be able to full-upgrade either. So get your update process fixed, and then give it a whirl.


#19

Well, DUH. I couldn’t get sudo apt update to work because I had turned off the wifi kill switch!!

But even with it turned on, I got three error messages that seem to be internal to some script somewhere.

I nevertheless proceeded with sudo apt upgrade, and it seems to have worked…so far. 900 packages!! It’s downloading almost as much stuff as the system image I grabbed yesterday.

But…it seems to have done the trick. The file manager, at least, opens and the mountain pic appears on the desktop.

Anyway, I’m at least to the point where I should be able to fix things!

Thanks to everyone!