Only limited functionalities of the touchpad with i3wm


#1

Hi,

I have switched to the i3wm window manager, unfortunately, except for scrolling up/down, I can only perform left-clicks with the touchpad. Did I have to load some particular software to ensure I get access to all the functionalities of the touchpad?

I own a Librem 13v3

Thanks.


#2

Any idea on how to solve this?

Do you need more information?


#3

Hi @montaropdf,

Do you use i3wm with PureOS? Or did you install another distribution?


#4

Hi @thib,

I use i3wm with PureOS from the purism repo.


#5

Has this been solved? If so, how? I’m planning on installing/running i3 soon.


#6

No, and I don’t know how to solve it.
To me it is like something is loaded by gnome (pureOS eidtion) but not by i3.

I have the same problem with fedora 28 I installed recently in place of PureOS (I needed more recent packages for some applications)


#7

Yep, same here. I removed a few packages including pureos-desktop and gdm3. Now, I’m seeing that problem with the touchpad. Hopefully, someone from Purism will chime in and point the way. I’ll post any progress here as there’s no way I’m going back to using that desktop.


#8

Resolved this by creating /etc/X11/xorg.conf.d/90-touchpad.conf with the following:

Section "InputClass"
	Identifier "touchpad"
	Driver "libinput"
	MatchIsTouchpad "on"
		Option "Palm Detection" "on"
		Option "Palm Dimentions" "5 30"
		Option "Tapping" "on"
		Option "TappingButtonMap" "lrm"
		Option "NaturalScrolling" "on"
EndSection

#9

I will try this this week.

Thanks.