Oops I did it again...BIOS/UEFI problem?

During my recent installation of PureOS on a dual boot dual disks brand new Linux pc, the PureOS installer prompt me to create a 10mb partition along with the other three that I had created.

I don’t remember exactly how this partition is called and I’m not even sure about its purpose. But I suspect now that this was about this UEFI thing that has confused half of the linux universe!! lol

If that is the case this was not what I had to do as the other disk that currently runs LM19 was initially formatted on a very old pc and on Bios mode.

Now when PureOS is booting it gives me an error message about AMD needs firmware support while the installed now PureOS system doesn’t use the swap partition at all.

BUT that is not a problem because my pc supports both systems and it has plenty of RAM to not need the swap partition, that as it turned out, it seems to be there just in case. I don’t mind either for the two GBs that I engaged to this swap partition as my SSD disk is 250 GB so I have plenty of space.

So here is the point. The error that is given during the boot process of PureOS does perhaps has something to do with the UEFI thing and the 10 mb partition?
And if that is the case, can I change the mode that this installation works by booting from the live usb image and deleting that 10 MB partition?

Or this 10MB partition has nothing to do with the firmware mode that PureOS was installed and the error that I get is irrelevant?

Also can someone explain to me why this installation is unable to detect the swap partition? ( not that I mind that much. I’m asking out of curiosity).

My computer’s specs are: Processor AMD Ryzen 64 bit
One SATA disc with 1TB space that currently runs LM 19 installed in BIOS /legacy mode ( the disk that came from the old computer)
One SSD disc 250 GB space where the PureOS is installed the way I described above and 8 GB RAM plus a swap on its different installation.

P.S I want to make clear that none of the two installations has any serious problem. Both boot normally, the grub is as it should be,the only difference I’ve notice is that PureOS that runs Gnome consumes slightly more of the RAM.
Half Gb more of than that of LM which runs with Mate.

This post (and the whole thread) should help understand:

Actually (as I think now), +32768 number should do the better job.

naughty,naughty … it seems you haven’t done your homework … a little research and you would have easily discovered that PureOS is a Liberated-Debian so no easy out-of-the-box install experience for proprietary stuff …

Yes but my PureOS installation didn’t fail and whole desktop after some tweaks is the epitome of sleekness. The only problem that I see is that it can’t detect the swap partition that it is there, ( I have made it ) but the system doesn’t detect it. It does detect though the GPT ( or whatever this thing is called) and boots normally.
What is this GPT anyway??

Is there a way to make this particular installation detect the swap partition without having to format again the root partition that the OS currently is. I mean boot from the usb image and run the installer and change perhaps something to fix it? Just for the sake of fixing it.

When it gives me the error message about the processor during the boot process it says that it is disabled ( probably means fixed) by the BIOS.
And I have to admit that I don’t understand at all what it is talking about because the whole installation works like a charm probably because there is more than enough RAM in order not to rely on the swap of bother with the processor’s issue.

No, you already used Calamares installer the way you used it. I’m no expert on PureOS but their original installation on Librem products doesn’t contain additional swap partition (rest is easy to understand).

I haven’t done a thing. It liberated itself and I didn’t contribute a thing on that! I’m just trying to figure out though under what terms it liberated itself. lol

I would appreciate if you could explain to me, in simple words what is going on and how I could fix this if it needs to be fixed without re installing the universe and spoiling this marvellous desktop!

I have n o clue about Librem but the option of a swap was there in the first place and so I added one just for the sake of doing so because the pc doesn’t seem to need it.
I forgot to tell you that the marvellous desktop changes wallpaper every five minutes because the people from the store that I bought the pc told me that the new and supposedly modern screens have the tendency to get “burned” and create ghost images. So I had to make a custom wallpaper that changes every five minutes in order to avoid use the screensaver that turns on in the most inconvenient occasions. When I’m reading something or when I’m watching a movie. So I made a space themed wallpaper presentation.

And I solved btw the problem with the desktop icons as you can see on the left of the screenshot.

1 Like

And here is a screenshot of the system monitor and computer’s performance on PureOS with Brave browser and system monitor running.
This particular installation consumes about 400MB more RAM than the Linux Mint one that is installed on the same pc, on a second SATA disk and runs Mate.
As you can see it says that the swap is not available, though it exists. ( I know that it exists. It doesn’t know it … yet!)

The Linux Mint already existing installation is the one that confused me because I had installed it on the old ancient pc that had only BIOS firmware and transferred the disk from the old pc to the new one. That disk worked immediately after an update.
So I had to make the second installation on the SSD disk on legacy mode too otherwise I would had to re install the Mint in UEFI compatible mode and that would have been more complicated as I would have to resize the root partition and risk to lose the loads of data that I have on the SATA disk.

Anyway. The PureOS installation seems to work decently even though it gives this error during the boot.
If this error is not of the fatal ones, I think to leave it as it is.
Unless it is destined to die during the next update… !lol

Ok… Here is the situation with a lot of details and suggested solutions that might help you too. If you are wondering how I manage to copy these errors in the half second that they popup on my screen during the boot, the answer is that I waited patiently to photograph them! lol

So let’s go to the point. I don’t get one error during the boot of my PureOS installation but three.


`Unable to write to IOMMU perf. counter`

This is according to what I read online a common bug that appears in some kernels, ( and obviously the kernel that PureOS Hephaestus has).

It seems to be a warning that doesn’t usually harms the boot ( though some claim that it does).
I tried all the suggestions regarding editing the grub, (where I found another error too) but they didn’t work in my case.

There is another suggestion to patch the kernel and another one to change the settings of the bios, something that is not applicable in my case as I have a second disk on the same system and any changes to the Bios/legacy mode that I currently use might affect the other installation too.
You can read more about this on the following links.




The second error that I get during the boot of PureOS installation is the following.

[drm:amdgpu-pci-probe [amdgpu]] *ERROR8 amdgpu requires firmware read https://wiki.debian.firmware

The solution for this error is here:

But in order to apply it on my installation I have to ask first if the Amber repositories that PureOS uses have the firmware-linux-nonfree package or packages.
If there are no such packages in any of the repositories, then I would appreciate if you could inform me which debian repositories are more suitable to use in order to install the non free firmware that is needed for the AMD Ryzen processor that my pc has.


kvm disabled by bios

And I’m asking: WHAT???! What is this? Is it related with any of the above?

And finally regarding the swap partition that wasn’t detected from this installation. It seems that this partition is not even needed in SSD disks. But it is still there and I’m trying to find a way to mount it as swap on the system.
If you know how to do that please enlighten me.

1 Like

if you insist on running PureOS (Purism’s Debian liberated and modified OS) then test the latest and tell us if you encounter the SAME issue.

here you go > https://downloads.pureos.net/byzantium/gnome/2021-04-16/

1 Like

The kvm is the Kernel-based Virtual Machine. If your processor/motherboard support virtualization, you may need to turn it on in the BIOS. If not, well, there is nothing you can do about that.

As far as mounting your swap partition, check the /etc/fstab file. It should have a line similar to this

UUID=<uuid-of-swap-partition> none            swap    sw              0       0

Where <uuid-of-swap-partition> is replaced by the actual UUID. This will mount the swap partition at boot.

1 Like

Thank you for the suggestion but I’ll stick to the Hephaestus because I tried the live image of Byzantium and didn’t work properly. The Hephaestus though works normally no matter if it gives warnings.

Thank you very much. I’ll try both.

this is outdated

the newer one is:


1 Like

Something new in this Byzantium image is initial support for EFI. But, the operative expressions here are initial support and Testing version.


Sorry to say this but if Byzantium is not available on the official PureOS website then it should be wise to point out that all of these versions are for testing purposes when you recommend them to new users.
I personally wasn’t able to download Byzantium on the website, someone gave me a link towards one of the versions of its iso image. I tested it and it didn’t work properly.

Anyway… My point is that you should not recommend to people who are asking for information or help to use the new release if that release is not in its final and official version.

i suppose so, but even if the “Devel” name is not visible in the linked url form, you can still read it clearly as “Devel” (development) if you visit the link and have a look at the main .iso file (about 2GB)

I’m not saying that is not visible.
I’m just saying that if this new version is not yet officially released then it is not wise to suggest it to new users as the whatever bugs and malfunctions will discourage them to install PureOS on their computers.
It is not wise to suggest it from the “marketing” point of view, if you get my point, particularly if you try to attract more people to this particular distro and
the cause that is supposed to promote.
It is one thing to have some bugs on the official release, but is a completely different thing to suggest the developer release to new users, no matter what is their experience on linux.

okay, i’ll let this matter rest then … RIP !

unless the mods or somebody acting in a Purism official capacity drops future links in the forum regarding PureOS-devel i will NOT intervene further regarding this matter.

this version is already used on the Librem 14 and Librem Mini v2, due to the more recent kernel version required by the CPU that both devices use.

What is still missing is the update path for users of PureOS Amber on older devices like the Librem 13 and 15.

And works fine with coreboot+seabios or coreboot+heads. What is experimental in them is the initial EFI support. Which should allow for PureOS to boot with UEFI devices without needing Legacy BIOS mode, and Libreboot. It also opens up the door to test Coreboot+tianocore.
I used the expression testing version as a force of habit because pureOS Byzantium is based in Debian Bullseye, which is still considered testing by Debian’s release structure.
But it should move to stable in a few months.

1 Like