OpenBSD on Librem?


#1

Has anyone tried running OpenBSD on a Librem laptop? Does it work?


#2

FreeBSD has been reported to work, I am not sure about OpenBSD — however, there is no reason why it wouldn’t work.


#3

I suspect you’re right, but it would be good to hear from someone that’s actually done it! Looks like there’s a 10% restock fee, so buying a Librem, trying OpenBSD on it, and returning it if it doesn’t work will take time and $ or all involved. I might be the person that decides to take that on, but I’d hate to waste the effort if its already been done. Therefore, I ask. :slight_smile:


#4

I have just installed OpenBSD 6.1 on my Librem 13 rev1. dmesg shows everything is recognized, but I don’t know how to setup internet connection for example, install browser and test all this. And I am afraid I am not interested in learning how to do all this (nor do I have much spare time).

Librem 13 rev2 is slightly different hardware then my Librem 13 rev1 though (newer CPU, DDR4).


#5

Fair enough, thanks for sharing! A dmesg would be great, if you still have OpenBSD installed…you’d probably want to plug in a USB drive, mount it, and copy the dmesg onto it so you can use your normal laptop to post it. If not, no worries, its good to know you got as far as you did.


#6

Ha! I don’t have it anymore! :sweat_smile: But I’ll install it again. :slight_smile:

With FreeBSD I’ve found out that nor Broadwell (rev1) nor Skylake (rev2 of L13) are supported, so there’s no graphic acceleration: https://wiki.freebsd.org/Graphics#Hardware_Support (you need to use generic graphic driver in order to be able to start your desktop environment).
Perhaps this is the case with OpenBSD, too? I’m going to investigate this thoroughly before trying it again…


#7

Looks like Broadwell support is in, Skylake is not:

http://www.tedunangst.com/flak/post/openbsd-laptops
https://man.openbsd.org/intel

Some folks prefer the ‘wsfb’ driver for non-accelerated X on Skylake + OpenBSD. Mentioning that in case you start getting ambitious. :wink:


#8

And Skylake is in 6.1-current, which is to say, it’ll be in 6.2:

http://www.tedunangst.com/flak/post/openbsd-changes-of-note-624


#9

Thanks for the links! I am having troubles finding anything on BSD website. FreeBSD has much better documentation and website organized.


#10

I tried installing 6.1. I used softraid to do full disk encryption.

If I closed the lid, multiple file systems were corrupted upon resuming, and they remained unrecoverable through several reboots.

I would love to be able to run OpenBSD either as the base OS or via Qubes. (Qubes 3.2 also crashed when resuming from hibernate or suspend.)


#11

Hi,

I have now a librem 13v2. Running 6.2-beta works quite well. As mentionned by others the Skylake Graphics card is now fully supported. I’m running with softraid full disk encryption and suspend/resume works.

Appart from the non-supported wifi chipset, the most annoying part is the lack of CPU frequency scaling support, since Coreboot’s ACPI tables don’t include _PSS objects.

Please, Purism, consider providing those in a future Coreboot update !