Org.freedesktop.systemd1 failure

Something major seems to have broken on my PureOS install. I first noticed something wasn’t working properly when I was trying to get a virtual machine running, and I was attempting to convert an .ovf file to .qcow2 so that virt-manager could run it. When using qemu convert I received an error that org.freedesktop.systemd1 timed out. The system would hang for a while and then the service would time out again. I tried looking into the problem, restarting the service etc, according to different forum posts, but nothing was solving the issue.

Eventually I came across a post that suggested running apt-get update so I updated and upgraded the system. Apparently I hadn’t done this is a while, so it took some time, but I soon realized that in the middle of various packages unpacking, the same freedesktop timeout error would pop up a couple of times, before the update process continued. When it was done, I ran apt-get autoremove and the system suggested I apt --fix-broken install because one of my packages required a later version of tor than what I had. This command hung at 0% though, and after a while errored out.

I decided to reboot my system, but using the GUI’s power button did nothing, so I hard rebooted. Now upon booting into my system, I’m unable to log in through the GUI. My account icon is empty, and when entering my password the screen goes blank for several seconds, some text flashes in the upper left corner and it kicks me back to the login screen. I CAN still get into the system through tty2 via ctrl+alt+f2 but I need the GUI to run virtualization. I have no real idea where to start looking for this issue, but I have access to my logs.

Can anyone help me fix my system? I need it working properly again ASAP for my college courses.

You say the account icon is empty on the GUI, but you can still login to the terminal?

I would try

sudo apt update
sudo apt full-upgrade

If that works, then reboot. If not, then report back with whether you see the same error or something different.

1 Like

After running apt full-upgrade, I got the same message as before, telling me I had unmet dependencies and to run apt --fix-broken install, which I had done before. But I ran it again just to see, and now everything magically works after reboot.

At least I think it does. Thanks. I had backed up my important files and was about to just wipe and install Kali. Now I don’t need to.

1 Like