OS Change Problems

I have a Librem 13 v4 with Librem Key, only two weeks old. I really do not like PureOS and I am trying to install Linux Mint. I have Mint ISO on USB ready to install but can’t seem to get it to install. Does anyone have a guide or steps to follow to get Mint installed? It seems the Librem Key is getting in the way. I can log in to PureOS but it won’t even factory reset. Almost ready to return this laptop. Everything from OpenVPN issues to updates erasing settings in PureBrowser. Never had so many issues changing a Linux OS. :frowning:

What specifically is going wrong? Are you just having trouble getting the laptop to boot from the flash drive, or does the problem occur once you’ve booted up?

1 Like

It boots to the flash drive, I can get to Choose Boot Option which shows Start_Linux_Mint as well as other options but when I do, it just boots back into PureBoot Main Menu again. I’ve tried all of the options, even OEM reinstall and basically can only boot into Default. And in default the terminal is now all messed up as all the keyboard keys have been reassigned to random keys (wtf?) but only in Purism’s version of CP- tilix or something. I’m so sorry, I’ve been using Linux for years now and have never had this much of an issue with a distro. :frowning: Usually when I have issues, it’s fixed by a backup and reinstall, but I can’t even do that. :frowning:

Never had this much of an issue with any Linux distro.

When in the Default terminal, are you able to use loadkeys to change the layout?

The automatic reboot behavior sounds similar to when you try to use a non-bootable image. How did you put the image on the flash drive?

1 Like

No, each key stroke is not the proper key anymore, thus loadkeys is 36ADEYS. Besides installing Librem One via instructions per Purism, updating, and basic browsing, I haven’t really had the chance to do anything. In the past when I have such issues, it’s been me installing or doing something that has caused a reinstall, this time, nothing. Had initial problems with Liberm Tunnel not working. It would say it was connected to the VPN server but returned my physical IP. Reinstall steps of Librem Tunnel did nothing so I figured I go to a distro I knew better, Mint, went to install via usb iso and get in the loop I described earlier.

How did you put the image on the flash drive? Since UEFI became standard I’ve had a hard time getting bootable ISO’s to work using anything but dd to write them to a flash drive.

1 Like

I first tried using PureOS via the terminal but ran into key stroke issue. So I went to my Windoze laptop and downloaded the Mint ISO burned to USB via Win32diskImager, which may be an issue now that I think of it, but it’s visible as an ISO at boot options… so confused lol!!! :frowning:

Win32DiskImager should be fine. Maybe try a different distro? Fedora has an automatic writer for flash drives and CD/DVD’s. Even if you don’t want to use Fedora, it’ll let you know if you’re able to boot from a flash drive.

1 Like

Okay, I will try Fedora and report back.Thank you very much!

OMG you are my hero Jt0! Fedora is installing. I’d buy you several drinks if I could!!!

Glad I could help! You can try using dd to write the Linux Mint image from there if you’re still wanting to install that. I’ve had success with the command line instructions here.

After full install of Fedora, I still get into a CoreBoot loop…
I was able to get in and install Fedora via LiveUSB…

I mean PureBoot, that is what seems to be the issue here.

Or that f****** Librem Key…

I’m stuck at the Fedora installation. It won’t let me install a large enough partition…

I just want to remove all GPG. Can’t, even reformat won’t do it. I’m ready to destroy this thing…

I’m not familiar with how the Librem Key works, but you might find this documentation useful.

Alternatively, the installer may just be attempting to use a small amount of free space and install alongside PureOS. You can try doing manual partitioning and marking all existing partitions for deletion.

I’m able to replicate the issue and will investigate

1 Like

well yes, formatting and firmware are separate things.

You don’t want to use the security features of PureBoot and the Librem Key? You can flash back to our standard coreboot/SeaBIOS firmware. Or, we can help you understand how PureBoot works, and help you get your preferred configuration sorted. Either way, if you want real-time support, our Heads community Matrix chat room is your best bet.


Thanks. I created a Matrix account and logged in. Awaiting a response in the Heads room. Thank you for pointing me in the right direction.