OS Updates troubles

I hadn’t used my L5 for a while, a while back I decided to try playing around with it. My first thought was, “Well, I’m sure after so many months there must be updates.” In the PureOS store there was an “OS Updates” When I tried to run the update, I got the error message, “Unable to download updates: The following packages have unmet dependencies:”

In the past when I’ve had this problem running sudo apt dist-upgrade in the terminal fixed the problem. But that hasn’t been working for me in this case.

Running sudo apt upgrade shows six packages held back: gnome-settings-daemon-common, librem5-base, librem5-base-defaults, librem5-gnome-base, nautilus-data, and pureos-store-common.

Just for giggles I tried running sudo apt upgrade librem5-base. But it showed this as the result:

librem5-base: Depend: modemmanger but it is not installable E: Broken packages

So, I tried running sudo apt install modemmanager just to see what it would propose to do, here is that output:

modemmanager is alread the newest version (1.18.6-1pureos3).
modemmanager set to manually installed.

  1. How do I fix the broken packages problem so I can upgrade the OS and the six held back pacakages?
  2. Why does the phone think modemmanager needs to be installed in order to upgrade a package when it is already installed?

Really confused…

Maybe this: PureOS update fails with unmet dependencies

Please post the non-pointless lines of /etc/apt/sources.list here or otherwise confirm which repos are in use.

You may want to reverse that.


I would reverse the modemmanager being set to “manually installed”, except… I don’t know what it means. I don’t know how it got set to be manually installed - or I don’t recall how that happened - and I don’t know how to reverse that.

output of /etc/apt/sources.list:

deb https://repo.pureos.net/pureos byzantium main
deb https://repo.pureos.net/pureos byzantium-updates main
deb https://repo.pureos.net/pureos byzantium-security main
# deb http://us.debian.org/debian bullseye-backports main
# deb https://repo.pureos.net/pureos octarine main

Use sudo apt full-upgrade.

I see you have bullseye-backports and octarine enabled. If you installed anything from there, you will have to take care of dependency issues yourself, as there’s no guarantee whatsoever that these repos will play well with byzantium.

“manually installed” means that the package was explicitly installed by the user e.g. with apt install ... rather than implicitly installed by virtue of being a required dependency, directly or indirectly, of something that was explicitly installed by the user.

It got set that way when you manually installed it just now just to see what it would do.

If a package is currently installed but was only implicitly installed then explicitly installing it will cause the message: xxx set to manually installed

apt-mark showmanual modemmanager

to confirm that modemmanager is indeed now marked as manually installed then

apt-mark auto modemmanager

to reverse your recent action and make it again marked as automatically installed.

I have those two repos commented out, I failed to show the “#” character in my post, I’ve edited that post so it appears now. I don’t THINK I have anything installed from those repos, haven’t figured out how to tell what might be installed - if anything - from those repos.

sudo apt full-upgrade does not work, output says: “6 not upgraded”

Could you try:

sudo rm /var/lib/apt/lists/*
sudo apt update
sudo apt full-upgrade
1 Like

# as a character has special significance to the markdown language used for the forum software used here. You need a backslash character in front of it in order to show the line commented out. However by non-pointless lines I meant don’t even show comments or blank lines. For example

grep -v ^# /etc/apt/sources.list

will strip out comments.

sudo rm /var/lib/apt/lists/*
sudo apt update
sudo apt full-upgrade

dos, thanks for the suggestion, that seems to have solved the problem. Two questions:

By following your suggestion, what exactly did I do? And, since this seemed to have solved the problem, what does it tell us was wrong with my phone?

1 Like

The output of grep -v ^# /etc/apt/sources.list is:

deb https://repo.pureos.net/pureos byzantium main
deb https://repo.pureos.net/pureos byzantium-updates main
deb https://repo.pureos.net/pureos byzantium-security main

(P.S.: Thanks for explaining the manual vs auto install marking thing.)

1 Like

Looks like the package list for all architecture has been updated, but arm64 one was kept outdated for some reason. It would probably correct itself with time. We are experiencing an issue with apt’s lists staying outdated for some reason, but we weren’t able to figure it out yet. What you did with these commands was to simply remove all the already downloaded lists and force them to be redownloaded from scratch.

1 Like