OSM Scout Server says "server stopped" after downloading a map

I am trying to get OSM Scout Server working with Pure Maps so that I can use Pure Maps offline. OSM Scout Server is not working for me. After I download a map, it just says “server stopped”. Here are the steps I took to produce the problem.

I’m running PureOS on the Librem 5 and installed Pure Maps using the command:

$ flatpak install flathub io.github.rinigus.PureMpas

which worked. I was able to open Pure Maps and navigate with GPS. I then installed OSM Scout Server using the command:

$ flatpak install flathub io.github.rinigus.OSMScoutServer

which installed without any apparent problems. I started OSM Scout Server using the following terminal command:

$ flatpak run io.github.rinigus.OSMScoutServer

I then opened “Map Manager” in OSM Scout Server and downloaded Mapbox GL World overlay, Mapbox GL fonts, and Address parsing language support. These downloads appeared to complete without problem.

I opened Pure Maps and under “Profile” selected “Offline”. I was able to use the low-resolution world map offline in Pure Maps.

Then, in OSM Scout Server, I opened “Map Manager” and clicked “Subscribe” and selected North America / US / Hawaii and clicked “Start download”. After it downloaded, there was a message that said, “Unpacking files”. After about 30 seconds I got a message that said:

“OSM Scout Server is not reachable. Waiting for it to appear.”

In terminal, I got the following output:

kf.kirigami: Failed to find a Kirigami platform plugin
file:///usr/lib/qml/org/kde/kirigami.2/private/PrivateActionToolButton.qml:76:5: QML Binding: Binding loop detected for property “value”
qrc:/qml/elemenCountryListItem.qml:26: TypeError: Cannot read property ‘width’ of null

qrc:/qml/StartPage.qml:283: SyntaxError: JSON.parse: Parseerror

This output didn’t change for at least 10 minutes, so I closed OSM Scout Server and ran it again. This time, I got a screen which said:

“Initializing and waiting for connection with the server”

and text which briefly said, “Activating server via DBus” before changing to “Server Stopped”. I get the following output in the terminal:

kf.kirigmi: Failed to find a Kirigami platform plugin
file:///usr/lib/qml/org/kde/kirigami.2/private/PrivateActionToolButton.qml:76:5: QML Binding: Binding loop detected for property “value”

The “server stopped” error message persisted for at least 10 minutes until I closed OSM Scout Server.

OSM Scout Server created a “Maps.OSM” directory in my home directory. When I delete this directory, I am able to start OSM Scout Server again and return to the Map Management screen. However, when I try to download a map again, the same process above repeats.

Please let me know if there is something I am doing wrong.

I believe the server goes to sleep with inactivity by default (at least I remember seeing that in the initial setup dialog) but I’m assuming it should also wake up when a request is made…I’m installing it now and downloading maps, I’ll report back here what I find.

I’m getting the same error but this is what I’m seeing: “loading style failed: Connection refused” is displayed in Pure Maps. journalctl gives me a “gclue_locator_set_time_threshold: assertion ‘GCLUE_IS_LOCATOR (locator)’ failed” when tailing the log.

Firewall problem?

When I start Pure Maps first without starting OSM Scout Server, and I choose Profile > Offline, then I also see the error message which says,

“loading style failed: Connection refused”

However, when I start OSM Scout Server first and then start Pure Maps and choose Profile > Offline, I get no error message in Pure Maps. I am able to see a low-resolution world map in Pure Maps. The high-resolution data is still not visible when I zoom in to Hawaii (which was the map I downloaded).

In the OSM Scout Server window, I still see the “server stopped” message, and I do not have the ability to select any options to change settings in OSM Scout Server.

dont think its a firewall problem because the osm server is running right on the librem itself.

Yeahbut you can have a firewall running on the Librem 5 itself. There are other mentions in this forum of some firewall running by default that customers are not aware of - which of course normally could be a good thing. So it’s one thing that should be checked for.

Do we know what port the server is supposed to be running on?

Based on one of the comments here:

would it be correct to assume OSM Scout Server is using port 8553?

Also, are there any other dependencies I should have installed besides Pure Maps and OSM Scout Server?

At the end of that thread it kind of says we’re dead in the water here. I’m not sure exactly what he’s referring to though.

Same issue for me. Similar to this maybe? https://github.com/rinigus/osmscout-server/issues/345

Yes, but that thread was for a different issue. It does have a reference to the port number though.

Yes, the failure mode does sound similar to the issue described in that thread. The error messages are different though.

Since multiple people are having this same issue, should this issue be reported to rinigus on Github?

1 Like

From what I have searched it seems to be happening on other OS’s other than Pureos so maybe there is something that has changed with the kernel that he hasn’t accounted for?

I tried installing Pure Maps and OSM Scout Server in Debian bookworm on a PinePhone and I get the same behavior.

Pure Maps works, but OSM Scout Server says,

OSM Scout Server is not reachable. Waiting for it to appear.”

after downloading a map.

When I close OSM Scout Server and restart it, it says, “Server Stopped”.

Latest update of OSM fixes this issue, I just loaded up Pure Maps successfully with offline maps.


I confirm that it works now after doing flatpak update.

The server works for me as well. What doesn’t work too well is finding my location. My position seems to jump between my actual position and south of Africa in the ocean

i.e. latitude 0°, longitude 0° ?

Yes. That makes sense. Some sort of default when signal isn’t found maybe?