Outbound calls drop while inbound and SMS work

Hi, I just got my Librem 5 yesterday and I’ve managed to get it working quickly. The SIM card registers on the network (sim is from BT mobile in the UK) and I can use:

  • Mobile data
  • SMS
  • Receiving calls

However, I cannot make outgoing calls. All I see in the UI is it attempting to call out, and then it just hangs up, and no call is received on the other end.

For additional context, I’m in Netherlands, and I am using a UK sim in it, with all the Roaming stuff turned on.

I also fully updated my phone yesterday too, so it’s not likely to be related to old software versions.

P.S. thank you for finally sending it out, really great to hold it finally and see how far it has come. My next stop is playing with the smartcard.

1 Like

Are you 100% sure that placing outbound calls works with this SIM using a different phone?

Is there maybe something you might have to enable that you’ve missed in your online account settings panel?

The reason I ask is that inbound calls are probably free with most European carriers, whereas outbound while roaming internationally might be chargeable, right?

You would want to see whether an incoming call is using 3G or is using 4G i.e. see whether this could be a VoLTE issue.

Ah, when I make or receive a call the display switches from 4G to 2G, could that be related?

Fair question. I certainly don’t have any limits on the SIM that I’m aware of, I’ve used it for years, and it’s normally a dual sim in my main phone, and can make calls data text etc without restriction. so, I would be a bit surprised if putting it in a different phone caused limits to be imposed!

Yeah, it was my main SIM for years, and then I moved country, and I kept it as a second SIM in a dual sim phone since then, but I have never stopped using it. It’s been in Android and iPhone phones too. No issues thus far.

And I believe if the SIM was being locked by the carrier it would not work for anything.

This means that VoLTE is not operational; otherwise it would remain on 4G/LTE during the call.

Do you have the BM818 Tool installed, with VoLTE enabled?

If you already have it enabled and calls are still dropping to 2G, then either your carrier isn’t implementing VoLTE on their network (or the foreign network isn’t doing so for the BT SIM*), or the carrier isn’t implementing VoLTE for the L5 (actually the BM818 modem, which is in common use in the automobile industry).

*Since you’ve used the SIM successfully in other phones, you can probably rule that out.

OK I’ve installed the BM818 Tool and ensured that VoLTE is enabled (restarted phone etc. too), and still dropping to 2G during calls, and outbound calls not going through. Carrier here is KPN NL.

Maybe ask the carrier whether customers are supposed to be using VoLTE.

If you know someone else using that same carrier, maybe check on their phone. (On an iPhone, for example, if the carrier has made VoLTE mandatory then the VoLTE setting simply disappears, otherwise there should be a setting for it that you can check.)

I found this: https://www.phonetravelwiz.com/buying-a-sim-card-in-the-netherlands-guide/

(Find “VoLTE” in the above webpage.)

May or may not be relevant.

1 Like

Because this is “roaming”, I think the OP is going to have to ask i.e. whether that counts as pre-paid or post-paid or neither i.e. basically what the requirement is.

If VoLTE is relevant at all then the OP will need to confirm that the modem firmware is up to date.

1 Like

I’m in the US and my outgoing calls are doing the same dropping off and not going through. Incoming calls work fine. I have a local cell carrier that has Verizon as a partner and the phone defaults to Verizon. My local carrier still uses 2g calling, but upgraded their SIMS for VoLTE.

Everything else works. Data didn’t work at first and did after I added my carrier’s APN.

1 Like

I was having trouble making calls, receiving them fine. I changed my settings to 4G only and it seemed to fix it. Or it was just a timing thing.

1 Like