Partial keyboard failure

Hey everyone,

while I really like the Librem13v3, I encounter some technical problems, This includes the known screen flickering issue (haven’t managed to fix that yet) and the keyboard recognizing pipe key issue (solved), occasionally it won’t boot on first try (no clue) and full disc encryption stopped recognizing the password at some point so I had to fully re-install PureOS without full disc encryption. However now I have encountered a problem that fundamentally stops me from using the laptop for its intended purposes.
Since evening Saturday/Sunday morning, a whole area of my keyboard stopped working. However, this problem starts after I enter my password in the log in screen. If I lock the computer / after it returns from sleep the problem persists in the log-in screen as well until reboot.
This makes me hope that this is a software issue (a hardware issue would be very bothersome as I’m located in Europe). The laptop has a German keyboard layout and was shipped in the end of 2018.

Underneath you can see the problem visualized, where “|” represents a key that is unresponsive. A special case is the “.” key as both the , and the . key return a “,”.

<yxcvbn|, ,|

I hope that someone can help me with this issue, I’m a non-expert user who until recently used Windows-only, so please excuse me if I get some stuff wrong or don’t understand your response right away. I’ve tried browsing the forums and using the search function but couldn’t find a thread or solution for my problem.
I hope that someone can support me in this problem as I’m willing to use a laptop that takes some work to maintain and whatever but I also really need my laptop for work and so far this is the most severe issue I have in that regard.

Thank you in advance for your time and help

Update: I ended up re-installing PureOS and the problem is apparently solved. I still don’t know what the problem was but I assume it was some software problem and it seems to have been somehow connected to the accessibility features (see below).

I recently downloaded the latest PureOS from and installed it on a new SSD. I’d been running the PureOS that was shipped with my Librem 13v2 in late 2017.

I was expecting to fix the “|” key problem again, but it was not needed. I don’t know if it was fixed in the latest PureOS, or if the fix I applied originally is at a lower level than the OS. (I forget how I did it over a year ago.)

I’m getting proper behavior with the “.” and “,” keys. Haven’t had that problem.

Another pleasant surprise is that OpenVPN is now included along with Network Manager support.

while I really like the Librem13v3, I encounter some technical problems, This includes the known screen flickering issue (haven’t managed to fix that yet)

At least for this one I can say that if this addresses the LCD LED backlight flickering when running on (low) battery, then we will hopefully soonish have a software fix for that. It seems that not only some Librem laptops suffer from this but quite a larger number of laptops of different brands but which share Intel chipsets. The problem seems to be in the backlight PWM frequency having some (cause unknown) side effect on other parts that in the end causes the backlight to modulate or flicker. Increasing the backlight PWM frequency from the default about 200Hz to something higher seems to fix it (successfully tried on a hand full of laptops that failed).

You can try yourself by installing the Intel GPU utilities:

sudo apt-get install intel-gpu-tools

and after that issue something like

sudo intel_reg write 0xC8254 0x03ff03ff

The problem is though that this new setting will get reset every time when the display gets blanked / switched off (e.g. by a screensaver). We are now investigating how to best make this setting permanent.



Thank you for your quick reply!
Good to know that a fix for the screen issue is being worked on. As the flickering is only a nuisance and not a fundamental problem for me I can wait for a permanent fix on this. The keyboard issue however is fundamental for me as always using the screen keyboard or an external keyboard will not allow me to use the laptop properly.

It have a new lead: following the advice in another forum ( I noticed that turning off the “mouse keys” feature from the accessibility menu changes my problem, but it won’t solve it.

The affected keys (see above) now do something, but not what they’re supposed to. They now return:

<yxcvbn0, ,+

So they seem to behave like a numpad, using the affected keys with Shift + key jumps to the previous line, to its end, next line and so on,

I feel like this may be solved by re-installing the firmware for the keyboard or something like that but I have no clue how I would do that or if that is a reasonable choice (I don’t want to get stuck entirely without a keyboard if it fails).
Any advice?

hi there! :slight_smile:

this is kinda much of an interesting stuff, i still dont own such a notebook, just planning it for the not-so-near future, but that numpad-like behaviour is like the [fn] key is playing an important role in the issue, so you can maybe experiment with it.

i can totally feel the pain, however i only had strange letters in place of őűŐŰ (hungarian stuff) in my x11 based gui toolkit (tekui - its a pretty great tool anyhow, but its not flawless; ) and the best i could do so far is monkeypatching it inside tekui like override some keycodes around its message processing instead of fixing its driver, and as i had some smaller or bigger researches around, i know that you can remap keys in x11 as a workaround, and that will serve u well in doing ur business til theres no better solution…

bests! :slight_smile:

I have had these issues with my Librem 15V3. I try to type in a password and I have to do it over and over sometimes. The problem comes and goes. Right now it is doing it and I can’t mount the 120G disc installed in the computer itself because the password isn’t working. Luckily, I have nothing on that drive that I need which is why I have nothing on it. I want to make sure everything is reliable on this computer before I put anything important on it. So far, so good except for this present password problem and a previous one which required me to re-load the entire operating system.

hi there! :slight_smile:

maybe you could try to type according to an another keyboard layout, like youve set it up on your own language and every chars match with your expectations, but thats a user-based setting (the keyboard layout) and when the machine is about to bringing itself up, then the layout gets a (probably english) default before you log in… or anything similar with different languages, you will know… anyhow, this is the 1st thing i would suspect… maybe you can also try an usb keyboard to figure out whats going on, or add a(n additional) new pw to your disk thats free from layout differences if thats possible (so basically if you have a language based on latin letters…), and my final guess for now is to check out your partitions, fstab, and crypttab, like if there is a key file on an unmounted partition or whatever like, but this is not where i would make my 1st tries, but this is still a good-to-know… a gratis debug option is to try ctrl+alt+f1 to switch to tty1 (ctrl+alt+f7 switches back to tty7 where you started from, but if not, then you can try out any of f1-f12 keys with this combination, or read a bit about these if you wanna be sure about what you are doing with them :smiley: ), or enter into the grub shell and try out the early-boot layout of your keyboard anyhow with these, as the pw input wont show you what happens actually…

have fun, and good luck! :slight_smile:

Thanks, Hippi. I can try some of what you suggested but I am seriously a newbie to GNU/Linux and not as adept at this stuff as many on here.

SOLUTION (for the record):

This is caused by the unusual fact that the Librem13 keyboard includes “NumLock” key even though the number keys are not marked an there is no indicator LED showing the NumLock status. So if you strike that key while doing something, you will get a part of your keyboard converted to a numeric input, with all the keys you normally get on a dedicated numeric keypad. The problem is worsened by the fact that some user interfaces remember the state of that key even across a reboot.
Just strike the “NumLock” key once again and your input should be back to normal.

This can be a real bugger, especially once you realize the simplicity of the solution :smiley: