Phone crashes (shutdown) after bluetooth connection to device

Hi all,
Tried through Gnome UI and terminal.
With bluetooth mouse and keyboard, and same result while connecting usb bluetooth doogle!!!
For a few days (weeks?), connecting/pairing old/new bluetooth device makes crash the system. I have to restart.
Thanks for your help!

How does the system crash, does it shut down or does it hang? Personally I’ve only paired one pair of headphones and one keyboard which works fine.

Regardless, maybe you should provide some logs of when that happens. Run the following to show the logs of the current boot

sudo journalctl -xe

And the following for the previous boot

sudo journalctl --boot=-1

Don’t paste the whole log here, as it might contain private information about your device. Just pick the part of the log which seems to be related to the Bluetooth issue or kernel crash (most likely at the end of the log).


thanks. I will do the logs in the next days because I don’t have yet a wired mouse to copy the output of the terminal…
I tried again:

  • reflashing the phone / rom image. Even after that !
  • with hks wifi / bluetooth off
  • with other bluetooth usb dongles

It is always the same problem as followed :

  • immediately happens after pairing or connecting the mouse or even usb bluetooth dongle
  • the screen gets immediately black but seems still active because the background light is visible.
  • nothing happens
  • then i press shortly the power button
  • the phone displays ‘librem 5’ without wheel, and shuts down
  • then i must start the phone 2 more simple press on power.

For months i was using bluetooth mouse without problem. Just recently some problem with the bluetooth keyboard but was ok. Recently suddendly this big problem happens/

This is a bug in phoc version 0.8.0-1~pureos1~amber1 which is fixed in 0.8.0-1~pureos1~amber2 - it’s already available in amber-phone-staging and should migrate to regular amber-phone repos in a few days.


For completeness, also here: Updating phoc to 0.8.0-1~pureos1-amber1 breaks USB mouse support?

Thanks. I have installed it manually through adding the repo to source-list and it works perfect again!!!

1 Like

Fixed version 0.8.0-1~pureos1-amber2 has just migrated into amber-phone.