Phone dead. 123

L-5 won’t recharge.

  1. phone was attached to Hoyoki dock as usual.

  2. It’s power was at 98% - that’s max when displayed (I already read those related articles).

  3. Powered phone off.

  4. Disconnected from dock

  5. All 3 switches set to Off

  6. Powered on waited for ‘crypt’ message.

  7. No crypt msg, no screen change, no power On/Off light. Nothing…

  8. Connected L5 into L5 power adapter. Red light blinked on, then off then nothing. Left power connected and turned switches Off ^ waited 1 hour.

  9. 1 hour later tried power-On. Nothing, no lights - nothing.

  10. Disconnected power from adapter. Tried to power-On, nothing.


Did you try reinserting the battery? It’s not to hard to do this.
Remove the backplate (I use an old credit card for the job) and next you can remove the battery. Put it back and normaly the L5 will boot again.

1 Like

if red LED is blinking when connected to adapter - it means phone is too hot to charge / function.

Can you boot with the battery completely removed? i.e. with power adapter connected and with power.

1 Like

Plan A: When my phone has become unresponsive, I’ve had success with pressing and holding the power button for a long time (15-30 seconds), waiting for a few seconds to check for activity; if nothing, then doing another long press (usually, 3-5 seconds IIRC). This controls the firmware of the device and is independent of problems with software (unless there’s an issue with the firmware, obviously, but that’s not a common issue to inadvertently find yourself in).

I’ve been able to do this with a hot phone while camping in hot weather (e.g. when the phon is very hot to the touch and the notification LED blinks constantly while powered).

Plan B: Try Plan A with the battery removed. If it works, it doesn’t necessarily mean that the battery is bad. It likely means that things just got in a funky state. Happens sometimes.

Plan C: Thoughts and prayers. Just kidding. Maybe there would be answers elsewhere in the forum or contact


That means the battery is fully charged. Definitely try @JCS 's “Plan A”. Keep the power button a LONG time, then release, then a short time to turn the phone back on. You shouldn’t need to remove the battery.

1 Like

Too bad doesn’t have a brick and mortar store. You could do a Monty-Python skit like the parrot.


I don’t recommend putting 4 million volts through the Librem 5 though. :wink:


Why not? Isn’t 4 million enough?

1 Like

Yes. On boot, the light blinks red (or orange), and if I pick up the L5 very gently BTW, pwr goes off. Boot again, log in, and move L5 even a bit, and pwr gos off, light still blinking, boot again…
Maybe I can send it back and they hotwire the pwr or use a good USB-c female.

I used @shopping4purism then @JCS suggestions.

Removing battery and replacing battery brought it back from the dead. For now.

  • I put pwr connector back in and boot brings up the green light - then nothing.
  • I removed the pwr and tried boot - no lights - nothing.
  • I replaced the pwr and it boots normally.
  • I pwrd off and tried to start w/ Hoyoki. Nothing.

tried other combos but only one boots properly. Remove/replace battery then put pwr plugged in.

Problems with this set up:

  • I need a very long pwr cable in order to consider it a ‘mobile’ phone.
  • I need to remove and replace battery before each use after pwr-down.
  • I cannot use a external keyboard/mouse/monitor to replace psycho-tap.

This L5 is of no use without a external keyboard/mouse; monitor is a plus.
Maybe when the Lapdock is back in stock.

I have the re-flash the flash instructions. Final resort.


I had this problem a while back and I just pulled the battery in and out, and experimented with different combos until it started working. :roll_eyes:

Yes, sounds like the connector is loose. With no battery installed, you are reliant on a solid connection with the USB-C cable - and, without a solid connection, just bumping it will cut power.

1 Like

The cable has rarely been removed and when I did, made certain I was pulling and pushing keeping it straight and not pull up or down.

  • At night, I left L5 plugged into Hoyoki dock to charge. Then power off.
    In the morning, I’d power on. Green light comes on, then out then nothing.
    I must unplug from Hoyoki, Power on again, and make it to desktop.
    Then I plug in again, and on mini-micro-screen, select Display and join with Hoyoki.

  • So I powered off @ night and unplug from Hoyoki and plug L5 to it’s supplied power adapter.
    Same issue. Enter encrypt PW and wait. Nothing. Screen usually goes from black to A dark grey the n the unlock is available. Such is not the case. I have to unplug power adapter from L5, Plug it back in again, and I can get to the desktop.

By the way; the Hoyoki Puri sells is not recognized by Puri L5.

Example: I unplugged from power adapter, took L5 for a drive. Went into foodery and turned phone on. Nothing. Removed and replaced battery (I leave the back off now for convenience). Then I can boot L5.

Weird eh! I have a re-flash coming up - I’ll come back to this if it continues.


I had this issue. I had a spare battery and it happened to have about 50% charge.
I have purchased a battery charger and always keep my spare battery charged.

Which battery charger did you buy?

That is not a option here because, if I understand it correctly since Puri, and other companies cannot ship lithium batteries on their own and must be in a phone. My L5 is the life of the battery, or updates. :neutral_face:


For sale on ebay, shipping from China: librem 5 battery for sale | eBay

Confirm specs before ordering, as I see this one from a Canada seller that has different specs from the one in my L5:

3.8V 4400mAh 16.72Wh


3.8V 4500mAh 17.1Wh (as in my L5)

Earlier developer iterations of the L5 prior to release of the Evergreen version had different physical dimensions, but I don’t recall if the battery was different.

You might find some other sellers (who can ship to your location) if you search the internet a bit.

1 Like

It doesn’t have to be in a phone to ship; the order simply cannot be a battery on its own. I have ordered a spare battery in conjunction with other miscellaneous items in the store, and the package shipped just fine.

Edit: The item was shipped to me via US-based ground courier. However, I have had similar experiences when ordering from Olimex (based out of Bulgaria) via air freight.

And the rules for air shipment may be different from the rules for land shipment.

From a previous post,

Nov '22

I got this charger as recom by Quareno, i think
Nov '22

Thank you. I have ordered the charger from aliexpress. It is very reasonably priced.
The web site mentions that the charger is only for 3.8V LI ion batteries and not 4.2V,
but the order says I got 4.2V Universal Wall Travel Charger.
Bit of a worry as the Librem 5 battery says it is 3.8V