Phone dead after connecting a supported USB hub

I’ve bought a Baseus QTUR0JR6C1RP hub, as advised by the Purism wiki. I’ve tested it with my computer and with a Samsung Android phone - worked flawlessly, including charging and video. Used the Librem charger.

Then I connected it to the Librem 5. The phone turned itself off and I was not able to power it on again.

The phone responded to connecting a charging cable by lighting a red light, but no other signs of life.

What do I do now?

Your battery was probably very low charged

If I were you, I would try those (be attentive to the led behavior when powering ON):

  1. Charging the battery for 30 min, then without connection to power supply, I’ll push the power ON button for 30 sec

If it does not work

  1. Remove the battery, connect phone to power supply, power it ON, see what happens

If it does not work

  1. Contact (see How to properly send emails to Purism)

Thanks, it worked!

I did 1). Around 16 seconds when keeping the power button pressed, a green led lights up and there’s a vibration. 1-2 seconds later the led goes dark again. But when I tried powering on again, it worked OK!

1 Like

Did you retry with the hub ? working good ?

Yes, the hub is working okay now. Pretty impressive how good the video works over USB.