Phone is freezing up after few minutes of use

Phone goes completely unresponsive after few minutes of use. Only way to make it work is hold power button long or if that doesn’t work then remove and insert battery.

How can I debug (which log files) what is causing this?

I’ve evergreen with Byzantium

Did you switch on suspend? It’s an experimental feature and not recommended yet.

I’ve not, but I’m reading through Can't use L5 after update! and thinking of flashing the phone (still waiting to see if any other suggestions come along)

Check if suspend to ram it enabled, because when STR it enabled the system is crashing sometimes when go to deep sleep.

Would you mind pointing how do I check this? Simply through settings? Or should I be looking through terminal?

Also phone freezes while actively using it (just wanted to mention that since there is no suspend involved)

It is in settings - > battery -> suspend option.
In my case i do not experiencing freezes when i use it with the screen ON.

1 Like

Trying to check this before I flash, but haven’t been able to boot phone for last 3 or so hrs. If I can’t I may just flash and see.

As you wrote recently:

Originally installed pureos-store package conflicts with gnome-software. Did you replaced pureos-store anyway (for some reason of yours, but still not sure, as never tried that, if this might be related to your current issue)?

And, as another question, are outputs on your Librem 5:
apt list librem5-base -a and
apt list librem5-gnome-base -a

hopefully pointing out to: 48pureos1, as already installed ones?

Also not sure, but this freezing issue might easily be related to:

@librem5, please go over all other posts within the very same thread (I’m just too tired to do this right now).

Sorry will post in battery thread, started this since it seems different than battery.
but no I didn’t replace pureos-store with gnome-software. I’m currently trying to flash latest image.


today I updated my system with apt in a terminal. During the process the system froze completely and I had to reboot the L5. Normally when I use the terminal for updating I expect a short freeze XD

A short time after I played with suspend and calling. Afterwards I disabled suspend in the gnome settings and pressed the power button to lock the phone. Then I rang the phone twice to make sure that calls work. In the next step I tried to unlock the phone an recall, but then the L5 froze again…

I am sure: From time to time, the phone gets better and better :wink: Thank’s Purism :slight_smile: