Pinetime Smartwatch Setup Guide

I thought this would be the problem but I couldn’t find a setting to turn on Bluetooth anywhere on the watch.

Can you tell me how to turn on Bluetooth on the watch?

Swipe right from the watchface and you should see four tiles. The gear icon is Settings. If you select that, then Bluetooth will be on the third page. You’ll swipe up a couple of times to get there. If you select Bluetooth, you should have an option to enable, if it’s currently disabled.

So going through the settings on the PineTime I have the following options:

Page 1:
Display, Wake Up, Time Format, Watch Face

Page 2:
Steps, Battery, PTS Colors, Firmware (1.6.0)

Page 3:
About

There is no bluetooth option I can find. I’m guessing possibly a firmware update is needed? Is it possible to update the firmware without using bluetooth?

I have InfiniTime version 1.10 now and there is Bluetooth enable/disable setting above About setting entry. Settings
Dislay, Wake Up, Time format, Watch Faces
Steps, Set date, Set time, Battery
Chimes, Shake Calib., Firmware, Bluetooth
About

I have build InfiniTime GUI myself according to above instructions. I have been able to pait clock and it works with notification etc. But it has problems with reconnect and I have feeling that even SW stability on InfiniTime side is sometimes problem. So in general it works but it has some road to go to be really usable.

The best is to check connection from commandline. I connect to Librem 5 over ssh. Reach root and use bluetoothctl. You can select paired-devices from its commandline. You can try to remove and connect again remove C1:2D:31:54:49:77, scan on find InfiniTime MAC request the pairing

pair C1:2D:31:54:49:77

Then you asked to rewrite code from the watches to the prompt and watch are connected.

The same can be done from the Bluetooth setting in the Librem 5 GUI, but feedback and reliability from terminal seems to be better for me.

Then you return from root to purism account and you can restart itd daemon

purism@pureos:~$ systemctl --user stop itd
purism@pureos:~$ systemctl --user start itd

I have app entry added to the /usr/local/share/applications which allows me to start itd from Posh, because I do not want to run it by default to draw power etc.

@andy53 Sorry I hadn’t replied sooner. Between holidays and getting over a virus, I hadn’t spent much time in here. According to the documentation here, I didn’t see other alternatives beyond using a companion app, which would necessitate bluetooth. If you wanted, you could drop a question as an Issue and wait for a reply there. I was able to get responses in a fairly timely manner when I’ve done so.

So following up on this I have got the PineTime connected to my L5! The issue was that when it came to editing the operating mode line the file had 2 “dev_oper_mode=” set and I only changed one.

Once I had changed both I got connected without any issues.

2 Likes

works for me too! very neat to have the pine time work so seamlessly. I am using the companion app and updated the firmware without any issues. For such a ridiculously cheap watch i just couldnt help myself and try it and the infinitime software is very well designed.

Some things i notice, sometimes it has issues to reconnect to the phone. This could be an L5 bluetooth issue though. Also i was able to control over bluetooth the Shortwave radio app, pause play from my watch but it is finiky. When paused via the app, it cannot always be restarted with the watch, though that maybe a Shortwave app bug.

1 Like

Has anyone had any luck getting notifications from the L5 to the PineTime?

Yes, once InfiniTime Daemon is running any notifications on the Librem5 should be mirrored to the watch.

1 Like