Please list ways to make the L5 phone or phosh crash or hang

Description: i thought it would be nice for users to have one place to show and describe various ways and software steps taken to make the L5 or shell crash, reboot or fail to boot (when used normally and where expected behaviour would be that it works). List L5 model, phosh version and software version in question, Month-Year experienced.


Librem 5 evergreen, files 3.38.2, phosh 0.21.1 , Nov 2022:

  1. install sushi in gnome software center under files app,
  2. in default app select eye of gnome image viewer,
  3. in pictures folder select a dng image (enable double click in Files settings to open files),
  4. select space bar

A popup shows that app is requesting installation of additional extension (even though its already installed). This will wreak havoc on the shell and the notification cannot be dismissed or closed. Interactions now hang up. Trying the same with opening the image with raw therapee causes even more issues.

  1. turn off phone by holding power button for a while,
  2. turn on phone,
  3. phone boots,
  4. after Librem splash but before lockscreen is fully loaded press power button briefly

This will cause boot process to restart, showing Librem boot splash but wont successfully boot again until user pushes power button for a long time then again long enough to turn it back on.

I appreciate what you’re doing here, but this information would be better if it were reported on github.


@irvinewade can you translate this to me too? because i not undertanding. :thinking:

@Gavaudan think of it this way gitlab etc is only a good place to post it if it is actually an issue, all the users of the L5 are here, so if the crash, bug, hang doesnt occur for them, or they are forwarned by what NOT to do then everyone is better off and no issue report needs to be filed. Now if there is a way to trawl all gitlab repos for L5 related open crashes and someone can post the list here occasionally - every year or so then that would also work. i mostly want to focus on users here, but maybe give developers a fun way to quickly scroll through one coherent list. Also maybe these can be repurposed later on for developing regression type test cases once a sufficient list of items exists.


…or they’ll trigger a bug that’s not getting reported? I don’t follow the logic here. And if it doesn’t occur for everyone, how many does it need to occur to in order for it to be considered a reportable issue? Also I think a list of steps uses to test if an issue still exists or not is better suited in a place like gitlab.

This is coming across more confrontational than I mean it, so please don’t take it that way. Like I said, I appreciate what you’re trying to do, but I don’t know how helpful it will actually be.


Here is a list of known gitlab phoc crashes for example, L5 related, but i find it hard to parse.

List of open phoc crashes

Title,Description,Issue ID,URL,State,Author,Author Username,Assignee,Assignee Username,Confidential,Locked,Due Date,Created At (UTC),Updated At (UTC),Closed At (UTC),Milestone,Weight,Labels,Time Estimate,Time Spent
Crash in gles2_clear,"```
Stack trace of thread 9542:
#0 0x00007fcecc91a7bb __GI_raise (
#1 0x00007fcecc905535 __GI_abort (
#2 0x00007fcecc95c508 __libc_message (
#3 0x00007fcecc962c1a malloc_printerr (
#4 0x00007fcecc96442c _int_free (
#5 0x00007fcecac87bbd n/a (
#6 0x00007fcecac8a0b9 n/a (
#7 0x00007fcecac5a3be n/a (
#8 0x00007fcecac5d8f1 n/a (
#9 0x00007fcecac5db75 n/a (
#10 0x00007fcecac58cd1 n/a (
#11 0x00007fcecd115816 gles2_clear (
#12 0x0000561e9e4d5ed1 output_render (phoc)
#13 0x00007fcecd13f03c wlr_signal_emit_safe (
#14 0x00007fcecd13f03c wlr_signal_emit_safe (
#15 0x00007fcecd104440 page_flip_handler (
#16 0x00007fcecc7f0e65 drmHandleEvent (
#17 0x00007fcecd107655 handle_drm_event (
#18 0x00007fceccaf0b72 wl_event_loop_dispatch (
#19 0x0000561e9e4d36a7 wayland_event_source_dispatch (phoc)
#20 0x00007fceccd73f2e g_main_dispatch (
#21 0x00007fceccd741c8 g_main_context_iterate (
#22 0x00007fceccd744c2 g_main_loop_run (
#23 0x0000561e9e4cc8da main (phoc)
#24 0x00007fcecc90709b __libc_start_main (
#25 0x0000561e9e4cca6a _start (phoc)

This doesn't seem to trigger when running with ASAN.",23,,Open,Guido Gunther,guido.gunther,"","",No,No,,2019-06-11 13:30:39,2021-02-09 07:25:18,,,,crash,0,0
Crashes when virtual keyboard closes (wlr_keyboard_destroy),"There's a bug somewhere resulting in a bad unref of the keymap:

This happens when the virtual keyboard client crashes.

It's probably caused by the input method not attempting to send a keymap before going away.

Stack trace:

1 raise 0x7ffff750d57f
2 abort 0x7ffff74f7895
3 __libc_message 0x7ffff75509d7
4 malloc_printerr 0x7ffff75572ec
5 malloc_consolidate 0x7ffff7557534
6 _int_free 0x7ffff7558e9a
7 ?? 0x7ffff78ae8c6
8 xkb_context_unref 0x7ffff78aef8a
9 xkb_keymap_unref 0x7ffff78b08bb
10 wlr_keyboard_destroy wlr_keyboard.c 136 0x451d4b
11 wlr_input_device_destroy wlr_input_device.c 39 0x451105
12 virtual_keyboard_destroy_resource wlr_virtual_keyboard_v1.c 116 0x45f41d
13 ?? 0x7ffff79ef856
14 ?? 0x7ffff79f3c42
15 ?? 0x7ffff79f4183
16 wl_client_destroy 0x7ffff79ef9d1
17 ?? 0x7ffff79efaad
18 wl_event_loop_dispatch 0x7ffff79f12e2
19 wayland_event_source_dispatch main.c 47 0x4152b7
20 g_main_dispatch gmain.c 3182 0x7ffff7c7906d

Crash in rendering (wlr_egl_swap_buffers),"I'm not sure if this is phosh or Mesa, or something else. Anyway, what I did is run qemu, open kgx, connect via ssh a couple times, and run a couple of times. When killing it, this happened:

purism@pureos:~$ coredumpctl -1 debug
Hint: You are currently not seeing messages from other users and the system.
Users in groups ‘adm’, ‘systemd-journal’ can see all messages.
Pass -q to turn off this notice.
PID: 361 (phoc)
UID: 1000 (purism)
GID: 1000 (purism)
Signal: 11 (SEGV)
Timestamp: Wed 2019-09-18 11:36:00 UTC (52s ago)
Command Line: /usr/bin/phoc -C /usr/share/phosh/rootston.ini -E bash -lc ‘gnome-session --disable-acceleration-check --session=phosh’
Executable: /usr/bin/phoc
Control Group: /user.slice/user-1000.slice/session-1.scope
Unit: session-1.scope
Slice: user-1000.slice
Session: 1
Owner UID: 1000 (purism)
Boot ID: 1c7ff308b004432997919d96dbcbe5d6
Machine ID: 708e68dddc194663bf1ebaf795baad61
Hostname: pureos
Storage: /var/lib/systemd/coredump/core.phoc.1000.1c7ff308b004432997919d96dbcbe5d6.361.1568806560000000.lz4
Message: Process 361 (phoc) of user 1000 dumped core.

            Stack trace of thread 361:
            #0  0x00007f0b6ad7e454 n/a (n/a)
            #1  0x00007f0b6854c7f7 n/a (
            #2  0x00007f0b6854db79 n/a (
            #3  0x00007f0b6854bed5 n/a (
            #4  0x00007f0b6854c854 n/a (
            #5  0x00007f0b68557471 n/a (
            #6  0x00007f0b68557fa3 n/a (
            #7  0x00007f0b688d2faf n/a (
            #8  0x00007f0b684adaba n/a (
            #9  0x00007f0b6478b38d n/a (
            #10 0x00007f0b6477c8c6 eglSwapBuffers (
            #11 0x000055700c69ca00 wlr_egl_swap_buffers (phoc)
            #12 0x000055700c68f4a1 swap_drm_surface_buffers (phoc)
            #13 0x000055700c68d4cc drm_connector_commit (phoc)
            #14 0x000055700c6be6ee wlr_output_commit (phoc)
            #15 0x000055700c67b722 output_render (phoc)
            #16 0x000055700c6c95bc wlr_signal_emit_safe (phoc)
            #17 0x000055700c6c95bc wlr_signal_emit_safe (phoc)
            #18 0x000055700c68b64b page_flip_handler (phoc)
            #19 0x00007f0b6a6c7e65 drmHandleEvent (
            #20 0x000055700c68e955 handle_drm_event (phoc)
            #21 0x00007f0b6a7c4b72 wl_event_loop_dispatch (
            #22 0x000055700c678c17 wayland_event_source_dispatch (phoc)
            #23 0x00007f0b6aa47f2e g_main_dispatch (
            #24 0x00007f0b6aa481c8 g_main_context_iterate (
            #25 0x00007f0b6aa484c2 g_main_loop_run (
            #26 0x000055700c671a0f main (phoc)
            #27 0x00007f0b6a2e009b __libc_start_main (
            #28 0x000055700c671baa _start (phoc)
            Stack trace of thread 411:
            #0  0x00007f0b6a3aa819 __poll (
            #1  0x00007f0b6aa48136 g_main_context_poll (
            #2  0x00007f0b6aa4825c g_main_context_iteration (
            #3  0x00007f0b6aa482a1 glib_worker_main (
            #4  0x00007f0b6aa70415 g_thread_proxy (
            #5  0x00007f0b69ba5fa3 start_thread (
            #6  0x00007f0b6a3b54cf __clone (
            Stack trace of thread 412:
            #0  0x00007f0b6a3aa819 __poll (
            #1  0x00007f0b6aa48136 g_main_context_poll (
            #2  0x00007f0b6aa4825c g_main_context_iteration (
            #3  0x00007f0b644bdffd n/a (
            #4  0x00007f0b6aa70415 g_thread_proxy (
            #5  0x00007f0b69ba5fa3 start_thread (
            #6  0x00007f0b6a3b54cf __clone (
            Stack trace of thread 413:
            #0  0x00007f0b6a3aa819 __poll (
            #1  0x00007f0b6aa48136 g_main_context_poll (
            #2  0x00007f0b6aa484c2 g_main_loop_run (
            #3  0x00007f0b6ac740d6 gdbus_shared_thread_func (
            #4  0x00007f0b6aa70415 g_thread_proxy (
            #5  0x00007f0b69ba5fa3 start_thread (
            #6  0x00007f0b6a3b54cf __clone (

GNU gdb (Debian 8.2.1-2+b1) 8.2.1

Crash in zwlr_output_mode_send_size,"phoc crashed on phosh startup like

#0 0x0000562cb6bdadfe in zwlr_output_mode_v1_send_size (height=, width=, resource_=0x562cb79832e0) at subprojects/wlroots/protocol/wlr-output-management-unstable-v1-protocol.h:546

warning: Source file is more recent than executable.
546 wl_resource_post_event(resource_, ZWLR_OUTPUT_MODE_V1_SIZE, width, height);
[Current thread is 1 (Thread 0x7f19fa43d4c0 (LWP 2081))]
(gdb) bt
#0 0x0000562cb6bdadfe in zwlr_output_mode_v1_send_size (height=, width=, resource_=0x562cb79832e0) at subprojects/wlroots/protocol/wlr-output-management-unstable-v1-protocol.h:546
#1 0x0000562cb6bdadfe in send_mode_state (mode_resource=mode_resource@entry=0x562cb79832e0, mode=mode@entry=0x111c1f0) at …/subprojects/wlroots/types/wlr_output_management_v1.c:639
#2 0x0000562cb6bdb02b in head_send_mode (head=head@entry=0x562cb79740c0, head_resource=head_resource@entry=0x562cb797c6c0, mode=mode@entry=0x111c1f0)
at …/subprojects/wlroots/types/wlr_output_management_v1.c:669
#3 0x0000562cb6bdbb9e in manager_send_head (head=head@entry=0x562cb79740c0, manager_resource=manager_resource@entry=0x562cb791a430, manager=0x562cb7457150)
at …/subprojects/wlroots/types/wlr_output_management_v1.c:765
#4 0x0000562cb6bdbc63 in manager_bind (client=, data=0x562cb7457150, version=, id=) at …/subprojects/wlroots/types/wlr_output_management_v1.c:578
#5 0x00007f19fc980ccd in () at /usr/lib/x86_64-linux-gnu/
#6 0x00007f19fc98025a in () at /usr/lib/x86_64-linux-gnu/
#7 0x00007f19fd1c1380 in wl_closure_invoke (closure=0x562cb75b1640, flags=2, target=, opcode=0, data=) at …/src/connection.c:1018
#8 0x00007f19fd1bd7f2 in wl_client_connection_data (fd=, mask=, data=0x562cb7b02c20) at …/src/wayland-server.c:432
#9 0x00007f19fd1bf402 in wl_event_loop_dispatch (loop=0x562cb72892e0, timeout=timeout@entry=0) at …/src/event-loop.c:1027
#10 0x0000562cb6b99f87 in wayland_event_source_dispatch (base=, callback=, data=) at …/src/server.c:42
#11 0x00007f19fd447f1d in g_main_dispatch (context=0x562cb743f230) at …/…/…/glib/gmain.c:3179
#12 0x00007f19fd447f1d in g_main_context_dispatch (context=context@entry=0x562cb743f230) at …/…/…/glib/gmain.c:3844
#13 0x00007f19fd4481a0 in g_main_context_iterate (context=0x562cb743f230, block=block@entry=1, dispatch=dispatch@entry=1, self=) at …/…/…/glib/gmain.c:3917
#14 0x00007f19fd448473 in g_main_loop_run (loop=0x562cb7642840) at …/…/…/glib/gmain.c:4111
#15 0x0000562cb6b99d1d in main (argc=, argv=) at …/src/main.c:96

Crash on monitor unplug (layer-shell handle_unmap),"While debugging a phosh crash i got this phoc crash on monitor unplug:

(gdb) bt
#0 0x00007fa94a9c6c67 in wl_list_remove (elm=elm@entry=0x55b90d834cb8) at …/src/wayland-util.c:55
#1 0x000055b90b24cfa4 in handle_unmap (listener=0x55b90d834c58, data=) at …/src/layer_shell.c:734
#2 0x000055b90b298ecc in wlr_signal_emit_safe (signal=signal@entry=0x55b90d8105c8, data=data@entry=0x55b90d810490) at …/subprojects/wlroots/util/signal.c:29
#3 0x000055b90b287ab1 in layer_surface_unmap (surface=surface@entry=0x55b90d810490) at …/subprojects/wlroots/types/wlr_layer_shell_v1.c:206
#4 0x000055b90b28834d in wlr_layer_surface_v1_close (surface=0x55b90d810490) at …/subprojects/wlroots/types/wlr_layer_shell_v1.c:294
#5 0x000055b90b298ecc in wlr_signal_emit_safe (signal=signal@entry=0x55b90d0ba6f8, data=data@entry=0x55b90d0ba4d0) at …/subprojects/wlroots/util/signal.c:29
#6 0x000055b90b260450 in drm_connector_cleanup (conn=conn@entry=0x55b90d0ba4d0) at …/subprojects/wlroots/backend/drm/drm.c:1655
#7 0x000055b90b260c68 in scan_drm_connectors (drm=) at …/subprojects/wlroots/backend/drm/drm.c:1455
#8 0x000055b90b298ecc in wlr_signal_emit_safe (signal=, data=data@entry=0x55b90c9c60b0) at …/subprojects/wlroots/util/signal.c:29
#9 0x000055b90b26cc3f in udev_event (fd=, mask=, data=0x55b90c9c60b0) at …/subprojects/wlroots/backend/session/session.c:52
#10 0x00007fa94a9c4402 in wl_event_loop_dispatch (loop=0x55b90c9be400, timeout=timeout@entry=0) at …/src/event-loop.c:1027
#11 0x000055b90b2470f7 in wayland_event_source_dispatch (base=, callback=, data=) at …/src/server.c:42
#12 0x00007fa94ac5f5fd in g_main_dispatch (context=0x55b90d09d490) at …/…/…/glib/gmain.c:3309
#13 g_main_context_dispatch (context=context@entry=0x55b90d09d490) at …/…/…/glib/gmain.c:3974
#14 0x00007fa94ac5f880 in g_main_context_iterate (context=0x55b90d09d490, block=block@entry=1, dispatch=dispatch@entry=1, self=) at …/…/…/glib/gmain.c:4047
#15 0x00007fa94ac5fb53 in g_main_loop_run (loop=0x55b90d09d5b0) at …/…/…/glib/gmain.c:4241
#16 0x000055b90b246e4c in main (argc=, argv=) at …/src/main.c:137

all of the shell surfaces where on the unplugged screen (this was on intel,shell unlocked).",155,,Open,Guido Gunther,guido.gunther,Sebastian Krzyszkowiak,sebastian.krzyszkowiak,No,No,,2020-09-15 13:55:27,2021-02-09 07:54:14,,,,"convergence,crash",0,0
Crash in reset_xdg_surface,"Also a malloc corruption:

(gdb) bt
#0 __GI_raise (sig=sig@entry=6) at …/sysdeps/unix/sysv/linux/raise.c:50
#1 0x0000ffffbb4c3ea0 in __GI_abort () at abort.c:79
#2 0x0000ffffbb511280 in __libc_message (action=action@entry=do_abort, fmt=fmt@entry=0xffffbb5d5000 “”%s\n"") at …/sysdeps/posix/libc_fatal.c:155
#3 0x0000ffffbb5187dc in malloc_printerr (str=str@entry=0xffffbb5d0be0 ““free(): invalid next size (normal)””) at malloc.c:5347
#4 0x0000ffffbb519afc in _int_free (av=0xffffbb610a98 <main_arena>, p=0xaaaaf12a4d90, have_lock=) at malloc.c:4322
#5 0x0000ffffbb6ed54c in reset_xdg_surface (xdg_surface=0xaaaaf13cb8e0) at …/types/xdg_shell/wlr_xdg_surface.c:495
#6 0x0000ffffbb764080 in destroy_resource (element=element@entry=0xaaaaf11e3840, data=data@entry=0x0, flags=0) at …/src/wayland-server.c:724
#7 0x0000ffffbb7647bc in wl_resource_destroy (resource=0xaaaaf11e3840) at …/src/wayland-server.c:741
#8 0x0000ffffbb2d4048 in () at /lib/aarch64-linux-gnu/
#9 0x0000ffffbb2d3770 in () at /lib/aarch64-linux-gnu/
#10 0x0000ffffbb769a20 in wl_closure_invoke (closure=closure@entry=0xaaaaf0456660, flags=flags@entry=2, target=, opcode=0, data=, data@entry=0xaaaaf04d4e90)
at …/src/connection.c:1018
#11 0x0000ffffbb764d80 in wl_client_connection_data (fd=, mask=, data=0xaaaaf04d4e90) at …/src/wayland-server.c:432
#12 0x0000ffffbb767a68 in wl_event_loop_dispatch (loop=0xaaaaf044e800, timeout=) at …/src/event-loop.c:1027
#13 0x0000aaaae086cf8c in ()
#14 0x0000ffffbb974bc8 in g_main_dispatch (context=0xaaaaf0ab7d40) at …/…/…/glib/gmain.c:3325
#15 g_main_context_dispatch (context=0xaaaaf0ab7d40) at …/…/…/glib/gmain.c:4043
#16 0x0000ffffbb974e5c in g_main_context_iterate (context=0xaaaaf0ab7d40, block=block@entry=1, dispatch=dispatch@entry=1, self=) at …/…/…/glib/gmain.c:4119
#17 0x0000ffffbb9751b0 in g_main_loop_run (loop=0xaaaaf044e930) at …/…/…/glib/gmain.c:4317
#18 0x0000aaaae086cca4 in ()
#19 0x0000ffffbb4c4218 in __libc_start_main (main=0xaaaae086ca90, argc=5, argv=0xffffe71b5ab8, init=, fini=, rtld_fini=, stack_end=)
at …/csu/libc-start.c:308
#20 0x0000aaaae086cd4c in ()

happened when swipe closing firefox.",205,,Open,Guido Gunther,guido.gunther,"","",No,No,,2021-03-05 16:05:41,2021-03-05 16:06:06,,,,"byzantium,crash",0,0
Byzantium - phoc 0.7.0 - SIGTRAP in infinite loop,"# What problem did you encounter

When starting my Librem5 VM, Phoc is crashing with :

Using host libthread_db library “”/lib/x86_64-linux-gnu/"".
Core was generated by `/usr/bin/phoc -C /usr/share/phosh/phoc.ini -E bash -lc ‘gnome-session --builtin’.
Program terminated with signal SIGTRAP, Trace/breakpoint trap.
#0 0x00007ff5595a0ca7 in g_log_structured_array () from /lib/x86_64-linux-gnu/
#0 0x00007ff5595a0ca7 in g_log_structured_array () at /lib/x86_64-linux-gnu/
#1 0x00007ff5595a10b5 in g_log_default_handler () at /lib/x86_64-linux-gnu/
#2 0x00007ff5595a1309 in g_logv () at /lib/x86_64-linux-gnu/
#3 0x00007ff5595a159f in g_log () at /lib/x86_64-linux-gnu/
#4 0x000056407d8c6522 in phoc_server_constructed (object=0x56407e0d3810) at …/src/server.c:152
#5 0x00007ff559690638 in () at /lib/x86_64-linux-gnu/
#6 0x00007ff559691b1d in g_object_new_with_properties () at /lib/x86_64-linux-gnu/
#7 0x00007ff5596925f1 in g_object_new () at /lib/x86_64-linux-gnu/
#8 0x000056407d8c67fd in phoc_server_get_default () at …/src/server.c:224
#9 0x000056407d8c5f29 in main (argc=, argv=) at …/src/main.c:131

And thats what I get when I do 'sudo coredumpctl list' :

Sat 2021-03-27 13:34:43 UTC 748 114 124 6 present /usr/bin/sddm-greeter
Sat 2021-03-27 13:34:44 UTC 524 1000 1000 11 present /usr/bin/phoc
Sat 2021-03-27 13:34:50 UTC 915 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:34:55 UTC 943 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:35:01 UTC 971 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:35:07 UTC 1000 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:35:13 UTC 1031 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:35:18 UTC 1058 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:35:24 UTC 1085 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:35:30 UTC 1112 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:35:36 UTC 1139 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:35:41 UTC 1166 1000 1000 5 present /usr/bin/phoc
Sat 2021-03-27 13:35:47 UTC 1193 1000 1000 5 present /usr/bin/phoc

Here some more details, for the crashes of sddm-greeter and phoc



## How to reproduce
Well I'm not sure how I got here, but March 25, I did :

sudo tasksel install desktop kde-desktop
sudo systemctl stop phosh
export WAYLAND_DISPLAY=wayland-0
startplasma-wayland --framebuffer --fb-device /dev/fb0 &#or fb1 to select the screen you want it on

plasmashell didn't went well, so then I restarted phosh

sudo systemctl start phosh

which worked, then I stopped the VM and restarted it 2 days later

# What hardware are you running phosh on?

 - [X] amd64 qemu image

I'm using the librem5.qcow2 (PureOS 10.0 byzantium) in kvm",210,,Open,fralb5,fralb5,"","",No,No,,2021-03-27 14:00:48,2021-03-31 12:18:20,,,,,0,0
Crash when going to single display mode,"got this crash when going from joined display to single display of builtin output:

#0 output_layout_output_get_box (l_output=0x0) at …/types/wlr_output_layout.c:79
#1 wlr_output_layout_contains_point (layout=, reference=, lx=270, ly=548) at …/types/wlr_output_layout.c:239
#2 0x0000aaaadad61e74 in roots_cursor_handle_touch_down (cursor=, event=) at …/src/cursor.c:522
#3 0x0000ffffa86c1c6c in wlr_signal_emit_safe (signal=, data=0xffffdbd7a838) at …/util/signal.c:29
#4 0x0000ffffa86c1c6c in wlr_signal_emit_safe (signal=, data=data@entry=0xffffdbd7a838) at …/util/signal.c:29
#5 0x0000ffffa868b82c in handle_touch_down (event=event@entry=0xaaaafd9a9860, libinput_dev=) at …/backend/libinput/touch.c:40
#6 0x0000ffffa8687f04 in handle_libinput_event (backend=backend@entry=0xaaaafd39fe30, event=event@entry=0xaaaafd9a9860) at …/backend/libinput/events.c:252
#7 0x0000ffffa86876dc in handle_libinput_readable (fd=, mask=, _backend=0xaaaafd39fe30) at …/backend/libinput/backend.c:41
#8 0x0000ffffa871ba68 in wl_event_loop_dispatch (loop=0xaaaafcd2df60, timeout=timeout@entry=0) at …/src/event-loop.c:1027
#9 0x0000aaaadad4cf7c in wayland_event_source_dispatch (base=, callback=, data=) at …/src/server.c:42
#10 0x0000ffffa895fbc8 in g_main_dispatch (context=0xaaaafd388ae0) at …/…/…/glib/gmain.c:3325
#11 g_main_context_dispatch (context=0xaaaafd388ae0) at …/…/…/glib/gmain.c:4043
#12 0x0000ffffa895fe5c in g_main_context_iterate (context=0xaaaafd388ae0, block=block@entry=1, dispatch=dispatch@entry=1, self=) at …/…/…/glib/gmain.c:4119
#13 0x0000ffffa89601b0 in g_main_loop_run (loop=loop@entry=0xaaaafcd2e960) at …/…/…/glib/gmain.c:4317
#14 0x0000aaaadad4cc94 in main (argc=, argv=) at …/src/main.c:137

Byzantium - phoc 0.7.0 crash with small diagnosis,"I'm able to crash phoc 0.7.0 on regular use, with my software having bad behaviors, and with this specific backtrace:

[Thread debugging using libthread_db enabled]
Using host libthread_db library “”/lib/x86_64-linux-gnu/"".
Core was generated by `/usr/bin/phoc -C /usr/share/phosh/phoc.ini -E bash -lc ‘gnome-session --builtin’.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f335f904490 in wl_event_loop_dispatch (loop=0x55ef803cd000, timeout=timeout@entry=0) at …/src/event-loop.c:1027
[Current thread is 1 (Thread 0x7f335b650f40 (LWP 508))]
#0 0x00007f335f904490 in wl_event_loop_dispatch (loop=0x55ef803cd000, timeout=timeout@entry=0) at …/src/event-loop.c:1027
#1 0x000055ef80229277 in wayland_event_source_dispatch (base=, callback=, data=) at …/src/server.c:42
#2 0x00007f335fba3e6b in g_main_context_dispatch () at /lib/x86_64-linux-gnu/
#3 0x00007f335fba4118 in () at /lib/x86_64-linux-gnu/
#4 0x00007f335fba440b in g_main_loop_run () at /lib/x86_64-linux-gnu/
#5 0x000055ef80228fcc in main (argc=, argv=) at …/src/main.c:137

I have already seen this crash with the previous version, so I decided to clone the wayland project (HEAD on commit d224e6c, after tag 1.19.0) and tried to find out why it crash at the line 1027 of the src/event-loop.c file

            if (source->fd != -1)  {
                    source->interface->dispatch(source, &ep[i]);

I added those traces

           if (source->fd != -1)  {
              fd = open( ""/log/server.log"" , O_CREAT | O_RDWR );
              if( fd > 0 ) {
                dprintf( fd, ""[%d/%d] source : '%p'\n"", i, count, source );
                dprintf( fd, "" - : '%u'\n"", ep[i].events );
                dprintf( fd, "" - : '%p'\n"", ep[i].data.ptr );
                dprintf( fd, "" - : '%d'\n"", ep[i].data.fd );
                dprintf( fd, "" - : '%u'\n"", ep[i].data.u32 );
                dprintf( fd, "" - : '%lu'\n"",  ep[i].data.u64 );
                dprintf( fd, "" - source->interface : '%p'\n"", source->interface );
                dprintf( fd, "" - source->interface->dispatch : '%p'\n"", source->interface->dispatch );
                close( fd );
                    source->interface->dispatch(source, &ep[i]);

After compilation and while in use, I get this kind of output when everything is OK

[0/1] source : ‘0x564d90983690’

  • : ‘1’
  • : ‘0x564d90983690’
  • : ‘-1869072752’
  • : ‘2425894544’
  • : ‘94891138365072’
  • source->interface : ‘0x7f2b977b9650’
  • source->interface->dispatch : ‘0x7f2b977ad580’

And this kind of output, when I made it crash again

[0/4] source : ‘0x560b34f54e00’

  • : ‘17’
  • : ‘0x560b34f54e00’
  • : ‘888491520’
  • : ‘888491520’
  • : ‘94606133120512’
  • source->interface : ‘0x560b3518d210’
  • source->interface->dispatch : ‘0x30’

So it seems somewhere ( EPOLLIN | EPOLLHUP ) is put to, and source->interface (not same range of address) or source->interface->dispatch is set with an invalid value",213,,Open,fralb5,fralb5,"","",No,No,,2021-03-31 12:11:35,2021-04-11 11:02:11,,,,,0,0

no offense taken and i do post bug reports in gitlab, lets just see if anything good comes of this idea.


Which post were you looking to have translated?

Here: Please list ways to make the L5 phone or phosh crash or hang.
I mean i not sure what Captain_Morgan want to do. :joy:

I think subsequent discussion has covered that. Maybe the topic itself will crash or hang. :wink: Maybe not.

Hopefully people are smart enough to limit this to things that require significant user interaction, so that the crash or hang can’t be caused e.g. remotely with little to no user interaction.


Found another way:

  1. install and run bleachbit (as root)
  2. select system option (including cache, memory, free diskspace, temporary files)
  3. select deep_scan option (temporary files, vimswap)
  4. run clean and ignore all warnings, make sure to use wipe option

For me bleachbit not only crashed pureos10 but it would not boot afterwards and had to reflash the phone.

Ok one more way to crash the linux os but in this case it will recover:

  1. sudo journalctl stop systemd-journald.socket
  2. sudo journalctl stop systemd-journald.audit.socket
  3. sudo journalctl stop systemd-dev-log.socket

Repeat with sudo journalctl disable for each until all are disabled.

sudo systemctl status systemd-journald

should show them as disabled one by one. Once all three services are disabled the OS will crash and phone will reboot after which all services are enabled again so changes dont persist. It indicates logging is required by pureos or certain system components.

Along the same lines when i decrease the log file quantity to one, 1KB size, flush the logs, rotate logs and make sure changes are saved in the journald.conf file and when keeping logs a maximum of 1second then after restarting logging and/or rebooting the L5 with pureos 10 the system behaves oddly.

For example with experimental suspend enabled, phone doesnt wake on pushing the power button after phone has suspended (screen backlight would not even power up). Or when pushing the power button oddly enough it crashes and reboots. As if its trying to dump something to a log file but the file is limited and it panics.

This wouldnt by any chance related to disabling the gnome screensaver support function?