Podasts Lost Dark Mode

I’ve seen lots of flatpak updates to Podcasts lately. Pretty sure those updates were coming to my Mint PCs, Armbian laptop and the L5, but I could be wrong about the L5. What I remember for sure is that dark mode has been working for a long time (at least with GTK apps). This morning, I finish a podcast but I can’t go to the next one because the app froze. Couldn’t flick it away with Phosh and couldn’t kill it from Usage. I figure it’s been many days since a reboot, so I go that way… but the phone freezes on shutdown. It takes a battery extraction to get it to start… and when it does, no dark mode in Podcasts! Other GTK apps are OK, but Podcasts is blindingly WHITE (disaster).

I re-applied dark mode (gsettings method), but no joy.

Is this happening to anyone else?

1 Like

No, but I do not use Podcasts. Did you use these two commands?

Yes, the very same commands. I am running Byzantium.

1 Like

Okay, try uninstalling and reinstalling the app to see if that solves the issue.

I exported my feeds, but haven’t reinstalled yet because I noticed that I had gotten a error when trying to reapply dark mode!

1 Like

Use the command without sudo.

No sudo, no error… no dark mode.

Uninstalled Podcasts.

Tried to reinstall from PureOS, got error “directory not empty”.

Flatsweep cleaned Podcasts and tons of other trash – recovered almost 5GB!

Reinstall success, but no dark mode.

Uninstall… reinstall from FlatHub, no dark mode. Also no desktop launcher! At least the feeds import worked. :roll_eyes:

Interesting exercise, but I don’t look forward manually rebuilding the launcher. Maybe it won’t be so bad if I plug into the convergence adapter first.

1 Like

Maybe it helps to use Flatseal to set the dark mode for the app?

In Flatseal go to Podcasts > Environment > Variables and add GTK_THEME=Adwaita-dark.

(It worked for me with other (GTK4) apps)


Dude… you ROCK!

I only ever used Flatseal for security settings – had no idea it could do this. Gotta use this trick on my laptop/desktop. Thanks!

1 Like

I have to say, it’s been a while since I took a hard look at Flatseal. Found the “All Applications” global setting, now all GTK flatpaks are dark!

1 Like