Possibly defective μSD reader ? Impossible to write or see parittions


I just got a Librem 5 evergreen from someone who didn’t want their anymore, and i’ve been setting it up for the past couple days.
However, i noticed that i’m unable write to sdcards with it (tried two different cards, both work fine on my pc but don’t function on my librem).

To be more specific, i can actually see the total storage of the sdcard (in this case 64GB), but the partition type is “Unknown” despite being FAT32.

Due to this, i’ve been trying to format it to no avail using the “Disks” :
Error Formatting Disk
Error wiping device: Failed to probe the device ‘/dev/sda’ (udisks-error-quark, 0)

Fdisk doesn’t show /dev/sda but lsblk does, dmesg gives the following output regarding the sdcard
critical medium error, dev sda, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 2
Buffer I/O error on dev sda, logical block 0, async page read

I don’t remember what other tool i used, but i also got an I/O error there.

Attempting to dd the card with 0’s “sounds” like it works, but every file is still intact when i plug the card back on the pc.

I’m currently running on the latest version of PureOS (reflashed it a day ago) and everything is updated+upgraded.

Anyone could have an idea regarding what i might have missed ?
I hope it’s not a defective reader, though i’m hoping for the worst.

This is my first time posting here, hopefully i’m not violating any guidelines :slight_smile:

Thanks for your attention, hopefully you have an idea to sort this issue out…

1 Like

Format externally ext4 format

first try something like sd-card-formatter linux tool which will format it in exFat

sudo ./format_sd --help

Then use disk to format in ext4 and create partition and volume on it.

1 Like

Getting the uSD card and the SIM card in the tray correctly can be fiddly. Are you sure that you have things arranged correctly, oriented correctly, and not loose? (Do you even have a SIM card installed?)

Assuming that there’s no useful content on the existing cards, I would use gparted on another computer to format the uSD card to ext4.

Reputable brand of uSD card? From reputable supplier?

With uSD card inserted, …

Post output of: ls -l /dev/sd*

Assuming that /dev/sda is listed, post output of

sudo od -A x -t x1 -N 512 /dev/sda

(dump the contents of the MBR)

1 Like

Thanks for the replies !

Formatting the card to ext4 from another pc didn’t help, and it’s a 512GB official sandisk extreme pro.

I don’t have a simcard installed, and i assume everything should be inserted properly since i can read the storage of the card itself :confused:

After running the commands you gave me, i get the following output :
root@x49:~# ls -l /dev/sd*
brw-rw---- 1 root disk 8, 0 May 11 14:08 /dev/sda
root@x49:~# od -A x -t x1 -N 512 /dev/sda
od: /dev/sda: read error: Input/output error

That doesn’t look too good to me…

for the librem 5 isnt 128GB the max it can handle via sd port? Oh never mind it states 2TB max somehow i thought it was less.

BTW i am using thin tape on the other side of my SD Card because it couldnt recognize it any longer. It was just the connector pins not fully engaging depending on card thickness and variations of.

1 Like

Thin tape ?
Mine still recognises the card, but i could always give that a try…
I’ll give an update once i have enough time to get that done :slight_smile:

Just tried, same thing, card detected by the system and it knows the size of it, but the partition is seen as “Unknown” :confused:

I only put one layer of tape though, but i folded the tape where the connectors are so it bumps them up slightly more.

1 Like

For the record, nope. I have a 512 GB uSD card in my Librem 5 and it works fine.

OK, what’s the other card? (make and model, you already mentioned 64 GB)

No, it does not.

Until you can get that od command to dump out the MBR (the first 512B block of the device) successfully, it isn’t going to give you anything other than “unknown partition type” (since it can’t even read the MBR to get the list of partitions, and each partition entry says what type it is).

At this stage, I’m thinking it’s either
a) poor contact with the connectors (as @Captain_Morgan suggests) - so do persevere with that, or
b) card incompatibility - this does happen - I ordered an SD card for a device completely unrelated to the Librem 5 and the card worked fine on my PC (tested exhaustively) but didn’t work when inserted into the actual target device (I returned the SD card, ordered a slightly different model, and the second SD card worked fine - c’est la vie).

For the second possibility, do you have any other uSD cards lying around?

1 Like

I tried 3 cards on the librem 5 :

  • One official 16gb sandisk (one of the black ones) card
  • One noname chinese 64gb card
  • The one i have right now, the 512gb sandisk extreme pro card.

I do own other cards, so i’ll definitely give it a try, but it’d be really annoying if i bought a 512gb extreme card thats doesnt work with the librem :confused:

If that doesn’t work, i’ll try adding some more tape once i get home, hopefully that helps…

Thanks for the answers !

Hi again, here to give a couple updates…

Since then, i’ve tried moving the card some more and updating, but to no avail.

I’ve also noticed some more issues with the librem :confused:

When a simcard is inserted, it is possible to make calls, but sometimes it just doesn’t work (hangs up immediately).
It isn’t possible to use mobile data either, even though it does say “4G” on the top left corner, and i have an European modem.

Not only that, but i got a nexdock 360, and it doesnt work with the Librem either… The librem does detect the display, but the nexdock doesn’t do anything, even though it works fine with all my other devices.

Anyone having these issues ? I’ll try to flash another OS or an older version in the meantime after i’m done backing up everything…

Have you been in contact with support@puri.sm about your issues?

1 Like

Not yet, but will do now :slight_smile:

Apparently, the SD reader might be fried because i hotswapped an sdcard once before learning you weren’t supposed to do that, ouch…
Also, somewhat unrelated, but i’m unable to upgrade the Librem to a sparklan card despite installing the firmware jail in https://source.puri.sm/Librem5/librem5-fw-jail
(wlan0 still not showing).

That’s unfortunate, but indeed a No No.

Sorry, but I can’t help you with that. My Sparklan card is still lying in my drawer and I’m very reluctant to swap it.
Maybe some else here can help you with that issue.

1 Like

Managed to figure that out, turns out the firmware i got was corrupted for some reason…
Getting another one that was linked in the forums worked right away with the fw jail, and now my card is active :smiley:

Waiting for an answer from support regarding my fried microsd reader for now, hopefully we can figure something out, as i haven’t seen a motherboard replacement for the librem 5 being sold in the online store.


There is a known-fix for phones with this issue. If your device is still under warranty then support can help you with getting it working again.

1 Like