Post-upgrade to 3.0, packages not installable


After upgrading to pureos 3.0 alpha (or beta or whatever the current state is) as per the blog instructions, I find I can’t install some packages. So far I’ve seen this with gnucash and clusterssh. In both cases the symptoms are similar.

gnucash depends on libfinance-quote-perl which depends on libdatetime-perl, but libdatetime-perl depends on perlapi-5.22.2.
clusterssh depends on perl-tk, but perl-tk depends on perlapi-5.22.1.

I have perl (and perl-base and perl-modules etc) 5.24.1.

Is there a plan to reconstruct the perl module packages against 5.24? Is there some other good option for getting these packages installed?



Hi Bret!

Have you tried downgrading perl to 5.24? Did you use any other repo besides PureOS’s?

I only have the PureOS repo. The only perl versions I see in the PureOS repo are 5.22.2 and 5.24.1. A lot of PureOS expects and depends on 5.24; other packages, like perl-tk and libdatetime-perl, depend on 5.22.

It does not seem to to work to have both perl 5.22 and 5.24 installed simultaneously.

It seems to me as though the only way to resolve this cleanly is to rebuild the debian packages that currently depend on 5.22 so that they instead depend on 5.24. I’m still curious whether there are plans to do that!

I guess I can grab the sources from the PureOS repo and build new deb files from them … it would help if there were instructions on how to do that, though!

I’ll see what’s wrong with our repo and report back.

FWIW, I was able to work around my issue by fetching the debian sources for, and dpkg-buildpackage’ing, the following packages that depend on perl 5.22:

libdatetime-perl libdevel-caller-perl libdevel-lexalias-perl libpadwalker-perl libparams-util-perl perl-tk



Did you encounter any issues with the custom-built packages?

No, they are all working fine. The only visible sign that I have custom-built packages installed is that they all appear in the “the following packages have been kept back” section when I run “apt-get upgrade”.

Thanks for the follow-up!

I’ve just got an explanation from our team that this is fixed, fixed packages should be in repo in a few days.

Just checked, it works fine on my side. There was issue with migration but if you have an up-to-date system you shouldn’t have any problem.