Preventing systemd from writing its status every second to console


#1

During debugging a startup issue I started using systemd debug shell. The shell would be a lot more useful if systemd wouldn’t write its status about units to console, because the output disturbs the output of commands in the debug shell.

Especially the update of the time while waiting for a unit to finish (which is written every second) I found really annoying.

I searched for a way to disable this output or even better have it only printed every x seconds, but didn’t find anything.

Also scrolling back in console while startup is impossible, because with every update it jumps back to the end.


#2

Maybe try /etc/systemd/system.conf

LogTarget=null

or other less brutal choices of log target.

Or, presumably equivalently, kernel command line systemd.log_target=null

Looks as if you can use signals to change the setting on the fly, which may be a more sophisticated approach.


#3

Thanks for pointing me in that direction - it looked promising. But it didn’t work.

My kernel command line contained systemd.log_target=journal systemd.default_standard_output=journal systemd.default_standard_error=journal nosplash noresume loglevel=7 systemd.debug-shell for testing, but it didn’t change the behaviour.

Here’s a screenshot of tty1:

And here’s one that shows the debug console of systemd on tty9:

One can see that the status of the waiting unit (swap that does not work) is still disturbing the use of the debug shell.

So I’m still looking for a solution…