Printer HP Laserjet P1006 does not react


#1

My HP Laserjet P1006 printer was identified and installed automatically in the printers menu and I set as default.

However, I press print testpage or try to print a document in libre office and nothing happens.

I get a message that print was completed but the printer does nothing. The printer runs on Windows laptop without any issues.

I run the error journal and the following lines seem to be related. Any advise what to do and run the printer would be much appriciated.

Jan 22 22:06:23 laptop /hpfax[3703]: [3703]: error: Failed to create /var/spool/cups/tmp/.hplip
Jan 22 22:08:00 laptop systemd[1550]: Failed to start Tracker metadata database store and lookup manager.
Jan 22 22:19:51 laptop /hp-config_usb_printer[4486]: hp-config_usb_printer[4486]: error: hp-systray must be running. Run ‘hp-systray &’ in a terminal.
Jan 22 22:19:51 laptop /hp-config_usb_printer[4486]: hp-config_usb_printer[4486]: error: HP Device plugin’s are not installed. Please install plugin’s using hp-plugin command.
Jan 22 22:19:55 laptop /hp-firmware[4491]: [4491]: error: Firmware file ‘/usr/share/hplip/data/firmware/hp_laserjet_p1006.fw.gz’ not found.
Jan 22 22:19:55 laptop /hp-firmware[4491]: hp-firmware[4491]: error: Firmware download failed.


#2

Try to install this open-source driver:
http://foo2xqx.rkkda.com/


#3

If you don’t want compile this driver, you can try “printer-driver-foo2zjs” package. But official site says:


I compiled this driver and it works fine for my HP printer, but i find this package today and don’t tried it yet.